aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-09-28 05:58:31 +0800
committerjbeich <jbeich@FreeBSD.org>2015-09-28 05:58:31 +0800
commit2e9ce53e631bfcedce66dead87240562571b23ed (patch)
tree1cb198fc157b8a938097742ffabded9c505a8113 /devel
parentd3f368beabebdebe6faa86f06f352797d8b22dca (diff)
downloadfreebsd-ports-graphics-2e9ce53e631bfcedce66dead87240562571b23ed.tar.gz
freebsd-ports-graphics-2e9ce53e631bfcedce66dead87240562571b23ed.tar.zst
freebsd-ports-graphics-2e9ce53e631bfcedce66dead87240562571b23ed.zip
devel/boost-*: convert to more option helpers
Approved by: office (truckman, bapt) (maintainer) Differential Revision: https://reviews.freebsd.org/D3739
Diffstat (limited to 'devel')
-rw-r--r--devel/boost-all/compiled.mk17
-rw-r--r--devel/boost-libs/Makefile10
-rw-r--r--devel/boost-python-libs/Makefile2
3 files changed, 8 insertions, 21 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index 02a3d85bf92..a38eb91b78c 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -8,8 +8,6 @@ PLIST_SUB+= BOOST_SHARED_LIB_VER=${PORTVERSION} COMPAT_LIB_VER=5
PKG_MESSAGE_FILE_THREADS= ${PORTSDIR}/devel/boost-all/pkg-message.threads
PKG_MESSAGE_FILE_PYTHON= ${PORTSDIR}/devel/boost-all/pkg-message.python
-.include <bsd.port.pre.mk>
-
BJAM_ARGS= --layout=system \
--prefix=${PREFIX} \
@@ -23,23 +21,16 @@ BOOST_TOOLSET= ${CHOSEN_COMPILER_TYPE}
BJAM_ARGS+= --toolset=${BOOST_TOOLSET} \
${_MAKE_JOBS}
-.if ${PORT_OPTIONS:MVERBOSE_BUILD}
-BJAM_ARGS+= -d2
-.endif
+VERBOSE_BUILD_VARS= BJAM_ARGS+=-d2
-.if ${PORT_OPTIONS:MDEBUG}
-BJAM_ARGS+= debug
-.else
-BJAM_ARGS+= release
-.endif
+DEBUG_VARS= BJAM_ARGS+=debug
+DEBUG_VARS_OFF= BJAM_ARGS+=release
BJAM_ARGS+= threading=multi \
link=shared,static
BJAM_ARGS+= optimization=speed
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-BJAM_ARGS+= inlining=full
-.endif
+OPTIMIZED_CFLAGS_VARS= BJAM_ARGS+=inlining=full
# ccache build fails when using precompiled headers, on a cached build.
.if defined(WITH_CCACHE_BUILD)
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 9299ef984b6..dfda699d7b8 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -14,7 +14,9 @@ VERBOSE_BUILD_DESC= Show compiler messages
ICU_DESC= Boost.Regex with ICU unicode support
ICU_LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
+ICU_VARS= BJAM_ARGS+=-sICU_PATH=${LOCALBASE}
ICU_USES_OFF= iconv
+ICU_VARS_OFF= BJAM_ARGS+=-sICONV_PATH=${ICONV_PREFIX}
.include "${.CURDIR}/../boost-all/common.mk"
@@ -30,12 +32,6 @@ PLIST_SUB+= COROUTINE="@comment " CONTEXT="@comment " \
PLIST_SUB+= COROUTINE="" CONTEXT="" LOCALE="" LOG=""
.endif
-.if ${PORT_OPTIONS:MICU}
-BJAM_ARGS+= -sICU_PATH=${LOCALBASE}
-.else
-BJAM_ARGS+= -sICONV_PATH=${ICONV_PREFIX}
-.endif
-
do-build:
@cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_ARGS} stage
@@ -64,4 +60,4 @@ post-install:
-e "s|%%PYTHON_LIBDIR%%|${PYTHON_LIBDIR}|g" \
-e "s|%%PYTHON_VERSION%%|${PYTHON_VERSION}|g" ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/boost-python-libs/Makefile b/devel/boost-python-libs/Makefile
index cbdce88c2a1..e09d3c30a6b 100644
--- a/devel/boost-python-libs/Makefile
+++ b/devel/boost-python-libs/Makefile
@@ -49,4 +49,4 @@ post-install:
-e "s|%%PYTHON_LIBDIR%%|${PYTHON_LIBDIR}|g" \
-e "s|%%PYTHON_VERSION%%|${PYTHON_VERSION}|g" ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>