aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-14 02:36:10 +0800
committerpgj <pgj@FreeBSD.org>2011-08-14 02:36:10 +0800
commit32c9d55bc038c14f41dc85b68356a71e01849079 (patch)
treeaf55da193555b63da4eafbbca1fd470e157918de /devel
parentb6c867568ddd018b697b27a8ec43ecc94986abbf (diff)
downloadfreebsd-ports-graphics-32c9d55bc038c14f41dc85b68356a71e01849079.tar.gz
freebsd-ports-graphics-32c9d55bc038c14f41dc85b68356a71e01849079.tar.zst
freebsd-ports-graphics-32c9d55bc038c14f41dc85b68356a71e01849079.zip
A priority search queue efficiently supports the opperations of both a
search tree and a priority queue. A 'Binding' is a product of a key and a priority. Bindings can be inserted, deleted, modified and queried in logarithmic time, and the binding with the least priority can be retrieved in constant time. A queue can be built from a list of bindings, sorted by keys, in linear time. WWW: http://hackage.haskell.org/package/PSQueue Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-PSQueue/Makefile18
-rw-r--r--devel/hs-PSQueue/distinfo2
-rw-r--r--devel/hs-PSQueue/pkg-descr8
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5a5509df9a9..de2c8b04fe7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -566,6 +566,7 @@
SUBDIR += hs-MonadCatchIO-mtl
SUBDIR += hs-MonadCatchIO-transformers
SUBDIR += hs-ObjectName
+ SUBDIR += hs-PSQueue
SUBDIR += hs-QuickCheck
SUBDIR += hs-StateVar
SUBDIR += hs-Stream
diff --git a/devel/hs-PSQueue/Makefile b/devel/hs-PSQueue/Makefile
new file mode 100644
index 00000000000..89b4fa37767
--- /dev/null
+++ b/devel/hs-PSQueue/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: hs-PSQueue
+# Date created: September 20, 2010
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= PSQueue
+PORTVERSION= 1.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Priority Search Queue
+
+LICENSE= BSD
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-PSQueue/distinfo b/devel/hs-PSQueue/distinfo
new file mode 100644
index 00000000000..42f31babc8e
--- /dev/null
+++ b/devel/hs-PSQueue/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/PSQueue-1.1.tar.gz) = a8e0871ad10f916f55c3b9baec53eff23c4e97e09cf96d6c66771789e00a49cc
+SIZE (cabal/PSQueue-1.1.tar.gz) = 6280
diff --git a/devel/hs-PSQueue/pkg-descr b/devel/hs-PSQueue/pkg-descr
new file mode 100644
index 00000000000..a6481f342de
--- /dev/null
+++ b/devel/hs-PSQueue/pkg-descr
@@ -0,0 +1,8 @@
+A priority search queue efficiently supports the opperations of both a
+search tree and a priority queue. A 'Binding' is a product of a key and
+a priority. Bindings can be inserted, deleted, modified and queried in
+logarithmic time, and the binding with the least priority can be
+retrieved in constant time. A queue can be built from a list of
+bindings, sorted by keys, in linear time.
+
+WWW: http://hackage.haskell.org/package/PSQueue