aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-07-11 16:09:44 +0800
committerjylefort <jylefort@FreeBSD.org>2005-07-11 16:09:44 +0800
commit408036eede3996349a034c77f7dcdc61695821b1 (patch)
treea4959e7565dbb5fd8fa9d50301be50499be82217 /devel
parent2a6bdc4f6b09a8b159ba862abb678c5dee6db9bc (diff)
downloadfreebsd-ports-graphics-408036eede3996349a034c77f7dcdc61695821b1.tar.gz
freebsd-ports-graphics-408036eede3996349a034c77f7dcdc61695821b1.tar.zst
freebsd-ports-graphics-408036eede3996349a034c77f7dcdc61695821b1.zip
Add p5-Algorithm-Bucketizer.
Algorithm::Bucketizer distributes items of a defined size into a number of dynamically created buckets, each of them capable of holding items of a defined total size. WWW: http://search.cpan.org/search?dist=Algorithm-Bucketizer PR: ports/83064 Submitted by: Christopher Boumenot <boumenot@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Algorithm-Bucketizer/Makefile31
-rw-r--r--devel/p5-Algorithm-Bucketizer/distinfo2
-rw-r--r--devel/p5-Algorithm-Bucketizer/pkg-descr5
-rw-r--r--devel/p5-Algorithm-Bucketizer/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 16beefc3c35..14fa590cf07 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -645,6 +645,7 @@
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Accounting
SUBDIR += p5-Algorithm-Annotate
+ SUBDIR += p5-Algorithm-Bucketizer
SUBDIR += p5-Algorithm-ChooseSubsets
SUBDIR += p5-Algorithm-Cluster
SUBDIR += p5-Algorithm-Diff
diff --git a/devel/p5-Algorithm-Bucketizer/Makefile b/devel/p5-Algorithm-Bucketizer/Makefile
new file mode 100644
index 00000000000..173acdd59a0
--- /dev/null
+++ b/devel/p5-Algorithm-Bucketizer/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Algorithm-Bucketizer
+# Date created: 06 Jul 2005
+# Whom: Christopher Boumenot <boumenot@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Bucketizer
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= boumenot@gmail.com
+COMMENT= Distribute sized items to buckets with limited size
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Algorithm/Permute.pm:${PORTSDIR}/devel/p5-Algorithm-Permute
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::Bucketizer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8.0 or superior. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Algorithm-Bucketizer/distinfo b/devel/p5-Algorithm-Bucketizer/distinfo
new file mode 100644
index 00000000000..af403218735
--- /dev/null
+++ b/devel/p5-Algorithm-Bucketizer/distinfo
@@ -0,0 +1,2 @@
+MD5 (Algorithm-Bucketizer-0.10.tar.gz) = 84fe8c33195e21909459503d7e4ad52f
+SIZE (Algorithm-Bucketizer-0.10.tar.gz) = 7554
diff --git a/devel/p5-Algorithm-Bucketizer/pkg-descr b/devel/p5-Algorithm-Bucketizer/pkg-descr
new file mode 100644
index 00000000000..da0ffa8ae91
--- /dev/null
+++ b/devel/p5-Algorithm-Bucketizer/pkg-descr
@@ -0,0 +1,5 @@
+Algorithm::Bucketizer distributes items of a defined size into a number of
+dynamically created buckets, each of them capable of holding items of a defined
+total size.
+
+WWW: http://search.cpan.org/search?dist=Algorithm-Bucketizer
diff --git a/devel/p5-Algorithm-Bucketizer/pkg-plist b/devel/p5-Algorithm-Bucketizer/pkg-plist
new file mode 100644
index 00000000000..3d848b077fb
--- /dev/null
+++ b/devel/p5-Algorithm-Bucketizer/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Bucketizer/.packlist
+%%SITE_PERL%%/Algorithm/Bucketizer.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Bucketizer
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true