aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-28 18:24:46 +0800
committeredwin <edwin@FreeBSD.org>2003-09-28 18:24:46 +0800
commit4a575c8b93dcbf32bb18a1d2ddbc67e9138c314c (patch)
tree7fafb22224bf80a1e4a649969f3c0fcc93bb2f7f /devel
parent779631dae34d7a4787cbe696fc45504f6dfa5f2b (diff)
downloadfreebsd-ports-graphics-4a575c8b93dcbf32bb18a1d2ddbc67e9138c314c.tar.gz
freebsd-ports-graphics-4a575c8b93dcbf32bb18a1d2ddbc67e9138c314c.tar.zst
freebsd-ports-graphics-4a575c8b93dcbf32bb18a1d2ddbc67e9138c314c.zip
New Port: Common Lisp portability package (CMUCL Binaries)
cl-port binaries for lang/cmucl PR: ports/52367 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cl-port-cmucl/Makefile41
-rw-r--r--devel/cl-port-cmucl/pkg-descr10
-rw-r--r--devel/cl-port-cmucl/pkg-plist8
4 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d5bc10a3346..e35346b2e3c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -106,6 +106,7 @@
SUBDIR += cl-asdf-cmucl
SUBDIR += cl-asdf-sbcl
SUBDIR += cl-port
+ SUBDIR += cl-port-cmucl
SUBDIR += cl-port-sbcl
SUBDIR += cl-split-sequence
SUBDIR += clanlib
diff --git a/devel/cl-port-cmucl/Makefile b/devel/cl-port-cmucl/Makefile
new file mode 100644
index 00000000000..ce338e350e5
--- /dev/null
+++ b/devel/cl-port-cmucl/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: cl-port-cmucl
+# Date created: 12 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= port
+PORTVERSION= 2002.10.02.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ ftp://www.aarg.net/pub/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -cmucl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= Cross-Lisp portability package
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/cmuclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-cmucl \
+ lisp:${PORTSDIR}/lang/cmucl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/cmuclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-cmucl \
+ lisp:${PORTSDIR}/lang/cmucl
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ lisp -nositeinit -noinit \
+ -load ${LOCALBASE}/etc/asdf-init.lisp \
+ -eval "(asdf:oos 'asdf:compile-op :port)" \
+ -eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/port/cmuclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/port/cmuclfasl/
+
+.include <bsd.port.mk>
diff --git a/devel/cl-port-cmucl/pkg-descr b/devel/cl-port-cmucl/pkg-descr
new file mode 100644
index 00000000000..8fe46247c30
--- /dev/null
+++ b/devel/cl-port-cmucl/pkg-descr
@@ -0,0 +1,10 @@
+CLOCC Port provides a portable interface to various features absent
+from the ANSI Common Lisp standard, such as sockets, multiprocessing,
+calling external programs, Gray streams etc.
+
+This package contains binaries compiled for CMU CL.
+
+WWW: http://clocc.sourceforge.net
+
+-- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/devel/cl-port-cmucl/pkg-plist b/devel/cl-port-cmucl/pkg-plist
new file mode 100644
index 00000000000..4f7c342bc7f
--- /dev/null
+++ b/devel/cl-port-cmucl/pkg-plist
@@ -0,0 +1,8 @@
+lib/common-lisp/port/cmuclfasl/ext.fasl
+lib/common-lisp/port/cmuclfasl/gray.fasl
+lib/common-lisp/port/cmuclfasl/net.fasl
+lib/common-lisp/port/cmuclfasl/path.fasl
+lib/common-lisp/port/cmuclfasl/proc.fasl
+lib/common-lisp/port/cmuclfasl/shell.fasl
+lib/common-lisp/port/cmuclfasl/sys.fasl
+@dirrm lib/common-lisp/port/cmuclfasl