aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-02-27 01:44:59 +0800
committerfjoe <fjoe@FreeBSD.org>2003-02-27 01:44:59 +0800
commit4adc184b421c6d780cf148060baa0e2212f5b4ab (patch)
tree811faa2c0c8233e0a42d5ad46c4accccb151c2a2 /devel
parent508b373884f5904a40ecaffdf321c3e79abdabd1 (diff)
downloadfreebsd-ports-graphics-4adc184b421c6d780cf148060baa0e2212f5b4ab.tar.gz
freebsd-ports-graphics-4adc184b421c6d780cf148060baa0e2212f5b4ab.tar.zst
freebsd-ports-graphics-4adc184b421c6d780cf148060baa0e2212f5b4ab.zip
New port: a cross-assembler for 6805, 6809, 68HC11, 6502, Sunplus, 8051,
Z80, PIC, and AVR PR: 48243
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tpasm/Makefile35
-rw-r--r--devel/tpasm/distinfo1
-rw-r--r--devel/tpasm/files/patch-Makefile13
-rw-r--r--devel/tpasm/pkg-descr24
-rw-r--r--devel/tpasm/pkg-plist8
6 files changed, 82 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c66ab63ceae..eb84379d980 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -878,6 +878,7 @@
SUBDIR += tkref
SUBDIR += tmake
SUBDIR += towitoko
+ SUBDIR += tpasm
SUBDIR += tpg
SUBDIR += trio
SUBDIR += tvision
diff --git a/devel/tpasm/Makefile b/devel/tpasm/Makefile
new file mode 100644
index 00000000000..848d0302143
--- /dev/null
+++ b/devel/tpasm/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: tpasm
+# Date created: 13 Feb 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tpasm
+PORTVERSION= 1.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ct0.com/pub/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= Cross-assembler for 680x, 68hc11, 6502, Sunplus, 8051, Z80, PIC, AVR
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+ @${MKDIR} ${PREFIX}/libdata/${PORTNAME}
+.for file in 8051 80c390 p16c505 picmacros
+ ${INSTALL_DATA} ${WRKSRC}/include/${file}.inc ${PREFIX}/libdata/${PORTNAME}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/MANUAL.TXT ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/tpasm/distinfo b/devel/tpasm/distinfo
new file mode 100644
index 00000000000..0ce3b5641d9
--- /dev/null
+++ b/devel/tpasm/distinfo
@@ -0,0 +1 @@
+MD5 (tpasm1.1.tgz) = 06452069f0ce8dd16b830463abdf4a6a
diff --git a/devel/tpasm/files/patch-Makefile b/devel/tpasm/files/patch-Makefile
new file mode 100644
index 00000000000..94629960fa9
--- /dev/null
+++ b/devel/tpasm/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Feb 13 19:58:06 2003
++++ Makefile Thu Feb 13 19:58:18 2003
+@@ -17,8 +17,8 @@
+
+ # new gnu compilers have a really annoying default behavior of wrapping
+ # error message lines. The default should be NO-WRAPPING.
+-OPTIONS=-O2 -Wall -x c++ -fmessage-length=0
+-CFLAGS=$(INCLUDES) $(OPTIONS)
++OPTIONS=-x c++
++CFLAGS+=$(INCLUDES) $(OPTIONS)
+
+ OBJECTS = \
+ globals.o \
diff --git a/devel/tpasm/pkg-descr b/devel/tpasm/pkg-descr
new file mode 100644
index 00000000000..a9de62e96de
--- /dev/null
+++ b/devel/tpasm/pkg-descr
@@ -0,0 +1,24 @@
+Tpasm is a command line based cross assembler for a variety of common
+microprocessors and controllers, currently supporting:
+
+Rockwell 6502 (6502, 65c02)
+Motorola 6805 (6805, 68705), 6809, 68hc11
+Intel 8051 (8031, 8032, 8051, 8052, 80c390)
+Atmel AVR (avt, attiny, at90, atmega series)
+Core Technologies CTXP-1
+Microchip PIC (12xxx, 14xxx, 16xxx, 17xxx series)
+Sunplus SPCxxx series
+Zilog Z80 (z80, z180)
+
+Features are:
+
+ * True multi-pass assembly (will take as many passes as needed)
+ * Multiple segments
+ * Sophisticated expressions
+ * Macros, repeats, conditionals
+ * Arbitrary length labels
+ * Local labels
+ * Supporting new processors is reasonably straightforward
+ * Can switch between processors during assembly
+
+WWW: http://www.sqrt.com/
diff --git a/devel/tpasm/pkg-plist b/devel/tpasm/pkg-plist
new file mode 100644
index 00000000000..537ad1eea02
--- /dev/null
+++ b/devel/tpasm/pkg-plist
@@ -0,0 +1,8 @@
+bin/tpasm
+libdata/tpasm/8051.inc
+libdata/tpasm/80c390.inc
+libdata/tpasm/p16c505.inc
+libdata/tpasm/picmacros.inc
+@dirrm libdata/tpasm
+%%PORTDOCS%%share/doc/tpasm/MANUAL.TXT
+%%PORTDOCS%%@dirrm share/doc/tpasm