aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-11-08 17:06:33 +0800
committerwen <wen@FreeBSD.org>2011-11-08 17:06:33 +0800
commit4d0536a55110ff194e73bd5ec283cb475a455fab (patch)
tree23f3fd54a76620ec66b6dafbb568c17f00b11ef9 /devel
parent62b7a2bf1540bc7248425b41314ad4debe75f2d6 (diff)
downloadfreebsd-ports-graphics-4d0536a55110ff194e73bd5ec283cb475a455fab.tar.gz
freebsd-ports-graphics-4d0536a55110ff194e73bd5ec283cb475a455fab.tar.zst
freebsd-ports-graphics-4d0536a55110ff194e73bd5ec283cb475a455fab.zip
The zope.minmax.AbstractValue class provides a super class which can be
subclassed to store arbitrary homogeneous values in a persistent storage and apply different conflict resolution policies. The subclasses defined here are resolving the conflicts using always either the maximum or the minimum of the conflicting values. WWW: http://pypi.python.org/pypi/zope.minmax/ Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> (via GitHub)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-zope.minmax/Makefile26
-rw-r--r--devel/py-zope.minmax/distinfo2
-rw-r--r--devel/py-zope.minmax/pkg-descr8
-rw-r--r--devel/py-zope.minmax/pkg-plist27
5 files changed, 64 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8620829e9cf..0d85c902748 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3211,6 +3211,7 @@
SUBDIR += py-zope.i18n
SUBDIR += py-zope.interface
SUBDIR += py-zope.location
+ SUBDIR += py-zope.minmax
SUBDIR += py-zope.schema
SUBDIR += py-zope.testing
SUBDIR += pybaz
diff --git a/devel/py-zope.minmax/Makefile b/devel/py-zope.minmax/Makefile
new file mode 100644
index 00000000000..a214dcff5cf
--- /dev/null
+++ b/devel/py-zope.minmax/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-zope.minmax
+# Date created: Nov 9, 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zope.minmax
+PORTVERSION= 1.1.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= zope
+
+MAINTAINER= cvs-src@yandex.ru
+COMMENT= Homogeneous values favoring maximum or minimum
+
+LICENSE= ZPL21
+
+RUN_DEPENDS= zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3 \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+.include <bsd.port.mk>
diff --git a/devel/py-zope.minmax/distinfo b/devel/py-zope.minmax/distinfo
new file mode 100644
index 00000000000..4f201ecb183
--- /dev/null
+++ b/devel/py-zope.minmax/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zope/zope.minmax-1.1.2.tar.gz) = 3ed8cc293853cc8fc06ab5bd1a134b6abbfece9e7191e7fea994e72fd1694e1f
+SIZE (zope/zope.minmax-1.1.2.tar.gz) = 5554
diff --git a/devel/py-zope.minmax/pkg-descr b/devel/py-zope.minmax/pkg-descr
new file mode 100644
index 00000000000..1d2b79d74bd
--- /dev/null
+++ b/devel/py-zope.minmax/pkg-descr
@@ -0,0 +1,8 @@
+The zope.minmax.AbstractValue class provides a super class which can be
+subclassed to store arbitrary homogeneous values in a persistent storage
+and apply different conflict resolution policies.
+
+The subclasses defined here are resolving the conflicts using always
+either the maximum or the minimum of the conflicting values.
+
+WWW: http://pypi.python.org/pypi/zope.minmax/
diff --git a/devel/py-zope.minmax/pkg-plist b/devel/py-zope.minmax/pkg-plist
new file mode 100644
index 00000000000..e1edc4084d8
--- /dev/null
+++ b/devel/py-zope.minmax/pkg-plist
@@ -0,0 +1,27 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/namespace_packages.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/_minmax.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/_minmax.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/_minmax.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/interfaces.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/interfaces.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/interfaces.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/minmax.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/tests.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/tests.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax/tests.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/minmax
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%