aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-29 19:50:08 +0800
committerkrion <krion@FreeBSD.org>2003-08-29 19:50:08 +0800
commit52d996b011e07e6bae73eda7c9d41d3d434307ee (patch)
treefeb5a3ea4275df583cc42370a96bfda54ee8cc7f /devel
parentbf427dd79152629d633618a950323441b6a5e50a (diff)
downloadfreebsd-ports-graphics-52d996b011e07e6bae73eda7c9d41d3d434307ee.tar.gz
freebsd-ports-graphics-52d996b011e07e6bae73eda7c9d41d3d434307ee.tar.zst
freebsd-ports-graphics-52d996b011e07e6bae73eda7c9d41d3d434307ee.zip
New port - devel/xxl
XXL is a library for C and C++ that provides exception handling and asset management. Asset management is integrated with the exception handling mechanism such that assets may be automatically cleaned up if an exception is thrown, which allows for much simplified program structure with respect to error handling. By allowing XXL to track assets and using its exception handling features, the programmer no longer has to check error conditions on every function call and cleanup the assets on failure because XXL does the work. PR: 56128 Submitted by: Robert Schlotterbeck <rws@suki.rs.tarrant.tx.us>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/xxl/Makefile21
-rw-r--r--devel/xxl/distinfo1
-rw-r--r--devel/xxl/files/patch-ltmain.sh15
-rw-r--r--devel/xxl/pkg-descr11
-rw-r--r--devel/xxl/pkg-plist5
6 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f572bf441f8..53a8c544d3d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1038,6 +1038,7 @@
SUBDIR += xtl
SUBDIR += xwpe
SUBDIR += xxgdb
+ SUBDIR += xxl
SUBDIR += yacl
SUBDIR += yasm
SUBDIR += z80-asm
diff --git a/devel/xxl/Makefile b/devel/xxl/Makefile
new file mode 100644
index 00000000000..62c6544e060
--- /dev/null
+++ b/devel/xxl/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: xxl
+# Date created: 28 Aug 2003
+# Whom: Robert Schlotterbeck <robert@rs.tarrant.tx.us>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xxl
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= http://www.zork.org/software/
+
+MAINTAINER= robert@rs.tarrant.tx.us
+COMMENT= C and C++ that provides exception handling and asset management
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --without-threads
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/xxl/distinfo b/devel/xxl/distinfo
new file mode 100644
index 00000000000..97a946803e8
--- /dev/null
+++ b/devel/xxl/distinfo
@@ -0,0 +1 @@
+MD5 (xxl-1.0.0.tar.gz) = 32e0764c5026f0c7491e739f4d570a5d
diff --git a/devel/xxl/files/patch-ltmain.sh b/devel/xxl/files/patch-ltmain.sh
new file mode 100644
index 00000000000..d95cb821895
--- /dev/null
+++ b/devel/xxl/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Fri Aug 29 13:31:36 2003
++++ ltmain.sh Fri Aug 29 13:31:59 2003
+@@ -5425,10 +5425,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/xxl/pkg-descr b/devel/xxl/pkg-descr
new file mode 100644
index 00000000000..0a14562e24d
--- /dev/null
+++ b/devel/xxl/pkg-descr
@@ -0,0 +1,11 @@
+XXL is a library for C and C++ that provides exception handling and asset
+management. Asset management is integrated with the exception handling
+mechanism such that assets may be automatically cleaned up if an exception
+is thrown, which allows for much simplified program structure with respect to
+error handling.
+
+By allowing XXL to track assets and using its exception handling features, the
+programmer no longer has to check error conditions on every function call and
+cleanup the assets on failure because XXL does the work.
+
+WWW: http://www.zork.org/xxl/
diff --git a/devel/xxl/pkg-plist b/devel/xxl/pkg-plist
new file mode 100644
index 00000000000..8f9d22464c1
--- /dev/null
+++ b/devel/xxl/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+include/xxl.h
+lib/libxxl.a
+lib/libxxl.so
+lib/libxxl.so.1