aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2015-09-29 02:33:46 +0800
committergarga <garga@FreeBSD.org>2015-09-29 02:33:46 +0800
commit57fb1dc0aa073ef7ccdba271d818a9044077eabe (patch)
tree3ade2546faededa53f6ca397ef28668c65b1b409 /devel
parent85f398fdc32a145eea6010fe55c4f4ffc19b4a56 (diff)
downloadfreebsd-ports-graphics-57fb1dc0aa073ef7ccdba271d818a9044077eabe.tar.gz
freebsd-ports-graphics-57fb1dc0aa073ef7ccdba271d818a9044077eabe.tar.zst
freebsd-ports-graphics-57fb1dc0aa073ef7ccdba271d818a9044077eabe.zip
- Add devel/git-gui, a devel/git slave port with GUI option enabled
- Register conflicts with master and other slave ports - Bump PORTREVISION PR: 202948
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/git-gui/Makefile17
-rw-r--r--devel/git-gui/pkg-descr6
-rw-r--r--devel/git-lite/Makefile2
-rw-r--r--devel/git-subversion/Makefile2
-rw-r--r--devel/git/Makefile3
6 files changed, 28 insertions, 3 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 745aac6a0c9..4f00fcb4f8d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -636,6 +636,7 @@
SUBDIR += git-codereview
SUBDIR += git-cola
SUBDIR += git-extras
+ SUBDIR += git-gui
SUBDIR += git-lite
SUBDIR += git-merge-changelog
SUBDIR += git-modes
diff --git a/devel/git-gui/Makefile b/devel/git-gui/Makefile
new file mode 100644
index 00000000000..312dd4e8b8f
--- /dev/null
+++ b/devel/git-gui/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -gui
+
+COMMENT= Distributed source code management tool (GUI enabled)
+
+MASTERDIR= ${.CURDIR}/../git
+
+DESCR= ${.CURDIR}/pkg-descr
+
+OPTIONS_SLAVE= GUI
+
+CONFLICTS_INSTALL= git-[0-9]* git-lite-[0-9]* git-subversion-[0-9]*
+
+DISTINFO_FILE= ${MASTERDIR}/distinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/git-gui/pkg-descr b/devel/git-gui/pkg-descr
new file mode 100644
index 00000000000..04f70334c41
--- /dev/null
+++ b/devel/git-gui/pkg-descr
@@ -0,0 +1,6 @@
+Git is a free and open source distributed version control system designed to
+handle everything from small to very large projects with speed and efficiency.
+
+This version provides a package with GUI option enabled.
+
+WWW: http://git-scm.com/
diff --git a/devel/git-lite/Makefile b/devel/git-lite/Makefile
index 2ebc80d3076..adca254c2cd 100644
--- a/devel/git-lite/Makefile
+++ b/devel/git-lite/Makefile
@@ -10,7 +10,7 @@ DESCR= ${.CURDIR}/pkg-descr
OPTIONS_EXCLUDE=GUI SVN GITWEB CONTRIB P4 CVS PERL
-CONFLICTS_INSTALL= git-[0-9]* git-subversion-[0-9]*
+CONFLICTS_INSTALL= git-[0-9]* git-gui-[0-9]* git-subversion-[0-9]*
DISTINFO_FILE= ${MASTERDIR}/distinfo
diff --git a/devel/git-subversion/Makefile b/devel/git-subversion/Makefile
index b218a29d4d0..a09d2624f11 100644
--- a/devel/git-subversion/Makefile
+++ b/devel/git-subversion/Makefile
@@ -10,7 +10,7 @@ DESCR= ${.CURDIR}/pkg-descr
OPTIONS_SLAVE= SVN
-CONFLICTS_INSTALL= git-[0-9]* git-lite-[0-9]*
+CONFLICTS_INSTALL= git-[0-9]* git-gui-[0-9]* git-lite-[0-9]*
DISTINFO_FILE= ${MASTERDIR}/distinfo
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 92121ee6580..62dfbae3e05 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -3,6 +3,7 @@
PORTNAME= git
PORTVERSION= 2.5.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -16,7 +17,7 @@ COMMENT?= Distributed source code management tool
LICENSE= GPLv2
-CONFLICTS_INSTALL?= git-subversion-[0-9]* git-lite-[0-9]*
+CONFLICTS_INSTALL?= git-gui-[0-9]* git-subversion-[0-9]* git-lite-[0-9]*
USERS= git_daemon
GROUPS= git_daemon