aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2011-12-06 19:40:17 +0800
committertobez <tobez@FreeBSD.org>2011-12-06 19:40:17 +0800
commit5a3f3f2ab9f6ea8bea5a9320422fda38a0a4f83c (patch)
tree832f389758ecbb5c15575596780a68f8bf01084f /devel
parent1d6201c8937037c32fea045ac3db0bdd11202401 (diff)
downloadfreebsd-ports-graphics-5a3f3f2ab9f6ea8bea5a9320422fda38a0a4f83c.tar.gz
freebsd-ports-graphics-5a3f3f2ab9f6ea8bea5a9320422fda38a0a4f83c.tar.zst
freebsd-ports-graphics-5a3f3f2ab9f6ea8bea5a9320422fda38a0a4f83c.zip
Add devel/p5-Set-CrossProduct 1.95, a Perl module to work with the cross
product of two or more sets. Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Set-CrossProduct/Makefile23
-rw-r--r--devel/p5-Set-CrossProduct/distinfo2
-rw-r--r--devel/p5-Set-CrossProduct/pkg-descr6
-rw-r--r--devel/p5-Set-CrossProduct/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5efc8913400..fffef657830 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2308,6 +2308,7 @@
SUBDIR += p5-Set-Array
SUBDIR += p5-Set-ConsistentHash
SUBDIR += p5-Set-Crontab
+ SUBDIR += p5-Set-CrossProduct
SUBDIR += p5-Set-Infinite
SUBDIR += p5-Set-NestedGroups
SUBDIR += p5-Set-Object
diff --git a/devel/p5-Set-CrossProduct/Makefile b/devel/p5-Set-CrossProduct/Makefile
new file mode 100644
index 00000000000..7735e527e2c
--- /dev/null
+++ b/devel/p5-Set-CrossProduct/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: devel/p5-Set-CrossProduct
+# Date created: 06 December 2011
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-CrossProduct
+PORTVERSION= 1.95
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:BDFOY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Work with the cross product of two or more sets
+
+PERL_CONFIGURE= yes
+
+MAN1= cross.1
+MAN3= Set::CrossProduct.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Set-CrossProduct/distinfo b/devel/p5-Set-CrossProduct/distinfo
new file mode 100644
index 00000000000..c9c547024a2
--- /dev/null
+++ b/devel/p5-Set-CrossProduct/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Set-CrossProduct-1.95.tar.gz) = 03a0cefb71c2bdd035140fbdfe44e12c8aa765eb1a4c8dd9d7de5e8baf9f09d4
+SIZE (Set-CrossProduct-1.95.tar.gz) = 6799
diff --git a/devel/p5-Set-CrossProduct/pkg-descr b/devel/p5-Set-CrossProduct/pkg-descr
new file mode 100644
index 00000000000..829264aa1ed
--- /dev/null
+++ b/devel/p5-Set-CrossProduct/pkg-descr
@@ -0,0 +1,6 @@
+Create a list by taking one item from each array, and do that for all
+possible ways that can be done, so that the first item in the list is
+always from the first array, the second item from the second array, and
+so on.
+
+WWW: http://search.cpan.org/dist/Set-CrossProduct/
diff --git a/devel/p5-Set-CrossProduct/pkg-plist b/devel/p5-Set-CrossProduct/pkg-plist
new file mode 100644
index 00000000000..e4680e3f406
--- /dev/null
+++ b/devel/p5-Set-CrossProduct/pkg-plist
@@ -0,0 +1,6 @@
+bin/cross
+%%SITE_PERL%%/Set/CrossProduct.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/CrossProduct/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/CrossProduct
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set
+@dirrmtry %%SITE_PERL%%/Set