aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-08-27 11:54:17 +0800
committerclsung <clsung@FreeBSD.org>2007-08-27 11:54:17 +0800
commit6370dbf26463765eeff0662057bea681b3490cc1 (patch)
treefc3fb62fdc8e702a25be52a1263a19525d09833c /devel
parent23dfac3103c140ec8b9eb2d8900caf4638d6bee3 (diff)
downloadfreebsd-ports-graphics-6370dbf26463765eeff0662057bea681b3490cc1.tar.gz
freebsd-ports-graphics-6370dbf26463765eeff0662057bea681b3490cc1.tar.zst
freebsd-ports-graphics-6370dbf26463765eeff0662057bea681b3490cc1.zip
Data::Alias is a module that allows you to apply "aliasing semantics"
to a section of code, causing aliases to be made whereever Perl would normally make copies instead. You can use this to improve efficiency and readability, when compared to using references. WWW: http://search.cpan.org/dist/Data-Alias/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Alias/Makefile21
-rw-r--r--devel/p5-Data-Alias/distinfo3
-rw-r--r--devel/p5-Data-Alias/pkg-descr6
-rw-r--r--devel/p5-Data-Alias/pkg-plist7
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 62770304bea..31a3ee82311 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1001,6 +1001,7 @@
SUBDIR += p5-DB_File-Lock
SUBDIR += p5-Danga-Socket
SUBDIR += p5-Data-ACL
+ SUBDIR += p5-Data-Alias
SUBDIR += p5-Data-Bind
SUBDIR += p5-Data-Compare
SUBDIR += p5-Data-Dump
diff --git a/devel/p5-Data-Alias/Makefile b/devel/p5-Data-Alias/Makefile
new file mode 100644
index 00000000000..6a13c9f422d
--- /dev/null
+++ b/devel/p5-Data-Alias/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: devel/p5-Data-Alias
+# Date created: 27 August 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Alias
+PORTVERSION= 1.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Comprehensive set of aliasing operations
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Alias.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Alias/distinfo b/devel/p5-Data-Alias/distinfo
new file mode 100644
index 00000000000..716b2fb835c
--- /dev/null
+++ b/devel/p5-Data-Alias/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Alias-1.06.tar.gz) = 3c95c582f7fd1d8747e87dda0a8ffc7e
+SHA256 (Data-Alias-1.06.tar.gz) = 75fa193dbc4ee6f8ddcbdcb0d152d35a888abec36af7e0514bea7bfe4a049b06
+SIZE (Data-Alias-1.06.tar.gz) = 61261
diff --git a/devel/p5-Data-Alias/pkg-descr b/devel/p5-Data-Alias/pkg-descr
new file mode 100644
index 00000000000..65e509073fb
--- /dev/null
+++ b/devel/p5-Data-Alias/pkg-descr
@@ -0,0 +1,6 @@
+Data::Alias is a module that allows you to apply "aliasing semantics"
+to a section of code, causing aliases to be made whereever Perl would
+normally make copies instead. You can use this to improve efficiency
+and readability, when compared to using references.
+
+WWW: http://search.cpan.org/dist/Data-Alias/
diff --git a/devel/p5-Data-Alias/pkg-plist b/devel/p5-Data-Alias/pkg-plist
new file mode 100644
index 00000000000..ad793920d5d
--- /dev/null
+++ b/devel/p5-Data-Alias/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Alias.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Alias/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Alias/Alias.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Alias/Alias.bs
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Alias
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Data