aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-06-14 09:25:23 +0800
committerclsung <clsung@FreeBSD.org>2006-06-14 09:25:23 +0800
commit666f25bf5da314d205ad6cf523619f740f586f8c (patch)
tree7779f0f770ff38814fa573e2f167dd846a9196b9 /devel
parent25d9787cb0c45be153e1845a1f76c65a6df7d595 (diff)
downloadfreebsd-ports-graphics-666f25bf5da314d205ad6cf523619f740f586f8c.tar.gz
freebsd-ports-graphics-666f25bf5da314d205ad6cf523619f740f586f8c.tar.zst
freebsd-ports-graphics-666f25bf5da314d205ad6cf523619f740f586f8c.zip
- Unbroken FreeBSD 5.x and 4.x.
- Use BUILD_DEPENDS and RUN_DEPENDS to replace LIB_DEPENDS. This will 1) force install port-base libreadline if OSVERSION < 700016 and 2) avoid configure broken with misc/compat5x installed. PR: ports/98904 Submitted by: maintainer (Gea-Suan Lin)
Diffstat (limited to 'devel')
-rw-r--r--devel/cgdb/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/cgdb/Makefile b/devel/cgdb/Makefile
index 4daa139e568..6acc9ce1590 100644
--- a/devel/cgdb/Makefile
+++ b/devel/cgdb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cgdb
PORTVERSION= 0.6.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,12 +22,9 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-IGNORE= it can be compiled, but cannot run
-.endif
-
.if ${OSVERSION} < 700016
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+BUILD_DEPENDS+= ${LOCALBASE}/lib/readline.so.5:${PORTSDIR}/devel/readline
+RUN_DEPENDS= ${BUILD_DEPENDS}
LDFLAGS+= -rpath ${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"