aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-09 19:18:23 +0800
committermiwi <miwi@FreeBSD.org>2009-09-09 19:18:23 +0800
commit69f6d51997761d6f11b4a13d2681cf73f8a73c6c (patch)
treec7ed9f56e6376f6948626c3098d5d442fc990a90 /devel
parent4681a2e8db6d8764a9a82fa494f81aecd964e7ec (diff)
downloadfreebsd-ports-graphics-69f6d51997761d6f11b4a13d2681cf73f8a73c6c.tar.gz
freebsd-ports-graphics-69f6d51997761d6f11b4a13d2681cf73f8a73c6c.tar.zst
freebsd-ports-graphics-69f6d51997761d6f11b4a13d2681cf73f8a73c6c.zip
The lockfile module exports a FileLock class which provides a simple
API for locking files. Unlike the Windows msvcrt.locking function, the Unix fcntl.flock, fcntl.lockf and the deprecated posixfile module, the API is identical across both Unix (including Linux and Mac) and Windows platforms. The lock mechanism relies on the atomic nature of the link (on Unix) and mkdir (on Windows) system calls. WWW: http://pypi.python.org/pypi/lockfile/ PR: ports/138647 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-lockfile/Makefile20
-rw-r--r--devel/py-lockfile/distinfo3
-rw-r--r--devel/py-lockfile/pkg-descr8
-rw-r--r--devel/py-lockfile/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ba28e1ba6d2..b1d8ae1bc27 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2430,6 +2430,7 @@
SUBDIR += py-libgsf
SUBDIR += py-ll-core
SUBDIR += py-lock_file
+ SUBDIR += py-lockfile
SUBDIR += py-log4py
SUBDIR += py-logilab-common
SUBDIR += py-lxml
diff --git a/devel/py-lockfile/Makefile b/devel/py-lockfile/Makefile
new file mode 100644
index 00000000000..d3ca177596b
--- /dev/null
+++ b/devel/py-lockfile/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: lockfile
+# Date created: 4th Sep, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lockfile
+PORTVERSION= 0.8
+CATEGORIES= devel python
+MASTER_SITES= http://smontanaro.dyndns.org/python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Platform-independent file locking module
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-lockfile/distinfo b/devel/py-lockfile/distinfo
new file mode 100644
index 00000000000..b1604ad069e
--- /dev/null
+++ b/devel/py-lockfile/distinfo
@@ -0,0 +1,3 @@
+MD5 (lockfile-0.8.tar.gz) = 2d515e19eb6f69d6ed711cbbafdec7ef
+SHA256 (lockfile-0.8.tar.gz) = e6e20ec66ceaea2cf81c675216d68f11b3d15a855fe6c64a26ef983b399afd7a
+SIZE (lockfile-0.8.tar.gz) = 8825
diff --git a/devel/py-lockfile/pkg-descr b/devel/py-lockfile/pkg-descr
new file mode 100644
index 00000000000..958cf522b6c
--- /dev/null
+++ b/devel/py-lockfile/pkg-descr
@@ -0,0 +1,8 @@
+The lockfile module exports a FileLock class which provides a simple
+API for locking files. Unlike the Windows msvcrt.locking function, the
+Unix fcntl.flock, fcntl.lockf and the deprecated posixfile module, the
+API is identical across both Unix (including Linux and Mac) and Windows
+platforms. The lock mechanism relies on the atomic nature of the link
+(on Unix) and mkdir (on Windows) system calls.
+
+WWW: http://pypi.python.org/pypi/lockfile/
diff --git a/devel/py-lockfile/pkg-plist b/devel/py-lockfile/pkg-plist
new file mode 100644
index 00000000000..024fd6b6b4a
--- /dev/null
+++ b/devel/py-lockfile/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/lockfile.py
+%%PYTHON_SITELIBDIR%%/lockfile.pyc
+%%PYTHON_SITELIBDIR%%/lockfile.pyo