aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2008-07-08 17:25:16 +0800
committerlev <lev@FreeBSD.org>2008-07-08 17:25:16 +0800
commit767681df74f890eae24980f9d2dad4d1d7059272 (patch)
treed34c2919750d9a584295d4e0f843f8429f5efd1c /devel
parent04cde6ba1cf38f88fd4a7b03af5d8e0200ee73e9 (diff)
downloadfreebsd-ports-graphics-767681df74f890eae24980f9d2dad4d1d7059272.tar.gz
freebsd-ports-graphics-767681df74f890eae24980f9d2dad4d1d7059272.tar.zst
freebsd-ports-graphics-767681df74f890eae24980f9d2dad4d1d7059272.zip
Fix building of bindings in BATCH mode (without options file at all):
invert checks such way, that default config without OPTIONS at all is equivalent to default config, specified via OPTIONS.
Diffstat (limited to 'devel')
-rw-r--r--devel/subversion/Makefile.common8
-rw-r--r--devel/subversion16/Makefile.common8
2 files changed, 10 insertions, 6 deletions
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index 8f1f53c3643..85d74367cd1 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.5.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.4/:book
@@ -31,7 +31,8 @@ OPTIONS=
CONFIGURE_ARGS+= --without-swig
-.if defined(WITH_NEON)
+# Default is "on"
+.if !defined(WITHOUT_NEON)
LIB_DEPENDS+= neon.28:${PORTSDIR}/www/neon28
CONFIGURE_ARGS+= --with-neon=${LOCALBASE}
PLIST_SUB+= NEON=""
@@ -57,7 +58,8 @@ CONFIGURE_ARGS+= --without-sasl
PLIST_SUB+= SASL="@comment "
.endif
-.if defined(WITH_BDB)
+# Default us "on"
+.if !defined(WITHOUT_BDB)
PLIST_SUB+= BDB=""
.else
CONFIGURE_ARGS+= --without-berkeley-db
diff --git a/devel/subversion16/Makefile.common b/devel/subversion16/Makefile.common
index 8f1f53c3643..85d74367cd1 100644
--- a/devel/subversion16/Makefile.common
+++ b/devel/subversion16/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.5.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.4/:book
@@ -31,7 +31,8 @@ OPTIONS=
CONFIGURE_ARGS+= --without-swig
-.if defined(WITH_NEON)
+# Default is "on"
+.if !defined(WITHOUT_NEON)
LIB_DEPENDS+= neon.28:${PORTSDIR}/www/neon28
CONFIGURE_ARGS+= --with-neon=${LOCALBASE}
PLIST_SUB+= NEON=""
@@ -57,7 +58,8 @@ CONFIGURE_ARGS+= --without-sasl
PLIST_SUB+= SASL="@comment "
.endif
-.if defined(WITH_BDB)
+# Default us "on"
+.if !defined(WITHOUT_BDB)
PLIST_SUB+= BDB=""
.else
CONFIGURE_ARGS+= --without-berkeley-db