aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorejc <ejc@FreeBSD.org>2000-09-19 03:01:19 +0800
committerejc <ejc@FreeBSD.org>2000-09-19 03:01:19 +0800
commit7731cc460a49827f96cad1c53cee630b1b44000e (patch)
treec30f29a1fcfdf5f54d6fc7322ea1f5fe3856156f /devel
parent4eb0a35d11198108b28613fd7c9329c76d17e5c5 (diff)
downloadfreebsd-ports-graphics-7731cc460a49827f96cad1c53cee630b1b44000e.tar.gz
freebsd-ports-graphics-7731cc460a49827f96cad1c53cee630b1b44000e.tar.zst
freebsd-ports-graphics-7731cc460a49827f96cad1c53cee630b1b44000e.zip
It helps when you "cvs add" the new patches, oops.
Diffstat (limited to 'devel')
-rw-r--r--devel/omniORB/files/patch-aj58
-rw-r--r--devel/omniORB/files/patch-ak11
-rw-r--r--devel/omniORB/files/patch-al11
3 files changed, 80 insertions, 0 deletions
diff --git a/devel/omniORB/files/patch-aj b/devel/omniORB/files/patch-aj
new file mode 100644
index 00000000000..5777ddf440b
--- /dev/null
+++ b/devel/omniORB/files/patch-aj
@@ -0,0 +1,58 @@
+--- ../mk/platforms/x86_freebsd_4.0.mk.orig Fri Aug 18 16:09:33 2000
++++ ../mk/platforms/x86_freebsd_4.0.mk Tue Sep 12 09:56:52 2000
+@@ -10,7 +10,7 @@
+ #
+ # You must set a path to a Python 1.5.2 interpreter.
+
+-#PYTHON = /usr/local/bin/python
++PYTHON = ${PYTHON_CMD}
+
+
+ #
+@@ -25,12 +25,13 @@
+ #
+
+ AR = ar cq
++MKDIRHIER= ${MKDIR}
+
+ CPP = /usr/libexec/cpp
+
+-CXX = g++295
++CXX ?= g++
+ CXXMAKEDEPEND += -D__cplusplus -D__GNUG__ -D__GNUC__
+-CXXDEBUGFLAGS = -O2
++CXXDEBUGFLAGS ?= -O2
+
+ CXXLINK = $(CXX) -pthread -s
+ CXXLINKOPTIONS = $(CXXDEBUGFLAGS) $(CXXOPTIONS)
+@@ -39,14 +40,14 @@
+ EgcsMajorVersion = 1
+ EgcsMinorVersion = 1 # This is actually a post-1.0 egcs snapshot.
+
+-CC = gcc295
++CC ?= gcc
+ CMAKEDEPEND += -D__GNUC__
+-CDEBUGFLAGS = -O2
++CDEBUGFLAGS ?= -O2
+
+ CLINK = $(CC)
+ CLINKOPTIONS = $(CDEBUGFLAGS) $(COPTIONS)
+
+-INSTALL = install -c
++INSTALL = ${BSD_INSTALL} -c
+
+ IMPORT_CPPFLAGS += -D__x86__ -D__freebsd__ -D__OSVERSION__=4
+
+@@ -72,10 +73,10 @@
+ # Default location of the omniORB configuration file [falls back to this if
+ # the environment variable OMNIORB_CONFIG is not set] :
+
+-OMNIORB_CONFIG_DEFAULT_LOCATION = /etc/omniORB.cfg
++OMNIORB_CONFIG_DEFAULT_LOCATION = ${PREFIX}/etc/omniORB.cfg
+
+ # Default directory for the omniNames log files.
+-OMNINAMES_LOG_DEFAULT_LOCATION = /var/omninames
++OMNINAMES_LOG_DEFAULT_LOCATION = /var/log/omninames
+
+ # Uncomment the following if you want all utils and examples build in
+ # this tree to statically linke with the omniORB libraries.
diff --git a/devel/omniORB/files/patch-ak b/devel/omniORB/files/patch-ak
new file mode 100644
index 00000000000..99a0f42846c
--- /dev/null
+++ b/devel/omniORB/files/patch-ak
@@ -0,0 +1,11 @@
+--- tool/omniidl/cxx/idlutil.cc.orig Fri Aug 18 16:09:06 2000
++++ tool/omniidl/cxx/idlutil.cc Mon Sep 11 17:44:48 2000
+@@ -148,7 +148,7 @@
+ IdlIntLiteral
+ idl_strtoul(const char* text, int base)
+ {
+- return strtoull(text, 0, base);
++ return strtouq(text, 0, base);
+ }
+
+ # endif
diff --git a/devel/omniORB/files/patch-al b/devel/omniORB/files/patch-al
new file mode 100644
index 00000000000..81ba9fce348
--- /dev/null
+++ b/devel/omniORB/files/patch-al
@@ -0,0 +1,11 @@
+--- tool/omniidl/cxx/dir.mk.orig Thu Jul 13 17:25:54 2000
++++ tool/omniidl/cxx/dir.mk Thu Sep 14 11:50:03 2000
+@@ -254,7 +254,7 @@
+ $(RM) $@; \
+ $(CXXLINK) $(CXXLINKOPTIONS) -shared -o $@ -Wl,-soname,$(soname) \
+ $(IMPORT_LIBRARY_FLAGS) \
+- $(filter-out $(LibSuffixPattern),$^) $(LIBS)\
++ $(filter-out $(LibSuffixPattern),$^) $(LIBS) -lgcc\
+ )
+
+ export:: $(lib)