aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-08-16 05:38:51 +0800
committerbapt <bapt@FreeBSD.org>2012-08-16 05:38:51 +0800
commit7c43a0579e678d15f3a51473fc0d08abcd3f4233 (patch)
treec31c3ede3f2216f174d247662723f94ac8090a78 /devel
parent3078fc3dee110dbd4b8079a210709b6b79e94c83 (diff)
downloadfreebsd-ports-graphics-7c43a0579e678d15f3a51473fc0d08abcd3f4233.tar.gz
freebsd-ports-graphics-7c43a0579e678d15f3a51473fc0d08abcd3f4233.tar.zst
freebsd-ports-graphics-7c43a0579e678d15f3a51473fc0d08abcd3f4233.zip
- update to 0.8.6 (plus patches from upstream git)
- patches are: * fix pkgconf returning 0 when a dependency is missing instead of 1 [1] * fix \" in cflags being lost [2] Reported by: Olivier Smedts <olivier@gid0.org> [1], tj@ [2]
Diffstat (limited to 'devel')
-rw-r--r--devel/pkgconf/Makefile2
-rw-r--r--devel/pkgconf/distinfo4
-rw-r--r--devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash63
3 files changed, 66 insertions, 3 deletions
diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile
index 5bba707b014..9f6747623a2 100644
--- a/devel/pkgconf/Makefile
+++ b/devel/pkgconf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pkgconf
-PORTVERSION= 0.8.5
+PORTVERSION= 0.8.6
CATEGORIES= devel
MASTER_SITES= http://nenolod.net/~nenolod/distfiles/
diff --git a/devel/pkgconf/distinfo b/devel/pkgconf/distinfo
index 042952207ed..4c0935eb336 100644
--- a/devel/pkgconf/distinfo
+++ b/devel/pkgconf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkgconf-0.8.5.tar.bz2) = 78283c42f6ba80e58f6425a9b2d5878f0cfa3b34f4e9bf130c2b97137b7e41f0
-SIZE (pkgconf-0.8.5.tar.bz2) = 81307
+SHA256 (pkgconf-0.8.6.tar.bz2) = 05a6f88b7654b93335f9dc292e5e6141d63d43a526337f16c873e301eb5a77d4
+SIZE (pkgconf-0.8.6.tar.bz2) = 79582
diff --git a/devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash b/devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash
new file mode 100644
index 00000000000..a1ca84a5a98
--- /dev/null
+++ b/devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash
@@ -0,0 +1,63 @@
+diff --git argvsplit.c argvsplit.c
+index cbfb55d..e9ed7b6 100644
+--- argvsplit.c
++++ argvsplit.c
+@@ -92,6 +92,8 @@ pkg_argv_split(const char *src, int *argc, char ***argv)
+ free(argv);
+ free(buf);
+ return -1;
++ } else {
++ *dst_iter++ = '\\';
+ }
+ default:
+ *dst_iter++ = *src_iter;
+diff --git fileio.c fileio.c
+index f1247c9..2c6b9e9 100644
+--- fileio.c
++++ fileio.c
+@@ -73,7 +73,14 @@ pkg_fgetline(char *line, size_t size, FILE *stream)
+ break;
+ }
+ else
++ {
++ if (quoted) {
++ *s++ = '\\';
++ quoted = false;
++ }
+ *s++ = c;
++ }
++
+ }
+
+ *s = '\0';
+diff --git tests/lib1/quotes.pc tests/lib1/quotes.pc
+new file mode 100644
+index 0000000..1aee256
+--- /dev/null
++++ tests/lib1/quotes.pc
+@@ -0,0 +1,10 @@
++prefix=/usr
++exec_prefix=${prefix}
++libdir=${prefix}/lib
++includedir=${prefix}/include
++
++Name: quotes
++Description: A testing pkg-config file
++Version: 1.2.3
++Libs: -L${libdir} -lfoo
++Cflags: -DQUOTED=\"bla\"
+diff --git tests/run.sh.in tests/run.sh.in
+index 231af22..ee50b3d 100644
+--- tests/run.sh.in
++++ tests/run.sh.in
+@@ -167,6 +167,10 @@ run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} --max-version 2.0 'foo '; echo \$
+ run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} --cflags missing-require; echo \$?" \
+ '1'
+
++# test quoted #35
++run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} --cflags quotes" \
++ "-DQUOTED=\\\"bla\\\""
++
+ # 10) tests for internal getopt implementation with options at the end
+ if [ "x@STRICT_MODE@" = "xno" ]; then
+ run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} foo --libs" \