aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-02 02:08:12 +0800
committerkrion <krion@FreeBSD.org>2003-11-02 02:08:12 +0800
commit7ed810480db0da146b9bac2b35c833a80f953b62 (patch)
tree3baa1c0a4dbc156d922d3f82cd7d1887f4041a1f /devel
parent2d3b18a848492a643a1f091c1e32306f6d16b104 (diff)
downloadfreebsd-ports-graphics-7ed810480db0da146b9bac2b35c833a80f953b62.tar.gz
freebsd-ports-graphics-7ed810480db0da146b9bac2b35c833a80f953b62.tar.zst
freebsd-ports-graphics-7ed810480db0da146b9bac2b35c833a80f953b62.zip
File::Path::Expand expands user directories in filenames. For
the simple case it's no more complex than s{^~/}{$HOME/}, but for other cases it consults C<getpwent> and does the right thing. PR: 58812 Submitted by: Lars Thegler <lars@thegler.dk>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Path-Expand/Makefile21
-rw-r--r--devel/p5-File-Path-Expand/distinfo1
-rw-r--r--devel/p5-File-Path-Expand/pkg-descr5
-rw-r--r--devel/p5-File-Path-Expand/pkg-plist5
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 02ff490eda7..02a48d4d9be 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -658,6 +658,7 @@
SUBDIR += p5-File-MMagic
SUBDIR += p5-File-NCopy
SUBDIR += p5-File-NFSLock
+ SUBDIR += p5-File-Path-Expand
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
SUBDIR += p5-File-Slurp
diff --git a/devel/p5-File-Path-Expand/Makefile b/devel/p5-File-Path-Expand/Makefile
new file mode 100644
index 00000000000..1cf19126446
--- /dev/null
+++ b/devel/p5-File-Path-Expand/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-File-Path-Expand
+# Date created: Sat Nov 1 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= File-Path-Expand
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Expand filenames
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Path::Expand.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Path-Expand/distinfo b/devel/p5-File-Path-Expand/distinfo
new file mode 100644
index 00000000000..d45e6e621cd
--- /dev/null
+++ b/devel/p5-File-Path-Expand/distinfo
@@ -0,0 +1 @@
+MD5 (File-Path-Expand-1.01.tar.gz) = 6f09799e04a24fbb2879e5e18437ebdf
diff --git a/devel/p5-File-Path-Expand/pkg-descr b/devel/p5-File-Path-Expand/pkg-descr
new file mode 100644
index 00000000000..863a0c5eac1
--- /dev/null
+++ b/devel/p5-File-Path-Expand/pkg-descr
@@ -0,0 +1,5 @@
+File::Path::Expand expands user directories in filenames. For the
+simple case it's no more complex than s{^~/}{$HOME/}, but for other
+cases it consults C<getpwent> and does the right thing.
+
+WWW: http://search.cpan.org/dist/File-Path-Expand
diff --git a/devel/p5-File-Path-Expand/pkg-plist b/devel/p5-File-Path-Expand/pkg-plist
new file mode 100644
index 00000000000..c963b342aa5
--- /dev/null
+++ b/devel/p5-File-Path-Expand/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/Path/Expand.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File-Path-Expand/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File-Path-Expand
+@unexec rmdir %D/%%SITE_PERL%%/File/Path 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true