aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-09-01 02:06:42 +0800
committerpav <pav@FreeBSD.org>2006-09-01 02:06:42 +0800
commit8549618b35dda00a1c8945b92937f1786254a2c6 (patch)
treeb5389a59de4f722342e22e6bb417d983739d0d8b /devel
parentb0b5ac7d0467c17777a53d7284494837e23ecbc6 (diff)
downloadfreebsd-ports-graphics-8549618b35dda00a1c8945b92937f1786254a2c6.tar.gz
freebsd-ports-graphics-8549618b35dda00a1c8945b92937f1786254a2c6.tar.zst
freebsd-ports-graphics-8549618b35dda00a1c8945b92937f1786254a2c6.zip
Levenshtein computes Levenshtein distances, similarity ratios, generalized
medians and set medians of Strings and Unicodes. Becuase it's implemented in C, it's much faster than corresponding Python library functions and methods. WWW: http://trific.ath.cx/resources/python/levenshtein/ PR: ports/102702 Submitted by: Aron Stansvik <elvstone@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-levenshtein/Makefile24
-rw-r--r--devel/py-levenshtein/distinfo3
-rw-r--r--devel/py-levenshtein/pkg-descr6
-rw-r--r--devel/py-levenshtein/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 28b75c6eaa8..fe0a4570b88 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1667,6 +1667,7 @@
SUBDIR += py-kid
SUBDIR += py-kjbuckets
SUBDIR += py-kqueue
+ SUBDIR += py-levenshtein
SUBDIR += py-ll-core
SUBDIR += py-log4py
SUBDIR += py-logging
diff --git a/devel/py-levenshtein/Makefile b/devel/py-levenshtein/Makefile
new file mode 100644
index 00000000000..42aaf70f3b3
--- /dev/null
+++ b/devel/py-levenshtein/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-levenshtein
+# Date created: 30 August 2006
+# Whom: Aron Stansvik <elvstone@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= levenshtein
+PORTVERSION= 0.10.1
+CATEGORIES= devel python
+MASTER_SITES= http://trific.ath.cx/Ftp/python/levenshtein/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-Levenshtein-${PORTVERSION}
+
+MAINTAINER= elvstone@gmail.com
+COMMENT= Python extension computing string distances and similarities
+
+WRKSRC= ${WRKDIR}/python-Levenshtein-${PORTVERSION}
+
+USE_PYTHON= 2.2+
+USE_PYTHON_PREFIX= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-levenshtein/distinfo b/devel/py-levenshtein/distinfo
new file mode 100644
index 00000000000..580f8dd32cd
--- /dev/null
+++ b/devel/py-levenshtein/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-Levenshtein-0.10.1.tar.gz) = c21cb043bb2951b3197a0447bd61aba4
+SHA256 (python-Levenshtein-0.10.1.tar.gz) = 0b39f0de210f8511af7c440c4d3d94ba8eb4b14a24677ee39750e4b2e75ed014
+SIZE (python-Levenshtein-0.10.1.tar.gz) = 41984
diff --git a/devel/py-levenshtein/pkg-descr b/devel/py-levenshtein/pkg-descr
new file mode 100644
index 00000000000..aa8a9060fcb
--- /dev/null
+++ b/devel/py-levenshtein/pkg-descr
@@ -0,0 +1,6 @@
+Levenshtein computes Levenshtein distances, similarity ratios, generalized
+medians and set medians of Strings and Unicodes. Becuase it's implemented
+in C, it's much faster than corresponding Python library functions and
+methods.
+
+WWW: http://trific.ath.cx/resources/python/levenshtein/
diff --git a/devel/py-levenshtein/pkg-plist b/devel/py-levenshtein/pkg-plist
new file mode 100644
index 00000000000..4d25f3a1f6a
--- /dev/null
+++ b/devel/py-levenshtein/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/Levenshtein.so