aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-03-13 19:23:02 +0800
committervs <vs@FreeBSD.org>2005-03-13 19:23:02 +0800
commit86d327ef553435f459ab608d81961a982ed870e5 (patch)
treed65d171a1ad17ff7a8e942fd288a960d12911cb9 /devel
parentb6a1b62475f00f8c9b116cc2b7ee66c9046e44c8 (diff)
downloadfreebsd-ports-graphics-86d327ef553435f459ab608d81961a982ed870e5.tar.gz
freebsd-ports-graphics-86d327ef553435f459ab608d81961a982ed870e5.tar.zst
freebsd-ports-graphics-86d327ef553435f459ab608d81961a982ed870e5.zip
Update to 3.10
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-hmake/Makefile12
-rw-r--r--devel/hs-hmake/distinfo4
-rw-r--r--devel/hs-hmake/files/patch-script::hi.inst11
3 files changed, 22 insertions, 5 deletions
diff --git a/devel/hs-hmake/Makefile b/devel/hs-hmake/Makefile
index 6fd05f1e6a2..13b62b24fcc 100644
--- a/devel/hs-hmake/Makefile
+++ b/devel/hs-hmake/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hmake
-PORTVERSION= 3.09
+PORTVERSION= 3.10
CATEGORIES= devel haskell
MASTER_SITES= http://www.haskell.org/hmake/ \
ftp://ftp.cs.york.ac.uk/pub/haskell/hmake/ \
@@ -16,7 +16,13 @@ PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
COMMENT= Intelligent compilation management tool for Haskell programs
+.include <bsd.port.pre.mk>
+
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+.if exists(${LOCALBASE}/lib/libreadline.so)
+LIB_DEPENDS= readline.5:${PORTSDIR}/devel/readline
+.endif
+RUN_DEPENDS= ${BUILD_DEPENDS}
HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --prefix=${PREFIX}
@@ -28,6 +34,6 @@ do-install:
MAN1= hmake.1
-CONFLICTS= nhc98-*
+CONFLICTS= nhc98-[0-9]*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/hs-hmake/distinfo b/devel/hs-hmake/distinfo
index 0beebb97786..b17ff3c2b04 100644
--- a/devel/hs-hmake/distinfo
+++ b/devel/hs-hmake/distinfo
@@ -1,2 +1,2 @@
-MD5 (hmake-3.09.tar.gz) = 72ac1fbca710dd8be5926600b119b4f4
-SIZE (hmake-3.09.tar.gz) = 100103
+MD5 (hmake-3.10.tar.gz) = 44eccd9574bb83e95ecedca29aa29d87
+SIZE (hmake-3.10.tar.gz) = 106380
diff --git a/devel/hs-hmake/files/patch-script::hi.inst b/devel/hs-hmake/files/patch-script::hi.inst
new file mode 100644
index 00000000000..51ca660cc1f
--- /dev/null
+++ b/devel/hs-hmake/files/patch-script::hi.inst
@@ -0,0 +1,11 @@
+--- script/hi.inst.orig Fri Mar 11 16:38:05 2005
++++ script/hi.inst Fri Mar 11 16:38:13 2005
+@@ -7,7 +7,7 @@
+ HMAKECONFDIR=${HMAKECONFDIR-ConfDir}
+ MACHINE=${MACHINE-"`$SCRIPTDIR/harch`"}
+ INSTALLVER="InstallVer"
+-export MACHINE INSTALLVER HMAKEDIR SCRIPTDIR
++export MACHINE INSTALLVER HMAKEDIR SCRIPTDIR HMAKECONFDIR
+
+ if [ ! -d $HMAKEDIR/$MACHINE ]
+ then