aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-05-28 05:50:37 +0800
committermiwi <miwi@FreeBSD.org>2007-05-28 05:50:37 +0800
commit890b2ae2ec5eb42be89129e07c04cf0a4f2dde01 (patch)
treeec06d0f9ec567a5e2ecce0e8f5248e8336ba4812 /devel
parent86e640e7a8a3ff935bff8816b26176724c1f9e5c (diff)
downloadfreebsd-ports-graphics-890b2ae2ec5eb42be89129e07c04cf0a4f2dde01.tar.gz
freebsd-ports-graphics-890b2ae2ec5eb42be89129e07c04cf0a4f2dde01.tar.zst
freebsd-ports-graphics-890b2ae2ec5eb42be89129e07c04cf0a4f2dde01.zip
Crow is a modern GUI builder for the GTK+ toolkit. It is an advanced
IDE-embeddable RAD tool designed to fulfill the needs of desktop programmers who want to create multi-platform GTK+ based applications with minimal GUI coding. Crow is full-featured yet lightweight: its tree-based Property Explorer solves many GUI constructing tasks in a versatile manner without additional popup dialogs. The project is targeted to develop a tool that is coherent and productive for experienced GTK+ users as well as simple and accessible for newcomers. WWW: http://crow-designer.sourceforge.net/ PR: ports/112618 Submitted by: Yinghong.Liu <liu_yinghong at yahoo.com.cn>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/crow/Makefile35
-rw-r--r--devel/crow/distinfo3
-rw-r--r--devel/crow/pkg-descr10
-rw-r--r--devel/crow/pkg-plist17
5 files changed, 66 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3fe803a6933..543ad74372c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -183,6 +183,7 @@
SUBDIR += cppi
SUBDIR += cppunit
SUBDIR += cproto
+ SUBDIR += crow
SUBDIR += cscope
SUBDIR += cscout
SUBDIR += cssc
diff --git a/devel/crow/Makefile b/devel/crow/Makefile
new file mode 100644
index 00000000000..1e9688e46b0
--- /dev/null
+++ b/devel/crow/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: crow
+# Date created: 11 May 2007
+# Whom: Yinghong.Liu <liu_yinghong@yahoo.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crow
+PORTVERSION= 2.11.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= crow-designer
+
+MAINTAINER= liu_yinghong@yahoo.com.cn
+COMMENT= A modern GUI builder for the GTK+ toolkit
+
+LIB_PC_DEPENDS= guiloader-c++.pc:${PORTSDIR}/devel/guiloader-c++
+
+LIB_DEPENDS+= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g} \
+ xdg-desktop-menu:${PORTSDIR}/devel/xdg-utils
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_GNOME= atk glib20 gtk20 pango
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/${PORTNAME}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/crow/distinfo b/devel/crow/distinfo
new file mode 100644
index 00000000000..80991317b8b
--- /dev/null
+++ b/devel/crow/distinfo
@@ -0,0 +1,3 @@
+MD5 (crow-2.11.0.tar.bz2) = efba3c1f10ef89581413f17ea542963c
+SHA256 (crow-2.11.0.tar.bz2) = 4390cbef9ae9d88cd40eb507663b665497ec4f1f73d22ca117b739b4de041297
+SIZE (crow-2.11.0.tar.bz2) = 362440
diff --git a/devel/crow/pkg-descr b/devel/crow/pkg-descr
new file mode 100644
index 00000000000..8a6c05051fb
--- /dev/null
+++ b/devel/crow/pkg-descr
@@ -0,0 +1,10 @@
+Crow is a modern GUI builder for the GTK+ toolkit. It is an advanced
+IDE-embeddable RAD tool designed to fulfill the needs of desktop programmers
+who want to create multi-platform GTK+ based applications with minimal
+GUI coding. Crow is full-featured yet lightweight: its tree-based Property
+Explorer solves many GUI constructing tasks in a versatile manner without
+additional popup dialogs. The project is targeted to develop a tool that
+is coherent and productive for experienced GTK+ users as well as simple
+and accessible for newcomers.
+
+WWW: http://crow-designer.sourceforge.net/
diff --git a/devel/crow/pkg-plist b/devel/crow/pkg-plist
new file mode 100644
index 00000000000..cf2bef31219
--- /dev/null
+++ b/devel/crow/pkg-plist
@@ -0,0 +1,17 @@
+bin/crow
+bin/crow-service
+include/crow/crow.h
+lib/libcrow.la
+lib/libcrow.so
+libdata/pkgconfig/crow.pc
+share/applications/crow.desktop
+share/mime/packages/crow.xml
+share/pixmaps/crow.png
+@dirrm share/mime/packages
+@dirrm share/mime
+@dirrmtry share/applications
+@dirrm include/crow
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true