aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-01-14 10:25:58 +0800
committeracm <acm@FreeBSD.org>2009-01-14 10:25:58 +0800
commit908270820c32ce977c436247acec5ebb4014c483 (patch)
tree13784964a04cff08ea8a7685f24a636e8f6f91d7 /devel
parente4dcf7429510d93364881ec76706c6fcf1d9c84d (diff)
downloadfreebsd-ports-graphics-908270820c32ce977c436247acec5ebb4014c483.tar.gz
freebsd-ports-graphics-908270820c32ce977c436247acec5ebb4014c483.tar.zst
freebsd-ports-graphics-908270820c32ce977c436247acec5ebb4014c483.zip
- New ports: devel/fpc-sdl
Free Pascal interface to SDL library
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/fpc-sdl/Makefile23
-rw-r--r--devel/fpc-sdl/pkg-plist36
3 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 58e9494396a..f60940c1121 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -352,6 +352,7 @@
SUBDIR += fortran-utils
SUBDIR += fortytwo-encore
SUBDIR += fpc-bfd
+ SUBDIR += fpc-sdl
SUBDIR += fpc-fcl-base
SUBDIR += fpc-fcl-db
SUBDIR += fpc-fcl-fpcunit
diff --git a/devel/fpc-sdl/Makefile b/devel/fpc-sdl/Makefile
new file mode 100644
index 00000000000..9643985b8e3
--- /dev/null
+++ b/devel/fpc-sdl/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-sdl
+# Date created: 2009-01-06
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTVERSION= 0
+CATEGORIES= devel lang
+PKGNAMESUFFIX= -sdl
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to SDL library
+
+USE_FPC= pthreads x11
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= SDL "Install SDL library" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-sdl/pkg-plist b/devel/fpc-sdl/pkg-plist
new file mode 100644
index 00000000000..5383a0a980a
--- /dev/null
+++ b/devel/fpc-sdl/pkg-plist
@@ -0,0 +1,36 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_image.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_mixer.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_mixer_nosmpeg.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_ttf.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_gfx.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_net.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/smpeg.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/logger.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdlutils.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_image.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_mixer.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_mixer_nosmpeg.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_ttf.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_gfx.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_net.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/smpeg.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/logger.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdlutils.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdl.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdl_image.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdl_mixer.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdl_mixer_nosmpeg.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdl_ttf.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdl_gfx.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdl_net.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsmpeg.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libplogger.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/libpsdlutils.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc