aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-09-17 22:54:09 +0800
committerdinoex <dinoex@FreeBSD.org>2009-09-17 22:54:09 +0800
commit91450a268945592d2b8d6a08f589a7f033303841 (patch)
tree1908d59b9ee139ac54c859ff36e66d5547fe037b /devel
parentaebfa57d49e9b223601f2378a9411d4ed0223ea9 (diff)
downloadfreebsd-ports-graphics-91450a268945592d2b8d6a08f589a7f033303841.tar.gz
freebsd-ports-graphics-91450a268945592d2b8d6a08f589a7f033303841.tar.zst
freebsd-ports-graphics-91450a268945592d2b8d6a08f589a7f033303841.zip
- enable support for plugins.
- new option WITHOUT_PLUGINS Suggested by: rdivacky Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/gold/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/gold/Makefile b/devel/gold/Makefile
index 36d50394245..1fe69df459d 100644
--- a/devel/gold/Makefile
+++ b/devel/gold/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gold
PORTVERSION= 1.9.0.2009.09.16
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.dinoex.de/pub/approved/
DISTNAME= binutils-${PORTNAME}-${PORTVERSION}
@@ -23,6 +24,9 @@ USE_PERL5_BUILD= yes
WRKSRC= ${WRKDIR}/binutils
PLIST_FILES= bin/ld-new
+OPTIONS= PLUGINS "Support fpr plugins" on \
+ NLS "Native language support" off
+
.include <bsd.port.pre.mk>
.if defined(WITH_NLS)
@@ -32,6 +36,10 @@ CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --disable-nls
.endif
+.if !defined(WITHOUT_PLUGINS)
+CONFIGURE_ARGS+= --enable-plugin
+.endif
+
do-configure:
.for i in . libiberty gold
-cd ${WRKSRC}/${i} && \