aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-06-28 06:15:04 +0800
committeradamw <adamw@FreeBSD.org>2016-06-28 06:15:04 +0800
commit9472fbb242641ae3a7e887306fa95bc2a98ac2b4 (patch)
treeb754e35b8623d76c5a63851ef479a9b0ab76338a /devel
parentb22a32b00787349416c1f73598f685eecbb01e36 (diff)
downloadfreebsd-ports-graphics-9472fbb242641ae3a7e887306fa95bc2a98ac2b4.tar.gz
freebsd-ports-graphics-9472fbb242641ae3a7e887306fa95bc2a98ac2b4.tar.zst
freebsd-ports-graphics-9472fbb242641ae3a7e887306fa95bc2a98ac2b4.zip
Update to 8.39. Introduce a "MAN3" option, to control installation of
~100 API manpages. Remove the bits about preventing coredumps on package clusters during regression tests, because I'm not clear why the package clusters would be running the regression tests. Rewrite the pkg-descr using current text from pcre.org. While here, clean up and reorganize the Makefile for simplicity and clarity.
Diffstat (limited to 'devel')
-rw-r--r--devel/pcre/Makefile59
-rw-r--r--devel/pcre/distinfo5
-rw-r--r--devel/pcre/files/patch-CVE-2016-128318
-rw-r--r--devel/pcre/files/patch-CVE-2016-319194
-rw-r--r--devel/pcre/pkg-descr9
-rw-r--r--devel/pcre/pkg-plist208
6 files changed, 134 insertions, 259 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index 4beb9382da6..e70df30d81b 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pcre
-PORTVERSION= 8.38
-PORTREVISION= 1
+PORTVERSION= 8.39
CATEGORIES= devel
MASTER_SITES= SF \
ftp://ftp.csx.cam.ac.uk/pub/software/programming/${PORTNAME}/ \
@@ -16,38 +15,36 @@ COMMENT= Perl Compatible Regular Expressions library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENCE
-GNU_CONFIGURE= yes
USES= libtool pathfix tar:bzip2
USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-utf --enable-unicode-properties \
--enable-pcre8 --enable-pcre16 --enable-pcre32
+
INSTALL_TARGET= install-strip
+TEST_TARGET= check
-OPTIONS_DEFINE= DOCS STACK_RECURSION
-OPTIONS_DEFAULT= STACK_RECURSION
-OPTIONS_RADIO= CLI
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS MAN3 STACK_RECURSION
+OPTIONS_DEFAULT= MAN3 STACK_RECURSION
+OPTIONS_SUB= yes
+
+OPTIONS_RADIO= CLI
OPTIONS_RADIO_CLI= LIBEDIT READLINE
+MAN3_DESC= Install API manpages (section 3)
STACK_RECURSION_DESC= Use the stack for recursion during matching
-LIBEDIT_CONFIGURE_ENABLE= pcretest-libedit
LIBEDIT_USES= libedit
+LIBEDIT_CONFIGURE_ENABLE= pcretest-libedit
READLINE_USES= readline
READLINE_CONFIGURE_ENABLE= pcretest-libreadline
.include <bsd.port.options.mk>
-.if ${ARCH} != "sparc64" && ${ARCH} != "ia64" && ${ARCH:Mmips64*} == ""
-CONFIGURE_ARGS+= --enable-jit
-.else
-CONFIGURE_ARGS+= --disable-jit
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-.endif
-
# Using the heap rather than the stack for recursion is slower but less
# prone to segfaults from stack exhaustion when matching certain patterns
.if !${PORT_OPTIONS:MSTACK_RECURSION}
@@ -87,29 +84,19 @@ CONFIGURE_ARGS+= --with-parens-nest-limit=${WITH_PARENS_NEST_LIMIT}
CONFIGURE_ARGS+= --with-posix-malloc-threshold=${WITH_POSIX_MALLOC_THRESHOLD}
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "sparc64" && ${ARCH} != "ia64" && ${ARCH:Mmips64*} == ""
+CONFIGURE_ARGS+= --enable-jit
+.else
+CONFIGURE_ARGS+= --disable-jit
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "/^\.rs/d" ${WRKSRC}/doc/*.3 ${WRKSRC}/doc/*.1
@${REINPLACE_CMD} -e "s/£//g" ${WRKSRC}/doc/pcre_compile2.3
-.if !${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -E -e '/^install-data-am/,/^$$/ s,install-(dist_doc|dist_html|html)DATA,,g' \
- ${WRKSRC}/Makefile.in
-.endif
-
-#prevent regression test coredumps from causing failures on the
-#package-building cluster:
-.ifndef(MAINTAINER_MODE)
-CORELIMIT?= /usr/bin/limits -Sc 0
-.endif
-TESTLOGS?= RunGrepTest RunTest pcre_jit_test pcre_scanner_unittest \
- pcre_stringpiece_unittest pcrecpp_unittest
post-stage:
${LN} -s libpcre.so.1 ${STAGEDIR}${PREFIX}/lib/libpcre.so.3
-check regression-test test: build
- @cd ${WRKSRC} ; \
- ${SETENV} ${MAKE_ENV} ${CORELIMIT} ${MAKE_CMD} ${MAKE_ARGS} check ; \
- for _l in ${TESTLOGS} ; do if ${TEST} -f $${_l}.log ; then \
- ${PRINTF} "\n\n$${_l}.log\n\n\n" ; ${CAT} $${_l}.log ; fi ; done
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/pcre/distinfo b/devel/pcre/distinfo
index 72b7b5035b5..2c4c469c5cd 100644
--- a/devel/pcre/distinfo
+++ b/devel/pcre/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pcre-8.38.tar.bz2) = b9e02d36e23024d6c02a2e5b25204b3a4fa6ade43e0a5f869f254f49535079df
-SIZE (pcre-8.38.tar.bz2) = 1562265
+TIMESTAMP = 1467064459
+SHA256 (pcre-8.39.tar.bz2) = b858099f82483031ee02092711689e7245586ada49e534a06e678b8ea9549e8b
+SIZE (pcre-8.39.tar.bz2) = 1560758
diff --git a/devel/pcre/files/patch-CVE-2016-1283 b/devel/pcre/files/patch-CVE-2016-1283
deleted file mode 100644
index 2488bc03a87..00000000000
--- a/devel/pcre/files/patch-CVE-2016-1283
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: pcre_compile.c
-===================================================================
---- pcre_compile.c (revision 1635)
-+++ pcre_compile.c (revision 1636)
-@@ -7311,7 +7311,12 @@
- so far in order to get the number. If the name is not found, leave
- the value of recno as 0 for a forward reference. */
-
-- else
-+ /* This patch (removing "else") fixes a problem when a reference is
-+ to multiple identically named nested groups from within the nest.
-+ Once again, it is not the "proper" fix, and it results in an
-+ over-allocation of memory. */
-+
-+ /* else */
- {
- ng = cd->named_groups;
- for (i = 0; i < cd->names_found; i++, ng++)
diff --git a/devel/pcre/files/patch-CVE-2016-3191 b/devel/pcre/files/patch-CVE-2016-3191
deleted file mode 100644
index db66f3b29e0..00000000000
--- a/devel/pcre/files/patch-CVE-2016-3191
+++ /dev/null
@@ -1,94 +0,0 @@
---- pcre_compile.c 2016/02/10 10:53:45 1630
-+++ pcre_compile.c 2016/02/10 19:13:17 1631
-@@ -6,7 +6,7 @@
- and semantics are as close as possible to those of the Perl 5 language.
-
- Written by Philip Hazel
-- Copyright (c) 1997-2014 University of Cambridge
-+ Copyright (c) 1997-2016 University of Cambridge
-
- -----------------------------------------------------------------------------
- Redistribution and use in source and binary forms, with or without
-@@ -560,6 +560,7 @@
- /* 85 */
- "parentheses are too deeply nested (stack check)\0"
- "digits missing in \\x{} or \\o{}\0"
-+ "regular expression is too complicated\0"
- ;
-
- /* Table to identify digits and hex digits. This is used when compiling
-@@ -4591,7 +4592,8 @@
- if (code > cd->start_workspace + cd->workspace_size -
- WORK_SIZE_SAFETY_MARGIN) /* Check for overrun */
- {
-- *errorcodeptr = ERR52;
-+ *errorcodeptr = (code >= cd->start_workspace + cd->workspace_size)?
-+ ERR52 : ERR87;
- goto FAILED;
- }
-
-@@ -6626,8 +6628,21 @@
- cd->had_accept = TRUE;
- for (oc = cd->open_caps; oc != NULL; oc = oc->next)
- {
-- *code++ = OP_CLOSE;
-- PUT2INC(code, 0, oc->number);
-+ if (lengthptr != NULL)
-+ {
-+#ifdef COMPILE_PCRE8
-+ *lengthptr += 1 + IMM2_SIZE;
-+#elif defined COMPILE_PCRE16
-+ *lengthptr += 2 + IMM2_SIZE;
-+#elif defined COMPILE_PCRE32
-+ *lengthptr += 4 + IMM2_SIZE;
-+#endif
-+ }
-+ else
-+ {
-+ *code++ = OP_CLOSE;
-+ PUT2INC(code, 0, oc->number);
-+ }
- }
- setverb = *code++ =
- (cd->assert_depth > 0)? OP_ASSERT_ACCEPT : OP_ACCEPT;
---- pcre_internal.h 2016/02/10 10:53:45 1630
-+++ pcre_internal.h 2016/02/10 19:13:17 1631
-@@ -7,7 +7,7 @@
- and semantics are as close as possible to those of the Perl 5 language.
-
- Written by Philip Hazel
-- Copyright (c) 1997-2014 University of Cambridge
-+ Copyright (c) 1997-2016 University of Cambridge
-
- -----------------------------------------------------------------------------
- Redistribution and use in source and binary forms, with or without
-@@ -2289,7 +2289,7 @@
- ERR50, ERR51, ERR52, ERR53, ERR54, ERR55, ERR56, ERR57, ERR58, ERR59,
- ERR60, ERR61, ERR62, ERR63, ERR64, ERR65, ERR66, ERR67, ERR68, ERR69,
- ERR70, ERR71, ERR72, ERR73, ERR74, ERR75, ERR76, ERR77, ERR78, ERR79,
-- ERR80, ERR81, ERR82, ERR83, ERR84, ERR85, ERR86, ERRCOUNT };
-+ ERR80, ERR81, ERR82, ERR83, ERR84, ERR85, ERR86, ERR87, ERRCOUNT };
-
- /* JIT compiling modes. The function list is indexed by them. */
-
---- pcreposix.c 2016/02/10 10:53:45 1630
-+++ pcreposix.c 2016/02/10 19:13:17 1631
-@@ -6,7 +6,7 @@
- and semantics are as close as possible to those of the Perl 5 language.
-
- Written by Philip Hazel
-- Copyright (c) 1997-2014 University of Cambridge
-+ Copyright (c) 1997-2016 University of Cambridge
-
- -----------------------------------------------------------------------------
- Redistribution and use in source and binary forms, with or without
-@@ -173,7 +173,8 @@
- REG_BADPAT, /* group name must start with a non-digit */
- /* 85 */
- REG_BADPAT, /* parentheses too deeply nested (stack check) */
-- REG_BADPAT /* missing digits in \x{} or \o{} */
-+ REG_BADPAT, /* missing digits in \x{} or \o{} */
-+ REG_BADPAT /* pattern too complicated */
- };
-
- /* Table of texts corresponding to POSIX error codes */
diff --git a/devel/pcre/pkg-descr b/devel/pcre/pkg-descr
index 1d834bdcddc..a95da7d71d6 100644
--- a/devel/pcre/pkg-descr
+++ b/devel/pcre/pkg-descr
@@ -1,8 +1,7 @@
The PCRE library is a set of functions that implement regular expression
-pattern matching using the same syntax and semantics as Perl 5, with just
-a few differences. The current implementation corresponds to Perl 5.005.
-PCRE is used by many programs, including Exim, Postfix, and PHP.
-
-Written by: Phil Hazel <ph10@cam.ac.uk>
+pattern matching using the same syntax and semantics as Perl 5. PCRE has its
+own native API, as well as a set of wrapper functions that correspond to the
+POSIX regular expression API. The PCRE library is free, even for building
+proprietary software.
WWW: http://www.pcre.org/
diff --git a/devel/pcre/pkg-plist b/devel/pcre/pkg-plist
index aabc0c2a76f..f5e8f211a95 100644
--- a/devel/pcre/pkg-plist
+++ b/devel/pcre/pkg-plist
@@ -10,16 +10,16 @@ include/pcrecpp.h
lib/libpcre.a
lib/libpcre.so
lib/libpcre.so.1
-lib/libpcre.so.1.2.6
+lib/libpcre.so.1.2.7
lib/libpcre.so.3
lib/libpcre16.a
lib/libpcre16.so
lib/libpcre16.so.0
-lib/libpcre16.so.0.2.6
+lib/libpcre16.so.0.2.7
lib/libpcre32.a
lib/libpcre32.so
lib/libpcre32.so.0
-lib/libpcre32.so.0.0.6
+lib/libpcre32.so.0.0.7
lib/libpcrecpp.a
lib/libpcrecpp.so
lib/libpcrecpp.so.0
@@ -27,7 +27,7 @@ lib/libpcrecpp.so.0.0.1
lib/libpcreposix.a
lib/libpcreposix.so
lib/libpcreposix.so.0
-lib/libpcreposix.so.0.0.3
+lib/libpcreposix.so.0.0.4
libdata/pkgconfig/libpcre.pc
libdata/pkgconfig/libpcre16.pc
libdata/pkgconfig/libpcre32.pc
@@ -36,103 +36,103 @@ libdata/pkgconfig/libpcreposix.pc
man/man1/pcre-config.1.gz
man/man1/pcregrep.1.gz
man/man1/pcretest.1.gz
-man/man3/pcre.3.gz
-man/man3/pcre16.3.gz
-man/man3/pcre16_assign_jit_stack.3.gz
-man/man3/pcre16_compile.3.gz
-man/man3/pcre16_compile2.3.gz
-man/man3/pcre16_config.3.gz
-man/man3/pcre16_copy_named_substring.3.gz
-man/man3/pcre16_copy_substring.3.gz
-man/man3/pcre16_dfa_exec.3.gz
-man/man3/pcre16_exec.3.gz
-man/man3/pcre16_free_study.3.gz
-man/man3/pcre16_free_substring.3.gz
-man/man3/pcre16_free_substring_list.3.gz
-man/man3/pcre16_fullinfo.3.gz
-man/man3/pcre16_get_named_substring.3.gz
-man/man3/pcre16_get_stringnumber.3.gz
-man/man3/pcre16_get_stringtable_entries.3.gz
-man/man3/pcre16_get_substring.3.gz
-man/man3/pcre16_get_substring_list.3.gz
-man/man3/pcre16_jit_exec.3.gz
-man/man3/pcre16_jit_stack_alloc.3.gz
-man/man3/pcre16_jit_stack_free.3.gz
-man/man3/pcre16_maketables.3.gz
-man/man3/pcre16_pattern_to_host_byte_order.3.gz
-man/man3/pcre16_refcount.3.gz
-man/man3/pcre16_study.3.gz
-man/man3/pcre16_utf16_to_host_byte_order.3.gz
-man/man3/pcre16_version.3.gz
-man/man3/pcre32.3.gz
-man/man3/pcre32_assign_jit_stack.3.gz
-man/man3/pcre32_compile.3.gz
-man/man3/pcre32_compile2.3.gz
-man/man3/pcre32_config.3.gz
-man/man3/pcre32_copy_named_substring.3.gz
-man/man3/pcre32_copy_substring.3.gz
-man/man3/pcre32_dfa_exec.3.gz
-man/man3/pcre32_exec.3.gz
-man/man3/pcre32_free_study.3.gz
-man/man3/pcre32_free_substring.3.gz
-man/man3/pcre32_free_substring_list.3.gz
-man/man3/pcre32_fullinfo.3.gz
-man/man3/pcre32_get_named_substring.3.gz
-man/man3/pcre32_get_stringnumber.3.gz
-man/man3/pcre32_get_stringtable_entries.3.gz
-man/man3/pcre32_get_substring.3.gz
-man/man3/pcre32_get_substring_list.3.gz
-man/man3/pcre32_jit_exec.3.gz
-man/man3/pcre32_jit_stack_alloc.3.gz
-man/man3/pcre32_jit_stack_free.3.gz
-man/man3/pcre32_maketables.3.gz
-man/man3/pcre32_pattern_to_host_byte_order.3.gz
-man/man3/pcre32_refcount.3.gz
-man/man3/pcre32_study.3.gz
-man/man3/pcre32_utf32_to_host_byte_order.3.gz
-man/man3/pcre32_version.3.gz
-man/man3/pcre_assign_jit_stack.3.gz
-man/man3/pcre_compile.3.gz
-man/man3/pcre_compile2.3.gz
-man/man3/pcre_config.3.gz
-man/man3/pcre_copy_named_substring.3.gz
-man/man3/pcre_copy_substring.3.gz
-man/man3/pcre_dfa_exec.3.gz
-man/man3/pcre_exec.3.gz
-man/man3/pcre_free_study.3.gz
-man/man3/pcre_free_substring.3.gz
-man/man3/pcre_free_substring_list.3.gz
-man/man3/pcre_fullinfo.3.gz
-man/man3/pcre_get_named_substring.3.gz
-man/man3/pcre_get_stringnumber.3.gz
-man/man3/pcre_get_stringtable_entries.3.gz
-man/man3/pcre_get_substring.3.gz
-man/man3/pcre_get_substring_list.3.gz
-man/man3/pcre_jit_exec.3.gz
-man/man3/pcre_jit_stack_alloc.3.gz
-man/man3/pcre_jit_stack_free.3.gz
-man/man3/pcre_maketables.3.gz
-man/man3/pcre_pattern_to_host_byte_order.3.gz
-man/man3/pcre_refcount.3.gz
-man/man3/pcre_study.3.gz
-man/man3/pcre_utf16_to_host_byte_order.3.gz
-man/man3/pcre_utf32_to_host_byte_order.3.gz
-man/man3/pcre_version.3.gz
-man/man3/pcreapi.3.gz
-man/man3/pcrebuild.3.gz
-man/man3/pcrecallout.3.gz
-man/man3/pcrecompat.3.gz
-man/man3/pcrecpp.3.gz
-man/man3/pcredemo.3.gz
-man/man3/pcrejit.3.gz
-man/man3/pcrelimits.3.gz
-man/man3/pcrematching.3.gz
-man/man3/pcrepartial.3.gz
-man/man3/pcrepattern.3.gz
-man/man3/pcreperform.3.gz
-man/man3/pcreposix.3.gz
-man/man3/pcreprecompile.3.gz
-man/man3/pcresample.3.gz
-man/man3/pcrestack.3.gz
-man/man3/pcresyntax.3.gz
-man/man3/pcreunicode.3.gz
+%%MAN3%%man/man3/pcre.3.gz
+%%MAN3%%man/man3/pcre16.3.gz
+%%MAN3%%man/man3/pcre16_assign_jit_stack.3.gz
+%%MAN3%%man/man3/pcre16_compile.3.gz
+%%MAN3%%man/man3/pcre16_compile2.3.gz
+%%MAN3%%man/man3/pcre16_config.3.gz
+%%MAN3%%man/man3/pcre16_copy_named_substring.3.gz
+%%MAN3%%man/man3/pcre16_copy_substring.3.gz
+%%MAN3%%man/man3/pcre16_dfa_exec.3.gz
+%%MAN3%%man/man3/pcre16_exec.3.gz
+%%MAN3%%man/man3/pcre16_free_study.3.gz
+%%MAN3%%man/man3/pcre16_free_substring.3.gz
+%%MAN3%%man/man3/pcre16_free_substring_list.3.gz
+%%MAN3%%man/man3/pcre16_fullinfo.3.gz
+%%MAN3%%man/man3/pcre16_get_named_substring.3.gz
+%%MAN3%%man/man3/pcre16_get_stringnumber.3.gz
+%%MAN3%%man/man3/pcre16_get_stringtable_entries.3.gz
+%%MAN3%%man/man3/pcre16_get_substring.3.gz
+%%MAN3%%man/man3/pcre16_get_substring_list.3.gz
+%%MAN3%%man/man3/pcre16_jit_exec.3.gz
+%%MAN3%%man/man3/pcre16_jit_stack_alloc.3.gz
+%%MAN3%%man/man3/pcre16_jit_stack_free.3.gz
+%%MAN3%%man/man3/pcre16_maketables.3.gz
+%%MAN3%%man/man3/pcre16_pattern_to_host_byte_order.3.gz
+%%MAN3%%man/man3/pcre16_refcount.3.gz
+%%MAN3%%man/man3/pcre16_study.3.gz
+%%MAN3%%man/man3/pcre16_utf16_to_host_byte_order.3.gz
+%%MAN3%%man/man3/pcre16_version.3.gz
+%%MAN3%%man/man3/pcre32.3.gz
+%%MAN3%%man/man3/pcre32_assign_jit_stack.3.gz
+%%MAN3%%man/man3/pcre32_compile.3.gz
+%%MAN3%%man/man3/pcre32_compile2.3.gz
+%%MAN3%%man/man3/pcre32_config.3.gz
+%%MAN3%%man/man3/pcre32_copy_named_substring.3.gz
+%%MAN3%%man/man3/pcre32_copy_substring.3.gz
+%%MAN3%%man/man3/pcre32_dfa_exec.3.gz
+%%MAN3%%man/man3/pcre32_exec.3.gz
+%%MAN3%%man/man3/pcre32_free_study.3.gz
+%%MAN3%%man/man3/pcre32_free_substring.3.gz
+%%MAN3%%man/man3/pcre32_free_substring_list.3.gz
+%%MAN3%%man/man3/pcre32_fullinfo.3.gz
+%%MAN3%%man/man3/pcre32_get_named_substring.3.gz
+%%MAN3%%man/man3/pcre32_get_stringnumber.3.gz
+%%MAN3%%man/man3/pcre32_get_stringtable_entries.3.gz
+%%MAN3%%man/man3/pcre32_get_substring.3.gz
+%%MAN3%%man/man3/pcre32_get_substring_list.3.gz
+%%MAN3%%man/man3/pcre32_jit_exec.3.gz
+%%MAN3%%man/man3/pcre32_jit_stack_alloc.3.gz
+%%MAN3%%man/man3/pcre32_jit_stack_free.3.gz
+%%MAN3%%man/man3/pcre32_maketables.3.gz
+%%MAN3%%man/man3/pcre32_pattern_to_host_byte_order.3.gz
+%%MAN3%%man/man3/pcre32_refcount.3.gz
+%%MAN3%%man/man3/pcre32_study.3.gz
+%%MAN3%%man/man3/pcre32_utf32_to_host_byte_order.3.gz
+%%MAN3%%man/man3/pcre32_version.3.gz
+%%MAN3%%man/man3/pcre_assign_jit_stack.3.gz
+%%MAN3%%man/man3/pcre_compile.3.gz
+%%MAN3%%man/man3/pcre_compile2.3.gz
+%%MAN3%%man/man3/pcre_config.3.gz
+%%MAN3%%man/man3/pcre_copy_named_substring.3.gz
+%%MAN3%%man/man3/pcre_copy_substring.3.gz
+%%MAN3%%man/man3/pcre_dfa_exec.3.gz
+%%MAN3%%man/man3/pcre_exec.3.gz
+%%MAN3%%man/man3/pcre_free_study.3.gz
+%%MAN3%%man/man3/pcre_free_substring.3.gz
+%%MAN3%%man/man3/pcre_free_substring_list.3.gz
+%%MAN3%%man/man3/pcre_fullinfo.3.gz
+%%MAN3%%man/man3/pcre_get_named_substring.3.gz
+%%MAN3%%man/man3/pcre_get_stringnumber.3.gz
+%%MAN3%%man/man3/pcre_get_stringtable_entries.3.gz
+%%MAN3%%man/man3/pcre_get_substring.3.gz
+%%MAN3%%man/man3/pcre_get_substring_list.3.gz
+%%MAN3%%man/man3/pcre_jit_exec.3.gz
+%%MAN3%%man/man3/pcre_jit_stack_alloc.3.gz
+%%MAN3%%man/man3/pcre_jit_stack_free.3.gz
+%%MAN3%%man/man3/pcre_maketables.3.gz
+%%MAN3%%man/man3/pcre_pattern_to_host_byte_order.3.gz
+%%MAN3%%man/man3/pcre_refcount.3.gz
+%%MAN3%%man/man3/pcre_study.3.gz
+%%MAN3%%man/man3/pcre_utf16_to_host_byte_order.3.gz
+%%MAN3%%man/man3/pcre_utf32_to_host_byte_order.3.gz
+%%MAN3%%man/man3/pcre_version.3.gz
+%%MAN3%%man/man3/pcreapi.3.gz
+%%MAN3%%man/man3/pcrebuild.3.gz
+%%MAN3%%man/man3/pcrecallout.3.gz
+%%MAN3%%man/man3/pcrecompat.3.gz
+%%MAN3%%man/man3/pcrecpp.3.gz
+%%MAN3%%man/man3/pcredemo.3.gz
+%%MAN3%%man/man3/pcrejit.3.gz
+%%MAN3%%man/man3/pcrelimits.3.gz
+%%MAN3%%man/man3/pcrematching.3.gz
+%%MAN3%%man/man3/pcrepartial.3.gz
+%%MAN3%%man/man3/pcrepattern.3.gz
+%%MAN3%%man/man3/pcreperform.3.gz
+%%MAN3%%man/man3/pcreposix.3.gz
+%%MAN3%%man/man3/pcreprecompile.3.gz
+%%MAN3%%man/man3/pcresample.3.gz
+%%MAN3%%man/man3/pcrestack.3.gz
+%%MAN3%%man/man3/pcresyntax.3.gz
+%%MAN3%%man/man3/pcreunicode.3.gz