aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-08-05 01:48:00 +0800
committerpi <pi@FreeBSD.org>2016-08-05 01:48:00 +0800
commit97217109fe03575175e651aeb83704df641dba17 (patch)
treed7e54a87b5dbab66fb9de9ed9227dc1537fe6ac3 /devel
parent4eec0dd6f1ccd9553dcfac99c314118f33a80803 (diff)
downloadfreebsd-ports-graphics-97217109fe03575175e651aeb83704df641dba17.tar.gz
freebsd-ports-graphics-97217109fe03575175e651aeb83704df641dba17.tar.zst
freebsd-ports-graphics-97217109fe03575175e651aeb83704df641dba17.zip
New port: devel/py-apptools
The apptools project includes a set of packages that Enthought has found useful in creating a number of applications. - apptools.appscripting: Framework for scripting applications. - apptools.help: Provides a plugin for displaying documents and examples. - apptools.io: Provides an abstraction for files and folders in a file system. - apptools.logger: Convenience functions for creating logging handlers - apptools.naming: Manages naming contexts, supporting non-string data types and scoped preferences - apptools.permissions: Supports limiting access to parts of an application unless the user is appropriately authorised (not full-blown security). - apptools.persistence: Supports pickling and restoring the state of an object. - apptools.preferences: Manages application preferences. - apptools.selection: Manages the communication between providers and listener of selected items in an application. - apptools.scripting: A framework for automatic recording of Python scripts. - apptools.sweet_pickle: Handles class-level versioning, to support loading of saved data that exist over several generations of internal class structures. - apptools.template: Supports creating templatizable object hierarchies. - apptools.type_manager: Manages type extensions, including factories to generate adapters, and hooks for methods and functions. - apptools.undo: Supports undoing and scripting application commands. WWW: https://docs.enthought.com/apptools PR: 204431 Submitted by: Vladimir Chukharev <vladimir.chukharev@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-apptools/Makefile25
-rw-r--r--devel/py-apptools/distinfo3
-rw-r--r--devel/py-apptools/pkg-descr27
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b1d7b657838..3d2097abfd2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3970,6 +3970,7 @@
SUBDIR += py-apipkg
SUBDIR += py-appdirs
SUBDIR += py-application
+ SUBDIR += py-apptools
SUBDIR += py-apscheduler
SUBDIR += py-archetypes.querywidget
SUBDIR += py-archetypes.referencebrowserwidget
diff --git a/devel/py-apptools/Makefile b/devel/py-apptools/Makefile
new file mode 100644
index 00000000000..2c8a5861d1c
--- /dev/null
+++ b/devel/py-apptools/Makefile
@@ -0,0 +1,25 @@
+# Created by: Vladimir Chukharev
+# $FreeBSD$
+
+PORTNAME= apptools
+PORTVERSION= 4.4.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= Vladimir.Chukharev@gmail.com
+COMMENT= Enthought application tools
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+# See ${WRKSRC}/image_LICENSE.txt for information that other
+# files *LICENSE* are not used
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traits>=4.5.0:devel/py-traits \
+ ${PYTHON_PKGNAMEPREFIX}configobj>=5.0.:devel/py-configobj
+
+USES= python:-2.7
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-apptools/distinfo b/devel/py-apptools/distinfo
new file mode 100644
index 00000000000..6d1f46d87e1
--- /dev/null
+++ b/devel/py-apptools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470314773
+SHA256 (apptools-4.4.0.tar.gz) = 73f5c2344d8d36b81f164e9e576425749e91342cf9e8615f3d72627af0de86b7
+SIZE (apptools-4.4.0.tar.gz) = 294669
diff --git a/devel/py-apptools/pkg-descr b/devel/py-apptools/pkg-descr
new file mode 100644
index 00000000000..f6a62fcbe4f
--- /dev/null
+++ b/devel/py-apptools/pkg-descr
@@ -0,0 +1,27 @@
+The apptools project includes a set of packages that Enthought has
+found useful in creating a number of applications.
+
+- apptools.appscripting: Framework for scripting applications.
+- apptools.help: Provides a plugin for displaying documents and examples.
+- apptools.io: Provides an abstraction for files and folders in a
+ file system.
+- apptools.logger: Convenience functions for creating logging handlers
+- apptools.naming: Manages naming contexts, supporting non-string data
+ types and scoped preferences
+- apptools.permissions: Supports limiting access to parts of an application
+ unless the user is appropriately authorised (not full-blown security).
+- apptools.persistence: Supports pickling and restoring the state of an
+ object.
+- apptools.preferences: Manages application preferences.
+- apptools.selection: Manages the communication between providers and
+ listener of selected items in an application.
+- apptools.scripting: A framework for automatic recording of Python scripts.
+- apptools.sweet_pickle: Handles class-level versioning, to support
+ loading of saved data that exist over several generations of
+ internal class structures.
+- apptools.template: Supports creating templatizable object hierarchies.
+- apptools.type_manager: Manages type extensions, including factories to
+ generate adapters, and hooks for methods and functions.
+- apptools.undo: Supports undoing and scripting application commands.
+
+WWW: https://docs.enthought.com/apptools