aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-12-07 18:28:15 +0800
committerknu <knu@FreeBSD.org>2002-12-07 18:28:15 +0800
commit9d6cafa93f7da6df9950986627a6bdbe913a04ce (patch)
treec1ee683b567c949f3a5dfaa9a2cb8c758497f256 /devel
parent00e3d773bc4b65d52f392f02a38e0aab373cc529 (diff)
downloadfreebsd-ports-graphics-9d6cafa93f7da6df9950986627a6bdbe913a04ce.tar.gz
freebsd-ports-graphics-9d6cafa93f7da6df9950986627a6bdbe913a04ce.tar.zst
freebsd-ports-graphics-9d6cafa93f7da6df9950986627a6bdbe913a04ce.zip
Do not build the profiled library on 5-CURRENT, where g++ -pg produces
strange function calls that the assembler cannot understand. Submitted by: bento http://bento.freebsd.org/errorlogs/5-latest/rudiments-0.24.log
Diffstat (limited to 'devel')
-rw-r--r--devel/rudiments/Makefile12
-rw-r--r--devel/rudiments/files/extra-patch-src+Makefile.in25
-rw-r--r--devel/rudiments/pkg-plist2
3 files changed, 37 insertions, 2 deletions
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index 6c1f375561c..c6f1c207524 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -21,9 +21,19 @@ MAKE_ARGS= VERSION="${PORTVERSION:R}"
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-*
+
+PLIST_SUB+= PROFILE="@comment "
+.else
+PLIST_SUB+= PROFILE=""
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${MAKE} doc-install
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/rudiments/files/extra-patch-src+Makefile.in b/devel/rudiments/files/extra-patch-src+Makefile.in
new file mode 100644
index 00000000000..c059fcc336b
--- /dev/null
+++ b/devel/rudiments/files/extra-patch-src+Makefile.in
@@ -0,0 +1,25 @@
+--- src/Makefile.in.orig Mon Apr 15 13:21:24 2002
++++ src/Makefile.in Sat Dec 7 19:27:01 2002
+@@ -17,7 +17,6 @@
+
+ all:
+ $(MAKE) ../lib/librudiments.a; \
+- $(MAKE) ../lib/librudiments_p.a; \
+ if ( test ! -n "@MINGW32@" -a ! -n "@CYGWIN@" -a ! -n "@UWIN@" ); then \
+ $(MAKE) ../lib/librudiments.so.$(VERSION); \
+ else \
+@@ -48,7 +47,6 @@
+ install:
+ $(top_srcdir)/mkinstalldirs $(libdir)
+ $(INSTALL) -m 644 ../lib/librudiments.a $(libdir); \
+- $(INSTALL) -m 644 ../lib/librudiments_p.a $(libdir); \
+ if ( test ! -n "@MINGW32@" -a ! -n "@CYGWIN@" -a ! -n "@UWIN@" ); then \
+ $(RM) $(libdir)/librudiments.so*; \
+ $(INSTALL) ../lib/librudiments.so.$(VERSION) $(libdir); \
+@@ -62,6 +60,5 @@
+ uninstall:
+ $(RM) $(libdir)/librudiments.so*
+ $(RM) $(libdir)/librudiments.a
+- $(RM) $(libdir)/librudiments_p.a
+ $(RM) $(libdir)/librudiments.dll
+ $(RM) $(libdir)/librudiments.lib
diff --git a/devel/rudiments/pkg-plist b/devel/rudiments/pkg-plist
index 225b98d8e0c..498d2aaa740 100644
--- a/devel/rudiments/pkg-plist
+++ b/devel/rudiments/pkg-plist
@@ -30,7 +30,7 @@ include/rudiments/private/socketnode.h
lib/librudiments.a
lib/librudiments.so
lib/librudiments.so.0
-lib/librudiments_p.a
+%%PROFILE%%lib/librudiments_p.a
%%PORTDOCS%%share/doc/rudiments/classes/clientsocket.h.html
%%PORTDOCS%%share/doc/rudiments/classes/commandline.h.html
%%PORTDOCS%%share/doc/rudiments/classes/daemonprocess.h.html