aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-09-17 23:26:27 +0800
committerkwm <kwm@FreeBSD.org>2015-09-17 23:26:27 +0800
commita08b07cecb7ac8a17cb5f04229d04223e67c2fb9 (patch)
treef577cf8fc16d62a2bfa0fecb84427622584c1ac9 /devel
parentdb1e3846f80eb4e0fe4a5ba6f82629e4f03f13de (diff)
downloadfreebsd-ports-graphics-a08b07cecb7ac8a17cb5f04229d04223e67c2fb9.tar.gz
freebsd-ports-graphics-a08b07cecb7ac8a17cb5f04229d04223e67c2fb9.tar.zst
freebsd-ports-graphics-a08b07cecb7ac8a17cb5f04229d04223e67c2fb9.zip
Update libclc to 0.1.0, snapshot from 20150710.
- Switch to the llvm github mirror, remove code to roll a custom tarball from svn. - Remove 8.x IGNORE and convert 9.x IGNORE to BROKEN_FreeBSD_9, do away with pre.mk/post.mk. - Bump llvm version to 3.6. to stay in sync with mesa, which will use it in the near future.
Diffstat (limited to 'devel')
-rw-r--r--devel/libclc/Makefile45
-rw-r--r--devel/libclc/Makefile.svn_rev1
-rw-r--r--devel/libclc/distinfo4
-rw-r--r--devel/libclc/pkg-plist69
4 files changed, 68 insertions, 51 deletions
diff --git a/devel/libclc/Makefile b/devel/libclc/Makefile
index 5c9e4e7fe2b..2462cc2077c 100644
--- a/devel/libclc/Makefile
+++ b/devel/libclc/Makefile
@@ -2,55 +2,28 @@
# $FreeBSD$
PORTNAME= libclc
-DISTVERSION= 0.0.1.r${SVN_REV}
+DISTVERSION= 0.1.0.20150710
CATEGORIES= devel
-MASTER_SITES= LOCAL/kwm
MAINTAINER= kwm@FreeBSD.org
COMMENT= Required library functions for OpenCL C programming language
BUILD_DEPENDS= clang${LLVMVER}:${PORTSDIR}/lang/clang${LLVMVER}
+USE_GITHUB= yes
+GH_ACCOUNT= llvm-mirror
+GH_TAGNAME= eed524f2a9
+
GNU_CONFIGURE= yes
-USES= gmake python:2,build ninja tar:xz
+USES= gmake python:2,build ninja
USE_LDCONFIG= yes
MAKE_ENV= MAKE=${GMAKE} DESTDIR=${STAGEDIR}
-LLVMVER= 35
+LLVMVER= 36
ALL_TARGET=
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 900000
-IGNORE= LLVM 3.5 is not available on 8.x
-.elif ${OSVERSION} < 1000000
-IGNORE= Does not build, missing <system_error> header
-.endif
-
-.if !defined(SVN_REV)
-.if defined(BOOTSTRAP)
-LANG= "C"
-SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} "Revision" | cut -d' ' -f2
-.else
-.include "Makefile.svn_rev"
-.endif
-.endif
-
-.if defined(BOOTSTRAP) || defined(SVN_FETCH)
-FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
-
-do-fetch:
- ${MKDIR} ${WRKDIR}
- svn export -r ${SVN_REV} \
- http://llvm.org/svn/llvm-project/libclc/trunk ${WRKSRC}
- cd ${WRKDIR}; tar cvJf ${DISTDIR}/${DISTNAME}.tar.xz ${DISTNAME}
- echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
-.if ${USER} == kwm
- scp ${DISTDIR}/${DISTNAME}.tar.xz \
- kwm@freefall.freebsd.org:public_distfiles/
-.endif
-.endif
+BROKEN_FreeBSD_9= missing <system_error> header
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|g' \
@@ -63,4 +36,4 @@ do-configure:
--with-llvm-config=${LOCALBASE}/bin/llvm-config${LLVMVER} \
--pkgconfigdir=${PREFIX}/libdata/pkgconfig
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libclc/Makefile.svn_rev b/devel/libclc/Makefile.svn_rev
deleted file mode 100644
index b5a4cd2ba74..00000000000
--- a/devel/libclc/Makefile.svn_rev
+++ /dev/null
@@ -1 +0,0 @@
-SVN_REV= 222830
diff --git a/devel/libclc/distinfo b/devel/libclc/distinfo
index f522bff2049..308234ca977 100644
--- a/devel/libclc/distinfo
+++ b/devel/libclc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libclc-0.0.1.r222830.tar.xz) = a3e361bde0158cb853fdaba14b6a13c87dfce7a4fe7cd410b672df47a2d63423
-SIZE (libclc-0.0.1.r222830.tar.xz) = 44932
+SHA256 (llvm-mirror-libclc-0.1.0.20150710-eed524f2a9_GH0.tar.gz) = 12cfa6c2530dd2308fa11ec43d450d1aa0f94cb9b05bbb80daa78b4dfa05d691
+SIZE (llvm-mirror-libclc-0.1.0.20150710-eed524f2a9_GH0.tar.gz) = 94347
diff --git a/devel/libclc/pkg-plist b/devel/libclc/pkg-plist
index 8044e9336de..eaac2e8c554 100644
--- a/devel/libclc/pkg-plist
+++ b/devel/libclc/pkg-plist
@@ -45,13 +45,30 @@ include/clc/clc.h
include/clc/clcfunc.h
include/clc/clctypes.h
include/clc/clcversion.h
+include/clc/common/degrees.h
+include/clc/common/degrees.inc
+include/clc/common/mix.h
+include/clc/common/mix.inc
+include/clc/common/radians.h
+include/clc/common/radians.inc
include/clc/common/sign.h
+include/clc/common/smoothstep.h
+include/clc/common/smoothstep.inc
+include/clc/common/step.h
+include/clc/common/step.inc
include/clc/convert.h
include/clc/float/definitions.h
include/clc/geometric/cross.h
include/clc/geometric/distance.h
+include/clc/geometric/distance.inc
include/clc/geometric/dot.h
include/clc/geometric/dot.inc
+include/clc/geometric/fast_distance.h
+include/clc/geometric/fast_distance.inc
+include/clc/geometric/fast_length.h
+include/clc/geometric/fast_length.inc
+include/clc/geometric/fast_normalize.h
+include/clc/geometric/fast_normalize.inc
include/clc/geometric/floatn.inc
include/clc/geometric/length.h
include/clc/geometric/length.inc
@@ -88,12 +105,26 @@ include/clc/integer/sub_sat.inc
include/clc/integer/upsample.h
include/clc/math/acos.h
include/clc/math/acos.inc
+include/clc/math/acosh.h
+include/clc/math/acosh.inc
+include/clc/math/acospi.h
+include/clc/math/acospi.inc
include/clc/math/asin.h
include/clc/math/asin.inc
+include/clc/math/asinh.h
+include/clc/math/asinh.inc
+include/clc/math/asinpi.h
+include/clc/math/asinpi.inc
include/clc/math/atan.h
include/clc/math/atan.inc
include/clc/math/atan2.h
include/clc/math/atan2.inc
+include/clc/math/atan2pi.h
+include/clc/math/atan2pi.inc
+include/clc/math/atanh.h
+include/clc/math/atanh.inc
+include/clc/math/atanpi.h
+include/clc/math/atanpi.inc
include/clc/math/binary_decl.inc
include/clc/math/binary_intrin.inc
include/clc/math/ceil.h
@@ -102,9 +133,13 @@ include/clc/math/copysign.h
include/clc/math/copysign.inc
include/clc/math/cos.h
include/clc/math/cos.inc
+include/clc/math/cospi.h
+include/clc/math/cospi.inc
+include/clc/math/erfc.h
include/clc/math/exp.h
include/clc/math/exp10.h
include/clc/math/exp2.h
+include/clc/math/exp2.inc
include/clc/math/fabs.h
include/clc/math/floor.h
include/clc/math/fma.h
@@ -112,17 +147,22 @@ include/clc/math/fmax.h
include/clc/math/fmin.h
include/clc/math/fmod.h
include/clc/math/fmod.inc
+include/clc/math/fract.h
+include/clc/math/fract.inc
include/clc/math/gentype.inc
+include/clc/math/half_rsqrt.h
+include/clc/math/half_sqrt.h
include/clc/math/hypot.h
include/clc/math/hypot.inc
+include/clc/math/ldexp.h
+include/clc/math/ldexp.inc
include/clc/math/log.h
+include/clc/math/log10.h
include/clc/math/log1p.h
include/clc/math/log1p.inc
include/clc/math/log2.h
include/clc/math/mad.h
include/clc/math/mad.inc
-include/clc/math/mix.h
-include/clc/math/mix.inc
include/clc/math/native_cos.h
include/clc/math/native_divide.h
include/clc/math/native_exp.h
@@ -143,6 +183,8 @@ include/clc/math/sin.h
include/clc/math/sin.inc
include/clc/math/sincos.h
include/clc/math/sincos.inc
+include/clc/math/sinpi.h
+include/clc/math/sinpi.inc
include/clc/math/sqrt.h
include/clc/math/tan.h
include/clc/math/tan.inc
@@ -154,6 +196,7 @@ include/clc/relational/all.h
include/clc/relational/any.h
include/clc/relational/binary_decl.inc
include/clc/relational/bitselect.h
+include/clc/relational/bitselect.inc
include/clc/relational/floatn.inc
include/clc/relational/isequal.h
include/clc/relational/isfinite.h
@@ -190,27 +233,29 @@ include/clc/workitem/get_num_groups.h
include/clc/workitem/get_work_dim.h
lib/clc/aruba-r600--.bc
lib/clc/barts-r600--.bc
-lib/clc/bonaire-r600--.bc
+lib/clc/bonaire-amdgcn--.bc
lib/clc/caicos-r600--.bc
lib/clc/cayman-r600--.bc
lib/clc/cedar-r600--.bc
lib/clc/cypress-r600--.bc
-lib/clc/hainan-r600--.bc
-lib/clc/hawaii-r600--.bc
+lib/clc/hainan-amdgcn--.bc
+lib/clc/hawaii-amdgcn--.bc
lib/clc/hemlock-r600--.bc
lib/clc/juniper-r600--.bc
-lib/clc/kabini-r600--.bc
-lib/clc/kaveri-r600--.bc
-lib/clc/mullins-r600--.bc
+lib/clc/kabini-amdgcn--.bc
+lib/clc/kaveri-amdgcn--.bc
+lib/clc/mullins-amdgcn--.bc
lib/clc/nvptx--nvidiacl.bc
lib/clc/nvptx64--nvidiacl.bc
-lib/clc/oland-r600--.bc
+lib/clc/oland-amdgcn--.bc
lib/clc/palm-r600--.bc
-lib/clc/pitcairn-r600--.bc
+lib/clc/pitcairn-amdgcn--.bc
lib/clc/redwood-r600--.bc
+lib/clc/subnormal_disable.bc
+lib/clc/subnormal_use_default.bc
lib/clc/sumo-r600--.bc
lib/clc/sumo2-r600--.bc
-lib/clc/tahiti-r600--.bc
+lib/clc/tahiti-amdgcn--.bc
lib/clc/turks-r600--.bc
-lib/clc/verde-r600--.bc
+lib/clc/verde-amdgcn--.bc
libdata/pkgconfig/libclc.pc