aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-03 09:07:27 +0800
committeredwin <edwin@FreeBSD.org>2003-09-03 09:07:27 +0800
commita6646b4b7bbb36da96634d8244261d61b36cafd6 (patch)
tree4bbcd74bb4ed8a7b10070329bf99ccbe98a5b9c7 /devel
parentf25da5cbeab9b4aaa9bb8c5c9e34dc8570351e23 (diff)
downloadfreebsd-ports-graphics-a6646b4b7bbb36da96634d8244261d61b36cafd6.tar.gz
freebsd-ports-graphics-a6646b4b7bbb36da96634d8244261d61b36cafd6.tar.zst
freebsd-ports-graphics-a6646b4b7bbb36da96634d8244261d61b36cafd6.zip
New port: PEAR template API
The Isotemplate API is somewhat tricky for a beginner although it is the best one you can build. template::parse() [phplib template = Isotemplate] requests you to name a source and a target where the current block gets parsed into. Source and target can be block names or even handler names. PR: ports/56304 Submitted by: Alex Miller <asm@asm.kiev.ua>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_Template_IT/Makefile39
-rw-r--r--devel/pear-HTML_Template_IT/distinfo1
-rw-r--r--devel/pear-HTML_Template_IT/pkg-descr21
-rw-r--r--devel/pear-HTML_Template_IT/pkg-plist23
5 files changed, 85 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c6fee0aca2d..4ef64a11228 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -800,6 +800,7 @@
SUBDIR += pear-Date
SUBDIR += pear-HTML_Common
SUBDIR += pear-HTML_Select_Common
+ SUBDIR += pear-HTML_Template_IT
SUBDIR += pear-I18N
SUBDIR += pear-PEAR
SUBDIR += pedisassem
diff --git a/devel/pear-HTML_Template_IT/Makefile b/devel/pear-HTML_Template_IT/Makefile
new file mode 100644
index 00000000000..6fd3b02ba49
--- /dev/null
+++ b/devel/pear-HTML_Template_IT/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: pear-HTML_Template_IT
+# Date created: 02 September 2003
+# Whom: Alex Miller (<asm@asm.kiev.ua>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Template_IT
+PORTVERSION= 1.1
+CATEGORIES= devel www
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR template API
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+MANIFEST= IT.php ITX.php IT_Error.php
+TESTDIR= ${PEARDIR}/tests/${PORTNAME}
+
+do-install:
+ @${MKDIR} -p ${PEARDIR}/HTML/Template
+.for FILE in ${MANIFEST}
+ @${CP} -p ${WRKSRC}/${FILE} ${PEARDIR}/HTML/Template
+.endfor
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML/Template
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${TESTDIR}
+ @${CP} -Rp ${WRKSRC}/tests/* ${TESTDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${TESTDIR}
+ @${ECHO_MSG} "===> Examples installed in ${TESTDIR}."
+ @${ECHO_MSG} " (These tests require PHPUnit - see"
+ @${ECHO_MSG} " <http://pear.php.net/package-info.php?package=PHPUnit>;;)."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_Template_IT/distinfo b/devel/pear-HTML_Template_IT/distinfo
new file mode 100644
index 00000000000..1bfa1448790
--- /dev/null
+++ b/devel/pear-HTML_Template_IT/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/HTML_Template_IT-1.1.tgz) = 6062a6b0cf6033b206bd62aaeb36c055
diff --git a/devel/pear-HTML_Template_IT/pkg-descr b/devel/pear-HTML_Template_IT/pkg-descr
new file mode 100644
index 00000000000..5a15e20101c
--- /dev/null
+++ b/devel/pear-HTML_Template_IT/pkg-descr
@@ -0,0 +1,21 @@
+HTML_Template_IT:
+Simple template API.
+The Isotemplate API is somewhat tricky for a beginner although it is the best
+one you can build. template::parse() [phplib template = Isotemplate] requests
+you to name a source and a target where the current block gets parsed into.
+Source and target can be block names or even handler names.
+
+Features :
+ * Nested blocks
+ * Include external file
+ * Custom tags format (default {mytag})
+
+HTML_Template_ITX :
+With this class you get the full power of the phplib template class.
+You may have one file with blocks in it but you have as well one main file
+and multiple files one for each block. This is quite usefull when you have
+user configurable websites. Using blocks not in the main template allows
+you to modify some parts of your layout easily.
+
+
+WWW: http://pear.php.net/package-info.php?package=HTML_Template_IT
diff --git a/devel/pear-HTML_Template_IT/pkg-plist b/devel/pear-HTML_Template_IT/pkg-plist
new file mode 100644
index 00000000000..14a9c23b287
--- /dev/null
+++ b/devel/pear-HTML_Template_IT/pkg-plist
@@ -0,0 +1,23 @@
+%%PEARDIR%%/HTML/Template/IT.php
+%%PEARDIR%%/HTML/Template/ITX.php
+%%PEARDIR%%/HTML/Template/IT_Error.php
+%%PKGREGDIR%%/package.xml
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/Console_TestListener.php
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/ITX_api_testcase.php
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/ITX_usage_testcase.php
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/IT_api_testcase.php
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/IT_usage_testcase.php
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/test.php
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/__include.html
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/addblock.html
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/blockiteration.html
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/blocks.html
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/globals.html
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/include.html
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/loadtemplatefile.html
+%%PORTDOCS%%%%PEARDIR%%/tests/HTML_Template_IT/templates/replaceblock.html
+@dirrm %%PEARDIR%%/HTML/Template
+@unexec rmdir %%PEARDIR%%/HTML 2>/dev/null || true
+@dirrm %%PKGREGDIR%%
+%%PORTDOCS%%@dirrm %%PEARDIR%%/tests/HTML_Template_IT/templates
+%%PORTDOCS%%@dirrm %%PEARDIR%%/tests/HTML_Template_IT