aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrse <rse@FreeBSD.org>1999-03-24 22:14:13 +0800
committerrse <rse@FreeBSD.org>1999-03-24 22:14:13 +0800
commitb799accb0e222aee48d5b42ff0fb341be02596ab (patch)
tree84945ca2f80afca74d3d705f6cf59fa5782c45ee /devel
parentb9a10563d548176c95ff7c4b671dcb469fe01acb (diff)
downloadfreebsd-ports-graphics-b799accb0e222aee48d5b42ff0fb341be02596ab.tar.gz
freebsd-ports-graphics-b799accb0e222aee48d5b42ff0fb341be02596ab.tar.zst
freebsd-ports-graphics-b799accb0e222aee48d5b42ff0fb341be02596ab.zip
Import of MM, a portable shared memory library.
The MM library is a 2-layer abstraction library which simplifies the usage of shared memory between forked (and this way strongly related) processes under Unix platforms. On the first layer it hides all platform dependent implementation details (allocation and locking) when dealing with shared memory segments and on the second layer it provides a high-level malloc(3)-style API for a convenient and well known way to work with data-structures inside those shared memory segments. This library is proposed to be used in future versions of Apache 1.3 as the base library for shared memory pools.
Diffstat (limited to 'devel')
-rw-r--r--devel/mm/Makefile27
-rw-r--r--devel/mm/distinfo1
-rw-r--r--devel/mm/pkg-comment1
-rw-r--r--devel/mm/pkg-descr14
-rw-r--r--devel/mm/pkg-plist8
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/mm/Makefile b/devel/mm/Makefile
new file mode 100644
index 00000000000..ecac291f21d
--- /dev/null
+++ b/devel/mm/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mm
+# Version required: 1.1b6
+# Date Created: 14 March 1999
+# Whom: Ralf S. Engelschall
+#
+# $Id: $
+#
+
+DISTNAME= mm-1.0b6
+CATEGORIES= devel
+MASTER_SITES= http://www.engelschall.com/sw/mm/
+
+MAINTAINER= rse@engelschall.com
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+MAN1= mm-config.1
+MAN3= mm.3
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+test:
+ @cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/devel/mm/distinfo b/devel/mm/distinfo
new file mode 100644
index 00000000000..89e18662897
--- /dev/null
+++ b/devel/mm/distinfo
@@ -0,0 +1 @@
+MD5 (mm-1.0b6.tar.gz) = 5e45cd642225946f4820a987eea1da5e
diff --git a/devel/mm/pkg-comment b/devel/mm/pkg-comment
new file mode 100644
index 00000000000..0c694aac479
--- /dev/null
+++ b/devel/mm/pkg-comment
@@ -0,0 +1 @@
+shared memory library for applications with a pre-forked process model
diff --git a/devel/mm/pkg-descr b/devel/mm/pkg-descr
new file mode 100644
index 00000000000..d96eb96d43a
--- /dev/null
+++ b/devel/mm/pkg-descr
@@ -0,0 +1,14 @@
+MM - Shared Memory Library
+Copyright (c) 1999 Ralf S. Engelschall, All rights reserved.
+
+The MM library is a 2-layer abstraction library which simplifies
+the usage of shared memory between forked (and this way strongly
+related) processes under Unix platforms. On the first layer it
+hides all platform dependent implementation details (allocation
+and locking) when dealing with shared memory segments and on the
+second layer it provides a high-level malloc(3)-style API for a
+convenient and well known way to work with data-structures inside
+those shared memory segments.
+
+The documentation and latest release can be found on
+http://www.engelschall.com/sw/mm/
diff --git a/devel/mm/pkg-plist b/devel/mm/pkg-plist
new file mode 100644
index 00000000000..46ac1b1dfa2
--- /dev/null
+++ b/devel/mm/pkg-plist
@@ -0,0 +1,8 @@
+bin/mm-config
+include/mm.h
+lib/libmm.a
+lib/libmm.la
+lib/libmm.so
+lib/libmm.so.10
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B