aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-22 17:57:07 +0800
committerclsung <clsung@FreeBSD.org>2006-08-22 17:57:07 +0800
commitb93a99b2afd539ab59f9c852ef3ecb0d122b1474 (patch)
tree3f8a85cc2d7f76d74a2a4a117ea84aceb178d5c3 /devel
parent42ec8352fcd47420a53c65e6342befd31614c172 (diff)
downloadfreebsd-ports-graphics-b93a99b2afd539ab59f9c852ef3ecb0d122b1474.tar.gz
freebsd-ports-graphics-b93a99b2afd539ab59f9c852ef3ecb0d122b1474.tar.zst
freebsd-ports-graphics-b93a99b2afd539ab59f9c852ef3ecb0d122b1474.zip
Add p5-App-Trace 0.50, embedded debug statements, including call/return
tracing. PR: ports/102317 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-App-Trace/Makefile30
-rw-r--r--devel/p5-App-Trace/distinfo3
-rw-r--r--devel/p5-App-Trace/pkg-descr8
-rw-r--r--devel/p5-App-Trace/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4759d53a729..c84a4f55ee5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -775,6 +775,7 @@
SUBDIR += p5-App-Cache
SUBDIR += p5-App-Info
SUBDIR += p5-App-Options
+ SUBDIR += p5-App-Trace
SUBDIR += p5-AppConfig
SUBDIR += p5-AppConfig-Std
SUBDIR += p5-Array-Iterator
diff --git a/devel/p5-App-Trace/Makefile b/devel/p5-App-Trace/Makefile
new file mode 100644
index 00000000000..c7b85c5e92e
--- /dev/null
+++ b/devel/p5-App-Trace/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-App-Trace
+# Date created: 2006-08-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-Trace
+PORTVERSION= 0.50
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= App
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Embedded debug statements, including call/return tracing
+
+RUN_DEPENDS= ${SITE_PERL}/App/Options.pm:${PORTSDIR}/devel/p5-App-Options
+
+PERL_CONFIGURE= yes
+
+MAN3= App::Trace.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from devel/p5-App-Options
+IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-App-Trace/distinfo b/devel/p5-App-Trace/distinfo
new file mode 100644
index 00000000000..ffd563ca123
--- /dev/null
+++ b/devel/p5-App-Trace/distinfo
@@ -0,0 +1,3 @@
+MD5 (App-Trace-0.50.tar.gz) = b8a43ea71b024d2c06d3d45250a2a04e
+SHA256 (App-Trace-0.50.tar.gz) = ddb4df82a72cf2ad448aaae10d09ca380fb9f3678d2927684df0ba2dc36812d3
+SIZE (App-Trace-0.50.tar.gz) = 6096
diff --git a/devel/p5-App-Trace/pkg-descr b/devel/p5-App-Trace/pkg-descr
new file mode 100644
index 00000000000..d863d845a19
--- /dev/null
+++ b/devel/p5-App-Trace/pkg-descr
@@ -0,0 +1,8 @@
+App::Trace provides debug/tracing support for perl programs and
+modules.
+
+The basic concept is that you put a special call at the beginning and
+end of each subroutine/method, and when tracing is enabled, you can
+see the flow of your program.
+
+WWW: http://search.cpan.org/dist/App-Trace/
diff --git a/devel/p5-App-Trace/pkg-plist b/devel/p5-App-Trace/pkg-plist
new file mode 100644
index 00000000000..465f782a01f
--- /dev/null
+++ b/devel/p5-App-Trace/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/App-Trace/.packlist
+%%SITE_PERL%%/App/Trace.pm
+@dirrmtry %%SITE_PERL%%/App
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/App-Trace