aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2002-05-27 17:38:47 +0800
committerskv <skv@FreeBSD.org>2002-05-27 17:38:47 +0800
commitba2b9b1d2b99641c9988026b85c49412f1b621ef (patch)
tree966604ea3d6665d69887eacc5bc6e07d7f2e7ad6 /devel
parent1f6711675dbbc1adcc8d468bdf6800271372e8ab (diff)
downloadfreebsd-ports-graphics-ba2b9b1d2b99641c9988026b85c49412f1b621ef.tar.gz
freebsd-ports-graphics-ba2b9b1d2b99641c9988026b85c49412f1b621ef.tar.zst
freebsd-ports-graphics-ba2b9b1d2b99641c9988026b85c49412f1b621ef.zip
Add p5-Class-Factory 0.03, base class for dynamic factory classes.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Factory/Makefile22
-rw-r--r--devel/p5-Class-Factory/distinfo1
-rw-r--r--devel/p5-Class-Factory/pkg-comment1
-rw-r--r--devel/p5-Class-Factory/pkg-descr12
-rw-r--r--devel/p5-Class-Factory/pkg-plist5
6 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c9a9a0b3ead..9f4d795c18f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -369,6 +369,7 @@
SUBDIR += p5-Class-Data-Inheritable
SUBDIR += p5-Class-Date
SUBDIR += p5-Class-Delegation
+ SUBDIR += p5-Class-Factory
SUBDIR += p5-Class-Fields
SUBDIR += p5-Class-ISA
SUBDIR += p5-Class-Loader
diff --git a/devel/p5-Class-Factory/Makefile b/devel/p5-Class-Factory/Makefile
new file mode 100644
index 00000000000..a49f952eb9e
--- /dev/null
+++ b/devel/p5-Class-Factory/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Class-Accessor
+# Date created: 6 Mar 2002
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Factory
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Class::Factory.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Factory/distinfo b/devel/p5-Class-Factory/distinfo
new file mode 100644
index 00000000000..13428d62771
--- /dev/null
+++ b/devel/p5-Class-Factory/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Factory-0.03.tar.gz) = bb37d56f8d4b05498534968d2fa54f3b
diff --git a/devel/p5-Class-Factory/pkg-comment b/devel/p5-Class-Factory/pkg-comment
new file mode 100644
index 00000000000..a66b51dffc3
--- /dev/null
+++ b/devel/p5-Class-Factory/pkg-comment
@@ -0,0 +1 @@
+Base class for dynamic factory classes
diff --git a/devel/p5-Class-Factory/pkg-descr b/devel/p5-Class-Factory/pkg-descr
new file mode 100644
index 00000000000..415f0455753
--- /dev/null
+++ b/devel/p5-Class-Factory/pkg-descr
@@ -0,0 +1,12 @@
+This is a simple module that factory classes can use to generate new
+types of objects on the fly, providing a consistent interface to common
+groups of objects.
+
+Factory classes are used when you have different implementations for the
+same set of tasks but may not know in advance what implementations you
+will be using.
+
+WWW: http://search.cpan.org/search?dist=Class-Factory
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Class-Factory/pkg-plist b/devel/p5-Class-Factory/pkg-plist
new file mode 100644
index 00000000000..0e7d0a3dcde
--- /dev/null
+++ b/devel/p5-Class-Factory/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Factory/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Class/Factory.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Factory
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Class 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true