aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2007-09-27 04:08:29 +0800
committerskv <skv@FreeBSD.org>2007-09-27 04:08:29 +0800
commitc62f378c2549c70929140a5e742be0951ae1ddb5 (patch)
tree3856d82429e49da66a0d9ce7d4d8a73167d420cf /devel
parentb0bdd14af084ec479aa89f44a441a6b616c456fa (diff)
downloadfreebsd-ports-graphics-c62f378c2549c70929140a5e742be0951ae1ddb5.tar.gz
freebsd-ports-graphics-c62f378c2549c70929140a5e742be0951ae1ddb5.tar.zst
freebsd-ports-graphics-c62f378c2549c70929140a5e742be0951ae1ddb5.zip
Add thrift 20070917, framework for scalable cross-language services
development.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/thrift/Makefile37
-rw-r--r--devel/thrift/distinfo3
-rw-r--r--devel/thrift/pkg-descr12
-rw-r--r--devel/thrift/pkg-plist61
5 files changed, 114 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b3e12c952ad..f5b4294e7d9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2243,6 +2243,7 @@
SUBDIR += tdl
SUBDIR += templ
SUBDIR += terminality
+ SUBDIR += thrift
SUBDIR += tide
SUBDIR += tigcc
SUBDIR += tinylaf
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
new file mode 100644
index 00000000000..a9fc6f18ae9
--- /dev/null
+++ b/devel/thrift/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: thrift
+# Date created: 27 September 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thrift
+PORTVERSION= 20070917
+CATEGORIES= devel
+MASTER_SITES= http://developers.facebook.com/thrift/
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Framework for scalable cross-language services development
+
+LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost \
+ event:${PORTSDIR}/devel/libevent
+
+USE_AUTOTOOLS= libtool:15
+USE_GCC= 4.0+
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS= --with-boost=${LOCALBASE} \
+ --with-event=${LOCALBASE}
+CONFIGURE_ENV+= ${MAKE_ENV}
+
+post-patch:
+ ${REINPLACE_CMD} -i '' -e 's=lib/py ==' ${WRKSRC}/*.*
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/thrift.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/thrift/distinfo b/devel/thrift/distinfo
new file mode 100644
index 00000000000..17f12fd4115
--- /dev/null
+++ b/devel/thrift/distinfo
@@ -0,0 +1,3 @@
+MD5 (thrift-20070917.tar.gz) = 2c96285e123113930400879663f354aa
+SHA256 (thrift-20070917.tar.gz) = dc4003144e19a11bcd2a4795c74a28d6596cf9a3cdc2a230ec6b7579e848e1e9
+SIZE (thrift-20070917.tar.gz) = 1228184
diff --git a/devel/thrift/pkg-descr b/devel/thrift/pkg-descr
new file mode 100644
index 00000000000..4ab6c0ca398
--- /dev/null
+++ b/devel/thrift/pkg-descr
@@ -0,0 +1,12 @@
+Thrift is a lightweight, language-independent software stack with an
+associated code generation mechanism for RPC. Thrift provides clean
+abstractions for data transport, data serialization, and application
+level processing. The code generation system takes a simple definition
+language as its input and generates code across programming languages
+that uses the abstracted stack to build interoperable RPC clients and
+servers.
+
+Thrift is specifically designed to support non-atomic version changes
+across client and server code.
+
+WWW: http://developers.facebook.com/thrift/
diff --git a/devel/thrift/pkg-plist b/devel/thrift/pkg-plist
new file mode 100644
index 00000000000..292fb97dc54
--- /dev/null
+++ b/devel/thrift/pkg-plist
@@ -0,0 +1,61 @@
+bin/thrift
+include/thrift/TLogging.h
+include/thrift/TProcessor.h
+include/thrift/TReflectionLocal.h
+include/thrift/Thrift.h
+include/thrift/config.h
+include/thrift/reflection_limited_types.h
+include/thrift/concurrency/Exception.h
+include/thrift/concurrency/Monitor.h
+include/thrift/concurrency/Mutex.h
+include/thrift/concurrency/PosixThreadFactory.h
+include/thrift/concurrency/Thread.h
+include/thrift/concurrency/ThreadManager.h
+include/thrift/concurrency/TimerManager.h
+include/thrift/concurrency/Util.h
+include/thrift/processor/PeekProcessor.h
+include/thrift/processor/StatsProcessor.h
+include/thrift/protocol/TBinaryProtocol.h
+include/thrift/protocol/TDebugProtocol.h
+include/thrift/protocol/TDenseProtocol.h
+include/thrift/protocol/TOneWayProtocol.h
+include/thrift/protocol/TProtocol.h
+include/thrift/protocol/TProtocolException.h
+include/thrift/server/TNonblockingServer.h
+include/thrift/server/TServer.h
+include/thrift/server/TSimpleServer.h
+include/thrift/server/TThreadPoolServer.h
+include/thrift/server/TThreadedServer.h
+include/thrift/transport/TFileTransport.h
+include/thrift/transport/THttpClient.h
+include/thrift/transport/TServerSocket.h
+include/thrift/transport/TServerTransport.h
+include/thrift/transport/TSocket.h
+include/thrift/transport/TSocketPool.h
+include/thrift/transport/TTransport.h
+include/thrift/transport/TTransportException.h
+include/thrift/transport/TTransportUtils.h
+include/thrift/transport/TZlibTransport.h
+lib/libthrift.a
+lib/libthrift.la
+lib/libthrift.so
+lib/libthrift.so.0
+lib/libthriftnb.a
+lib/libthriftnb.la
+lib/libthriftnb.so
+lib/libthriftnb.so.0
+lib/libthriftz.a
+lib/libthriftz.la
+lib/libthriftz.so
+lib/libthriftz.so.0
+share/thrift/if/reflection_limited.thrift
+%%PORTDOCS%%%%DOCSDIR%%/thrift.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/thrift/if
+@dirrm share/thrift
+@dirrm include/thrift/transport
+@dirrm include/thrift/server
+@dirrm include/thrift/protocol
+@dirrm include/thrift/processor
+@dirrm include/thrift/concurrency
+@dirrm include/thrift