aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-07-08 03:20:01 +0800
committermm <mm@FreeBSD.org>2011-07-08 03:20:01 +0800
commitc6c5d555eb7cc68b0b8d4321557fcf70afc61b73 (patch)
treea6a3fc7ce4810a6acb8d1f19b1052ba2bd37b682 /devel
parent7b33e1a80ca70e8dea8021148ac36abf41d55bc2 (diff)
downloadfreebsd-ports-graphics-c6c5d555eb7cc68b0b8d4321557fcf70afc61b73.tar.gz
freebsd-ports-graphics-c6c5d555eb7cc68b0b8d4321557fcf70afc61b73.tar.zst
freebsd-ports-graphics-c6c5d555eb7cc68b0b8d4321557fcf70afc61b73.zip
This Horde package provides a simple, functional caching API, with the option
to store the cached data on the filesystem, in one of the PHP opcode cache systems (APC, eAcclerator, XCache, or Zend Performance Suite's content cache), memcached, or an SQL table. WWW: http://pear.horde.org
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-Horde_Cache/Makefile32
-rw-r--r--devel/pear-Horde_Cache/distinfo2
-rw-r--r--devel/pear-Horde_Cache/pkg-descr6
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 891b9db04e0..2067f147ad4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2621,6 +2621,7 @@
SUBDIR += pear-HTML_Template_Sigma
SUBDIR += pear-HTML_TreeMenu
SUBDIR += pear-Horde_Autoloader
+ SUBDIR += pear-Horde_Cache
SUBDIR += pear-Horde_Cli
SUBDIR += pear-Horde_Constraint
SUBDIR += pear-Horde_Controller
diff --git a/devel/pear-Horde_Cache/Makefile b/devel/pear-Horde_Cache/Makefile
new file mode 100644
index 00000000000..7124ddad83e
--- /dev/null
+++ b/devel/pear-Horde_Cache/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pear-Horde_Cache
+# Date created: 6 July 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= Horde_Cache
+PORTVERSION= 1.0.4
+CATEGORIES= devel www pear
+PKGNAMEPREFIX= pear-
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Horde Caching API
+
+OPTIONS= APC "Require APC PHP extension" Off \
+ MEMCACHE "Enable Memcache support" Off \
+
+USE_HORDE_RUN= Horde_Exception Horde_Util
+USE_PHP= hash
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_APC)
+USE_PHP+= apc
+.endif
+
+.if defined(WITH_MEMCACHE)
+USE_HORDE_RUN+= Horde_Memcache
+.endif
+
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Horde_Cache/distinfo b/devel/pear-Horde_Cache/distinfo
new file mode 100644
index 00000000000..4bf6bf3e880
--- /dev/null
+++ b/devel/pear-Horde_Cache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde/Horde_Cache-1.0.4.tgz) = e6e7f65ee5beac430e58137009bb644f3ccdbefa617ce836878bb8095430522a
+SIZE (Horde/Horde_Cache-1.0.4.tgz) = 9879
diff --git a/devel/pear-Horde_Cache/pkg-descr b/devel/pear-Horde_Cache/pkg-descr
new file mode 100644
index 00000000000..d86a457de8c
--- /dev/null
+++ b/devel/pear-Horde_Cache/pkg-descr
@@ -0,0 +1,6 @@
+This Horde package provides a simple, functional caching API, with the option
+to store the cached data on the filesystem, in one of the PHP opcode cache
+systems (APC, eAcclerator, XCache, or Zend Performance Suite's content cache),
+memcached, or an SQL table.
+
+WWW: http://pear.horde.org