aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-23 15:26:11 +0800
committerkrion <krion@FreeBSD.org>2004-06-23 15:26:11 +0800
commitc9f920877b4d6ab3755977ab969357900f8e91fe (patch)
treedaa22eaf41227c55822115c8d08d16f0cdecf1cf /devel
parenta9c2294a5508e2749726a3906b4eb29905a9a9b1 (diff)
downloadfreebsd-ports-graphics-c9f920877b4d6ab3755977ab969357900f8e91fe.tar.gz
freebsd-ports-graphics-c9f920877b4d6ab3755977ab969357900f8e91fe.tar.zst
freebsd-ports-graphics-c9f920877b4d6ab3755977ab969357900f8e91fe.zip
Add p5-Unix-Statgrab 0.01,
Unix::Statgrab is a wrapper for libstatgrab, as available from http://www.i-scream.org/libstatgrab/. It is a reasonably portable attempt to query interesting stats about your computer. It covers information on the operating system, CPU, memory usage, network interfaces, hard-disks etc. PR: ports/68157 Submitted by: Tim Bishop <tim@bishnet.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Unix-Statgrab/Makefile35
-rw-r--r--devel/p5-Unix-Statgrab/distinfo2
-rw-r--r--devel/p5-Unix-Statgrab/files/patch-Makefile.PL11
-rw-r--r--devel/p5-Unix-Statgrab/pkg-descr7
-rw-r--r--devel/p5-Unix-Statgrab/pkg-plist8
6 files changed, 64 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a5da289afe9..73d21b6173c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -961,6 +961,7 @@
SUBDIR += p5-Tree-DAG_Node
SUBDIR += p5-UNIVERSAL-exports
SUBDIR += p5-UNIVERSAL-moniker
+ SUBDIR += p5-Unix-Statgrab
SUBDIR += p5-VCP
SUBDIR += p5-VCS
SUBDIR += p5-VCS-CVS
diff --git a/devel/p5-Unix-Statgrab/Makefile b/devel/p5-Unix-Statgrab/Makefile
new file mode 100644
index 00000000000..baf82bbd8b4
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Unix-Statgrab
+# Date created: June 20th, 2004
+# Whom: Tim Bishop <tim@bishnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Unix-Statgrab
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Unix
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tim@bishnet.net
+COMMENT= Perl extension for collecting information about the machine
+
+LIB_DEPENDS= statgrab.5:${PORTSDIR}/devel/libstatgrab
+
+USE_GNOME= pkgconfig
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= INC="`pkg-config libstatgrab --cflags`" \
+ LIBS="`pkg-config libstatgrab --libs`"
+
+MAN3= Unix::Statgrab.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -i -pe 's/}\(/}->(/' ${WRKSRC}/lib/Unix/Statgrab.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Unix-Statgrab/distinfo b/devel/p5-Unix-Statgrab/distinfo
new file mode 100644
index 00000000000..e4fcb42b2f7
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/distinfo
@@ -0,0 +1,2 @@
+MD5 (Unix-Statgrab-0.01.tar.gz) = a9af99129244c8bdc73ff447e6059969
+SIZE (Unix-Statgrab-0.01.tar.gz) = 20459
diff --git a/devel/p5-Unix-Statgrab/files/patch-Makefile.PL b/devel/p5-Unix-Statgrab/files/patch-Makefile.PL
new file mode 100644
index 00000000000..e9e029123c7
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.bak Sun Jun 20 22:44:53 2004
++++ Makefile.PL Sun Jun 20 22:45:05 2004
+@@ -7,7 +7,7 @@
+ my %args = map { split /\s*=\s*/ } @ARGV;
+ my $LIBS = $args{ LIBS } || "-lstatgrab";
+ my $INC = $args{ INC };
+- return 1 if system("$CC check.c $INC $LIBS -o /dev/null 2>/dev/null") == 0;
++ return 1 if system("$CC check.c $INC $LIBS 2>/dev/null") == 0;
+ return 0;
+ }
+
diff --git a/devel/p5-Unix-Statgrab/pkg-descr b/devel/p5-Unix-Statgrab/pkg-descr
new file mode 100644
index 00000000000..6ed6cbaf892
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/pkg-descr
@@ -0,0 +1,7 @@
+Unix::Statgrab is a wrapper for libstatgrab, as available from
+http://www.i-scream.org/libstatgrab/. It is a reasonably portable
+attempt to query interesting stats about your computer. It covers
+information on the operating system, CPU, memory usage, network
+interfaces, hard-disks etc.
+
+WWW: http://search.cpan.org/dist/Unix-Statgrab/
diff --git a/devel/p5-Unix-Statgrab/pkg-plist b/devel/p5-Unix-Statgrab/pkg-plist
new file mode 100644
index 00000000000..9c48d208326
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/Statgrab.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/Statgrab.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Unix/Statgrab.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Unix 2>/dev/null || true