aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2010-05-23 22:50:33 +0800
committerdanfe <danfe@FreeBSD.org>2010-05-23 22:50:33 +0800
commitd49e18a7049da50b84d4251b87312e8eae7a4cae (patch)
treec95f1941dbdd468e91858e7dfdd59b33b4bc3ed9 /devel
parent1df7bafb5b96517ce79259ae8a811bbee905ee0e (diff)
downloadfreebsd-ports-graphics-d49e18a7049da50b84d4251b87312e8eae7a4cae.tar.gz
freebsd-ports-graphics-d49e18a7049da50b84d4251b87312e8eae7a4cae.tar.zst
freebsd-ports-graphics-d49e18a7049da50b84d4251b87312e8eae7a4cae.zip
- Update to version 2.08.01
- Remove SF mirror now that it does not carry new distfiles any more - Reformat (kill line wrapping) and sort MAN1 values - Simplify PORTDOCS installation, canonicalize Makefile header - Replace `x86-64' with FreeBSDish `amd64' in COMMENT Approved by: krion (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/nasm/Makefile25
-rw-r--r--devel/nasm/distinfo12
-rw-r--r--devel/nasm/files/patch-output+outelf32.c12
-rw-r--r--devel/nasm/files/patch-output+outelf64.c12
4 files changed, 29 insertions, 32 deletions
diff --git a/devel/nasm/Makefile b/devel/nasm/Makefile
index 645378e8736..27d39874f1b 100644
--- a/devel/nasm/Makefile
+++ b/devel/nasm/Makefile
@@ -1,36 +1,33 @@
-# New ports collection makefile for: nasm
-# Date created: 7 April 1998
-# Whom: Murray Stokely <murray@cdrom.com>
+# New ports collection makefile for: The Netwide Assembler
+# Date created: 7 April 1998
+# Whom: Murray Stokely <murray@cdrom.com>
#
# $FreeBSD$
#
PORTNAME= nasm
-PORTVERSION= 2.07
+PORTVERSION= 2.08.01
PORTEPOCH= 1
CATEGORIES= devel lang
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20sources/${PORTVERSION} \
- http://www.nasm.us/pub/nasm/releasebuilds/${PORTVERSION}/
+MASTER_SITES= http://www.nasm.us/pub/nasm/releasebuilds/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-xdoc${EXTRACT_SUFX}
MAINTAINER= krion@FreeBSD.org
-COMMENT= General-purpose multi-platform x86 and x86-64 assembler
+COMMENT= General-purpose multi-platform x86 and amd64 assembler
USE_BZIP2= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install install_rdf
MAKE_JOBS_UNSAFE= yes
-MAN1= nasm.1 ndisasm.1 \
- ldrdf.1 rdf2bin.1 rdf2com.1 rdf2ihx.1 rdf2ith.1 rdf2srec.1 rdfdump.1 rdflib.1 rdx.1
-PORTDOCS= nasmdoc.txt
+MAN1= ldrdf.1 nasm.1 ndisasm.1 rdf2bin.1 rdf2com.1 rdf2ihx.1 \
+ rdf2ith.1 rdf2srec.1 rdfdump.1 rdflib.1 rdx.1
+PORTDOCS= *
post-install:
.ifndef(NOPORTDOCS)
-. for d in ${PORTDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/$d ${DOCSDIR}
-. endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/nasmdoc.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/nasm/distinfo b/devel/nasm/distinfo
index 63c2cc27a55..f690b68440d 100644
--- a/devel/nasm/distinfo
+++ b/devel/nasm/distinfo
@@ -1,6 +1,6 @@
-MD5 (nasm-2.07.tar.bz2) = d8934231e81874c29374ddef1fbdb1ed
-SHA256 (nasm-2.07.tar.bz2) = ac70ee451c73d742c9ff830502e5f8b1f648b2abffa8fd00944243283ba8e87c
-SIZE (nasm-2.07.tar.bz2) = 779934
-MD5 (nasm-2.07-xdoc.tar.bz2) = ef3c3eeb62f155adf27a7185d603b1dd
-SHA256 (nasm-2.07-xdoc.tar.bz2) = 0f946fc70067cf56d94a8e0db48257f03faa7bcf1e8987cce39b8e0ab128ecf3
-SIZE (nasm-2.07-xdoc.tar.bz2) = 815521
+MD5 (nasm-2.08.01.tar.bz2) = 1e3ebc1289c2be5963571c0937b7a211
+SHA256 (nasm-2.08.01.tar.bz2) = 049b9a1381c0c775a07490f272a57c1802627cbfd6b2d675770b72078bdd8bc6
+SIZE (nasm-2.08.01.tar.bz2) = 782436
+MD5 (nasm-2.08.01-xdoc.tar.bz2) = 7d43e061b32e62c480ea78486f4f355f
+SHA256 (nasm-2.08.01-xdoc.tar.bz2) = 67a5f148b8aa2cbced086493cb99f8a7c5c960bb49bcfc20ad9e2e2a6fe3c948
+SIZE (nasm-2.08.01-xdoc.tar.bz2) = 820135
diff --git a/devel/nasm/files/patch-output+outelf32.c b/devel/nasm/files/patch-output+outelf32.c
index 94f72f3d139..cda901ac2ee 100644
--- a/devel/nasm/files/patch-output+outelf32.c
+++ b/devel/nasm/files/patch-output+outelf32.c
@@ -1,9 +1,9 @@
---- output/outelf32.c.orig 2008-03-03 16:15:43.564355152 -0500
-+++ output/outelf32.c 2008-03-03 16:21:02.242598895 -0500
-@@ -1605,7 +1605,7 @@
- the source-file, the n_desc field should be set to the number
- of remaining stabs
- */
+--- output/outelf32.c.orig
++++ output/outelf32.c
+@@ -1702,7 +1702,7 @@
+ * the source-file, the n_desc field should be set to the number
+ * of remaining stabs
+ */
- WRITE_STAB(sptr, fileidx[0], 0, 0, 0, strlen(allfiles[0] + 12));
+ WRITE_STAB(sptr, fileidx[0], 0, 0, 0, stabstrlen);
diff --git a/devel/nasm/files/patch-output+outelf64.c b/devel/nasm/files/patch-output+outelf64.c
index 148b4aa7f1b..5d8b8a7f57f 100644
--- a/devel/nasm/files/patch-output+outelf64.c
+++ b/devel/nasm/files/patch-output+outelf64.c
@@ -1,9 +1,9 @@
---- output/outelf64.c.orig 2008-03-03 16:15:57.373145096 -0500
-+++ output/outelf64.c 2008-03-03 16:23:30.075070061 -0500
-@@ -1841,7 +1841,7 @@
- the source-file, the n_desc field should be set to the number
- of remaining stabs
- */
+--- output/outelf64.c.orig
++++ output/outelf64.c
+@@ -1772,7 +1772,7 @@
+ * the source-file, the n_desc field should be set to the number
+ * of remaining stabs
+ */
- WRITE_STAB(sptr, fileidx[0], 0, 0, 0, strlen(allfiles[0] + 12));
+ WRITE_STAB(sptr, fileidx[0], 0, 0, 0, stabstrlen);