aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-08-05 00:54:10 +0800
committeritetcu <itetcu@FreeBSD.org>2006-08-05 00:54:10 +0800
commitd8ed3c63fa51be5f94945e981d685a4e0b606809 (patch)
treed0d33c9fc92b7e7ae40c959e85edb45e7dcd544b /devel
parent908c45a8fd2d0dbf9a36044610dc4abbfb8e3a48 (diff)
downloadfreebsd-ports-graphics-d8ed3c63fa51be5f94945e981d685a4e0b606809.tar.gz
freebsd-ports-graphics-d8ed3c63fa51be5f94945e981d685a4e0b606809.tar.zst
freebsd-ports-graphics-d8ed3c63fa51be5f94945e981d685a4e0b606809.zip
This is a camlp4 extension that expands brace expansions like a shell
does. See sample.ml for examples. Author: Gerd Stolpmann WWW: http://www.ocaml-programming.de/packages/ PR: ports/101219 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-xstrp4/Makefile49
-rw-r--r--devel/ocaml-xstrp4/distinfo3
-rw-r--r--devel/ocaml-xstrp4/pkg-descr5
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bd75ebf7df1..cd951f71d74 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -706,6 +706,7 @@
SUBDIR += ocaml-sdl
SUBDIR += ocaml-sem
SUBDIR += ocaml-ulex
+ SUBDIR += ocaml-xstrp4
SUBDIR += ocamlweb
SUBDIR += ode
SUBDIR += ode-devel
diff --git a/devel/ocaml-xstrp4/Makefile b/devel/ocaml-xstrp4/Makefile
new file mode 100644
index 00000000000..a4929d9a7e4
--- /dev/null
+++ b/devel/ocaml-xstrp4/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ocaml-xstrp4
+# Date created: 2006-08-01
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= xstrp4
+PORTVERSION= 1.6
+CATEGORIES= devel
+MASTER_SITES= http://www.ocaml-programming.de/packages/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An OCaml extension to expands brace expansions
+
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample.* ${EXAMPLESDIR}
+
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+
+ @${ECHO_CMD} "@dirrm share/examples/ocaml/${PORTNAME}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/share/examples/ocaml 2>/dev/null ||true"\
+ >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-xstrp4/distinfo b/devel/ocaml-xstrp4/distinfo
new file mode 100644
index 00000000000..d2934e8541a
--- /dev/null
+++ b/devel/ocaml-xstrp4/distinfo
@@ -0,0 +1,3 @@
+MD5 (xstrp4-1.6.tar.gz) = 5322d8878f8c42e54c1a4fa27ee0a8c0
+SHA256 (xstrp4-1.6.tar.gz) = 09ffb1d0c309fec24207f677bcb44ad301da34d4a330d9ec8265953b03713f25
+SIZE (xstrp4-1.6.tar.gz) = 6460
diff --git a/devel/ocaml-xstrp4/pkg-descr b/devel/ocaml-xstrp4/pkg-descr
new file mode 100644
index 00000000000..77dc0b31f6e
--- /dev/null
+++ b/devel/ocaml-xstrp4/pkg-descr
@@ -0,0 +1,5 @@
+This is a camlp4 extension that expands brace expansions like a shell
+does. See sample.ml for examples.
+
+Author: Gerd Stolpmann
+WWW: http://www.ocaml-programming.de/packages/