aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2002-06-05 04:43:34 +0800
committertobez <tobez@FreeBSD.org>2002-06-05 04:43:34 +0800
commitdf94048a16ee5a3847b6130d1fb46b3205b63ab4 (patch)
treeb481468badf20db22782292871f165cc24400d7c /devel
parentf1758ea8e3ccd5a8f5c071fde9f1f98ee8be9a9e (diff)
downloadfreebsd-ports-graphics-df94048a16ee5a3847b6130d1fb46b3205b63ab4.tar.gz
freebsd-ports-graphics-df94048a16ee5a3847b6130d1fb46b3205b63ab4.tar.zst
freebsd-ports-graphics-df94048a16ee5a3847b6130d1fb46b3205b63ab4.zip
Add p5-IO-Multiplex, a convenient wrapper around select().
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IO-Multiplex/Makefile25
-rw-r--r--devel/p5-IO-Multiplex/distinfo1
-rw-r--r--devel/p5-IO-Multiplex/pkg-comment1
-rw-r--r--devel/p5-IO-Multiplex/pkg-descr8
-rw-r--r--devel/p5-IO-Multiplex/pkg-plist4
6 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 893a4e98eb9..b4a0e65f68f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -439,6 +439,7 @@
SUBDIR += p5-Glade-Perl
SUBDIR += p5-Heap
SUBDIR += p5-IO
+ SUBDIR += p5-IO-Multiplex
SUBDIR += p5-IO-String
SUBDIR += p5-IO-Stty
SUBDIR += p5-IO-Tty
diff --git a/devel/p5-IO-Multiplex/Makefile b/devel/p5-IO-Multiplex/Makefile
new file mode 100644
index 00000000000..61aeaa4a730
--- /dev/null
+++ b/devel/p5-IO-Multiplex/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-IO-Multiplex
+# Date created: 04 June 2002
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Multiplex
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Multiplex.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-Multiplex/distinfo b/devel/p5-IO-Multiplex/distinfo
new file mode 100644
index 00000000000..5a62c70fbd6
--- /dev/null
+++ b/devel/p5-IO-Multiplex/distinfo
@@ -0,0 +1 @@
+MD5 (IO-Multiplex-1.03.tar.gz) = f515f3018c9b125c6e706b90f7afc9d4
diff --git a/devel/p5-IO-Multiplex/pkg-comment b/devel/p5-IO-Multiplex/pkg-comment
new file mode 100644
index 00000000000..3bb64e023e6
--- /dev/null
+++ b/devel/p5-IO-Multiplex/pkg-comment
@@ -0,0 +1 @@
+IO::Multiplex - Manage IO on many file handles
diff --git a/devel/p5-IO-Multiplex/pkg-descr b/devel/p5-IO-Multiplex/pkg-descr
new file mode 100644
index 00000000000..851db88e2e1
--- /dev/null
+++ b/devel/p5-IO-Multiplex/pkg-descr
@@ -0,0 +1,8 @@
+IO::Multiplex is designed to take the effort out of managing multiple
+file handles. It is essentially a really fancy front end to the select
+system call. In addition to maintaining the select loop, it buffers all
+input and output to/from the file handles. It can also accept incoming
+connections on one or more listen sockets.
+
+Author: Bruce J Keeler <bruce@gridpoint.com>
+WWW: http://search.cpan.org/search?dist=IO-Multiplex
diff --git a/devel/p5-IO-Multiplex/pkg-plist b/devel/p5-IO-Multiplex/pkg-plist
new file mode 100644
index 00000000000..5f525f16cf5
--- /dev/null
+++ b/devel/p5-IO-Multiplex/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Multiplex/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/IO/Multiplex.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Multiplex
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/IO 2>/dev/null || true