aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2009-09-14 00:45:59 +0800
committertobez <tobez@FreeBSD.org>2009-09-14 00:45:59 +0800
commite02f79bdc0ac363a80a6fa442e132613c4554eed (patch)
tree0b49d2ac11c7569b9e542634dd1990de5fd44ae3 /devel
parent62aa84df59b0ef0d1e7fd6a6da5bd40a6a239ba8 (diff)
downloadfreebsd-ports-graphics-e02f79bdc0ac363a80a6fa442e132613c4554eed.tar.gz
freebsd-ports-graphics-e02f79bdc0ac363a80a6fa442e132613c4554eed.tar.zst
freebsd-ports-graphics-e02f79bdc0ac363a80a6fa442e132613c4554eed.zip
Update to 0.71.
Changes: http://search.cpan.org/dist/Algorithm-Evolutionary/Changes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Algorithm-Evolutionary/Makefile6
-rw-r--r--devel/p5-Algorithm-Evolutionary/distinfo6
-rw-r--r--devel/p5-Algorithm-Evolutionary/pkg-plist3
3 files changed, 10 insertions, 5 deletions
diff --git a/devel/p5-Algorithm-Evolutionary/Makefile b/devel/p5-Algorithm-Evolutionary/Makefile
index 520d8ce13ce..d4334464770 100644
--- a/devel/p5-Algorithm-Evolutionary/Makefile
+++ b/devel/p5-Algorithm-Evolutionary/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= Algorithm-Evolutionary
-PORTVERSION= 0.70
+PORTVERSION= 0.71
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -37,7 +37,7 @@ BUILD_DEPENDS+= p5-Test-Pod>0:${PORTSDIR}/devel/p5-Test-Pod \
PERL_CONFIGURE= yes
MAN1= tide_bitstring.pl.1 tide_float.pl.1 \
- canonical-genetic-algorithm.pl.1
+ canonical-genetic-algorithm.pl.1 rectangle-coverage.pl.1
MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Experiment.3 \
Algorithm::Evolutionary::Fitness::Any.3 \
@@ -52,6 +52,7 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Fitness::Trap.3 \
Algorithm::Evolutionary::Fitness::ZDT1.3 \
Algorithm::Evolutionary::Fitness::wP_Peaks.3 \
+ Algorithm::Evolutionary::Hash_Wheel.3 \
Algorithm::Evolutionary::Individual::Any.3 \
Algorithm::Evolutionary::Individual::Base.3 \
Algorithm::Evolutionary::Individual::BitString.3 \
@@ -70,6 +71,7 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Op::Creator.3 \
Algorithm::Evolutionary::Op::Crossover.3 \
Algorithm::Evolutionary::Op::DeltaTerm.3 \
+ Algorithm::Evolutionary::Op::EDA_step.3 \
Algorithm::Evolutionary::Op::Easy.3 \
Algorithm::Evolutionary::Op::Easy_MO.3 \
Algorithm::Evolutionary::Op::Eval::General.3 \
diff --git a/devel/p5-Algorithm-Evolutionary/distinfo b/devel/p5-Algorithm-Evolutionary/distinfo
index dfacc36c2e7..bf9add7c8d8 100644
--- a/devel/p5-Algorithm-Evolutionary/distinfo
+++ b/devel/p5-Algorithm-Evolutionary/distinfo
@@ -1,3 +1,3 @@
-MD5 (Algorithm-Evolutionary-0.70.tar.gz) = 8c7513e7c4d1ea2b17616871754ed4b1
-SHA256 (Algorithm-Evolutionary-0.70.tar.gz) = 947ee8c316cacbb67971f5dc545fa045265e31e73fe6f409273fb1ef281869ad
-SIZE (Algorithm-Evolutionary-0.70.tar.gz) = 94035
+MD5 (Algorithm-Evolutionary-0.71.tar.gz) = 4ca74a4078e04fb4c959cb67d28477ff
+SHA256 (Algorithm-Evolutionary-0.71.tar.gz) = ad0ba7f99301baf588c34751ea81f964f5d096f02875050898503f48b770864c
+SIZE (Algorithm-Evolutionary-0.71.tar.gz) = 95396
diff --git a/devel/p5-Algorithm-Evolutionary/pkg-plist b/devel/p5-Algorithm-Evolutionary/pkg-plist
index a588361e983..6780f36d94b 100644
--- a/devel/p5-Algorithm-Evolutionary/pkg-plist
+++ b/devel/p5-Algorithm-Evolutionary/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
bin/canonical-genetic-algorithm.pl
+bin/rectangle-coverage.pl
bin/tide_bitstring.pl
bin/tide_float.pl
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary/.packlist
@@ -17,6 +18,7 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Trap.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/ZDT1.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/wP_Peaks.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Hash_Wheel.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Any.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Base.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/BitString.pm
@@ -35,6 +37,7 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Creator.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Crossover.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/DeltaTerm.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/EDA_step.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Easy.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Easy_MO.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Eval/General.pm