aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2003-12-10 18:32:18 +0800
committerskv <skv@FreeBSD.org>2003-12-10 18:32:18 +0800
commite0a680ecf73ea15d157ad494bed4eba0d9d3a394 (patch)
tree5784321f6371026c18f58425e50372b0f68c97b3 /devel
parentab904b2ba7ba090b49431e70795a23f34709cf8d (diff)
downloadfreebsd-ports-graphics-e0a680ecf73ea15d157ad494bed4eba0d9d3a394.tar.gz
freebsd-ports-graphics-e0a680ecf73ea15d157ad494bed4eba0d9d3a394.tar.zst
freebsd-ports-graphics-e0a680ecf73ea15d157ad494bed4eba0d9d3a394.zip
Add p5-File-chdir 0.06, a more sensible way to change directories.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-chdir/Makefile22
-rw-r--r--devel/p5-File-chdir/distinfo1
-rw-r--r--devel/p5-File-chdir/pkg-descr12
-rw-r--r--devel/p5-File-chdir/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7e64d3f595b..d2b5a83111e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -679,6 +679,7 @@
SUBDIR += p5-File-Sync
SUBDIR += p5-File-Tail
SUBDIR += p5-File-Temp
+ SUBDIR += p5-File-chdir
SUBDIR += p5-FileHandle-Unget
SUBDIR += p5-Filter
SUBDIR += p5-Filter-CBC
diff --git a/devel/p5-File-chdir/Makefile b/devel/p5-File-chdir/Makefile
new file mode 100644
index 00000000000..e68dbc8c862
--- /dev/null
+++ b/devel/p5-File-chdir/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: File-chdir
+# Date created: 10 December 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-chdir
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= A more sensible way to change directories
+
+PERL_CONFIGURE= yes
+
+MAN3= File::chdir.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-chdir/distinfo b/devel/p5-File-chdir/distinfo
new file mode 100644
index 00000000000..a10f9f2b24f
--- /dev/null
+++ b/devel/p5-File-chdir/distinfo
@@ -0,0 +1 @@
+MD5 (File-chdir-0.06.tar.gz) = 41a4661789f6de97fb632e4560d37864
diff --git a/devel/p5-File-chdir/pkg-descr b/devel/p5-File-chdir/pkg-descr
new file mode 100644
index 00000000000..d2dd0bb7229
--- /dev/null
+++ b/devel/p5-File-chdir/pkg-descr
@@ -0,0 +1,12 @@
+Perl's chdir() has the unfortunate problem of being very, very, very
+global. If any part of your program calls chdir() or if any library you
+use calls chdir(), it changes the current working directory for the
+whole program.
+
+File::chdir gives you an alternative, $CWD and @CWD. These two
+variables combine all the power of chdir(), File::Spec and Cwd.
+
+WWW: http://search.cpan.org/dist/File-chdir/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-File-chdir/pkg-plist b/devel/p5-File-chdir/pkg-plist
new file mode 100644
index 00000000000..ca971eb7651
--- /dev/null
+++ b/devel/p5-File-chdir/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/chdir/.packlist
+%%SITE_PERL%%/File/chdir.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/chdir
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true