aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-04-10 17:17:32 +0800
committerclsung <clsung@FreeBSD.org>2008-04-10 17:17:32 +0800
commite18839bbc0c33aa571485f56f61848826665721c (patch)
tree10a6c087d638ab25b428ecb919d33ccf491a2cea /devel
parentd3e5df801f4c9cf1963e6c6c943e0ddcf52e76fb (diff)
downloadfreebsd-ports-graphics-e18839bbc0c33aa571485f56f61848826665721c.tar.gz
freebsd-ports-graphics-e18839bbc0c33aa571485f56f61848826665721c.tar.zst
freebsd-ports-graphics-e18839bbc0c33aa571485f56f61848826665721c.zip
Python bindings for Shapelib
============================ These are three python modules for shapelib: shapelib read/write shapefiles dbflib read/write dbf files shptree quadtree for shapes Shapelib is a free software library for reading and writing ESRI shape files and can be found at http://gdal.velocet.ca/projects/shapelib. The bindings were partly created with SWIG, a tool that can generate wrappers of C and C++ libraries for a variety of scripting languages. It's homepage is http://www.swig.org. The bindings themselves don't have a homepage at the moment, but the source tarballs/zip files can be downloaded from http://ftp.intevation.de/users/bh/pyshapelib/ WWW: http://ftp.intevation.de/users/bh/pyshapelib/ PR: ports/121067 Submitted by: TAOKA Fumiyoshi <fmysh at iijmio-mail.jp>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyshapelib/Makefile46
-rw-r--r--devel/py-pyshapelib/distinfo6
-rw-r--r--devel/py-pyshapelib/pkg-descr24
-rw-r--r--devel/py-pyshapelib/pkg-plist9
5 files changed, 86 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8e382cf7e39..3a7ec23b3e7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2054,6 +2054,7 @@
SUBDIR += py-px
SUBDIR += py-pycallgraph
SUBDIR += py-pydasm
+ SUBDIR += py-pyshapelib
SUBDIR += py-pytz
SUBDIR += py-pyutil
SUBDIR += py-qt4-assistant
diff --git a/devel/py-pyshapelib/Makefile b/devel/py-pyshapelib/Makefile
new file mode 100644
index 00000000000..c82c5a81698
--- /dev/null
+++ b/devel/py-pyshapelib/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: pyshapelib
+# Date created: 03 Feb 2008
+# Whom: TAOKA Fumiyoshi <fmysh@iijmio-mail.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyshapelib
+PORTVERSION= 0.3
+CATEGORIES= devel python geography
+MASTER_SITES= http://ftp.intevation.de/users/bh/pyshapelib/:py \
+ http://dl.maptools.org/dl/shapelib/:c
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:py ${SHAPELIB}${EXTRACT_SUFX}:c
+
+MAINTAINER= fmysh@iijmio-mail.jp
+COMMENT= Python bindings for Shapelib
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+SHAPELIB= shapelib-1.2.10
+USE_LDCONFIG= yes
+
+PORTDOCS= NEWS README
+PORTEXAMPLES= pytest.py
+
+post-extract:
+ ${LN} -s ${WRKDIR}/${SHAPELIB} ${WRKDIR}/shapelib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyshapelib/distinfo b/devel/py-pyshapelib/distinfo
new file mode 100644
index 00000000000..f6a581ced7b
--- /dev/null
+++ b/devel/py-pyshapelib/distinfo
@@ -0,0 +1,6 @@
+MD5 (pyshapelib-0.3.tar.gz) = 41372e56f96167ed8202eb6f747360a4
+SHA256 (pyshapelib-0.3.tar.gz) = 492d5050135c05e8213eecfcaedbccebf8e960a4407615a5d72af4696f409ad1
+SIZE (pyshapelib-0.3.tar.gz) = 40427
+MD5 (shapelib-1.2.10.tar.gz) = 4d96bd926167193d27bf14d56e2d484e
+SHA256 (shapelib-1.2.10.tar.gz) = afa54d60369e49a3d2ebcd1ffca75104bdc85d7f539b81aec8a6e2d311ca6b78
+SIZE (shapelib-1.2.10.tar.gz) = 167219
diff --git a/devel/py-pyshapelib/pkg-descr b/devel/py-pyshapelib/pkg-descr
new file mode 100644
index 00000000000..c50f12518fa
--- /dev/null
+++ b/devel/py-pyshapelib/pkg-descr
@@ -0,0 +1,24 @@
+
+Python bindings for Shapelib
+============================
+
+These are three python modules for shapelib:
+
+ shapelib read/write shapefiles
+
+ dbflib read/write dbf files
+
+ shptree quadtree for shapes
+
+Shapelib is a free software library for reading and writing ESRI shape
+files and can be found at http://gdal.velocet.ca/projects/shapelib.
+
+The bindings were partly created with SWIG, a tool that can generate
+wrappers of C and C++ libraries for a variety of scripting languages.
+It's homepage is http://www.swig.org.
+
+The bindings themselves don't have a homepage at the moment, but the
+source tarballs/zip files can be downloaded from
+http://ftp.intevation.de/users/bh/pyshapelib/
+
+WWW: http://ftp.intevation.de/users/bh/pyshapelib/
diff --git a/devel/py-pyshapelib/pkg-plist b/devel/py-pyshapelib/pkg-plist
new file mode 100644
index 00000000000..416638ab21f
--- /dev/null
+++ b/devel/py-pyshapelib/pkg-plist
@@ -0,0 +1,9 @@
+%%PYTHON_SITELIBDIR%%/dbflib.py
+%%PYTHON_SITELIBDIR%%/dbflib.pyc
+%%PYTHON_SITELIBDIR%%/dbflib.pyo
+%%PYTHON_SITELIBDIR%%/dbflibc.so
+%%PYTHON_SITELIBDIR%%/shapelib.py
+%%PYTHON_SITELIBDIR%%/shapelib.pyc
+%%PYTHON_SITELIBDIR%%/shapelib.pyo
+%%PYTHON_SITELIBDIR%%/shapelibc.so
+%%PYTHON_SITELIBDIR%%/shptree.so