aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-01-29 01:22:44 +0800
committermiwi <miwi@FreeBSD.org>2011-01-29 01:22:44 +0800
commiteece96e49fa382be1f8c2e8c8abc08dc3330d43f (patch)
tree3ce0f0cfd5877a07362aaa5332079540eaf8d89f /devel
parentf746b9484949812a6a0e1f1f48a20adfd2d2a79a (diff)
downloadfreebsd-ports-graphics-eece96e49fa382be1f8c2e8c8abc08dc3330d43f.tar.gz
freebsd-ports-graphics-eece96e49fa382be1f8c2e8c8abc08dc3330d43f.tar.zst
freebsd-ports-graphics-eece96e49fa382be1f8c2e8c8abc08dc3330d43f.zip
This module implements asynchronous notifications that enable you
to signal running perl code from another thread, asynchronously, and sometimes even without using a single syscall. WWW: http://search.cpan.org/dist/Async-Interrupt/ PR: ports/153837 Submitted by: Mikhail T. <michael at fun-box.ru> Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Async-Interrupt/Makefile21
-rw-r--r--devel/p5-Async-Interrupt/distinfo2
-rw-r--r--devel/p5-Async-Interrupt/pkg-descr5
-rw-r--r--devel/p5-Async-Interrupt/pkg-plist8
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fd8c739c29d..c3b18fa031a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1181,6 +1181,7 @@
SUBDIR += p5-Array-Iterator
SUBDIR += p5-Array-Unique
SUBDIR += p5-Array-Window
+ SUBDIR += p5-Async-Interrupt
SUBDIR += p5-Async-MergePoint
SUBDIR += p5-AtExit
SUBDIR += p5-Attribute-Handlers
diff --git a/devel/p5-Async-Interrupt/Makefile b/devel/p5-Async-Interrupt/Makefile
new file mode 100644
index 00000000000..c7e5189c77f
--- /dev/null
+++ b/devel/p5-Async-Interrupt/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Async-Interrupt
+# Date created: 2010-12-29
+# Whom: Mikhail T. <michael@fun-box.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Async-Interrupt
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= michael@fun-box.ru
+COMMENT= Allow C/XS libraries to interrupt perl asynchronously
+
+PERL_CONFIGURE= yes
+
+MAN3= Async::Interrupt.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Async-Interrupt/distinfo b/devel/p5-Async-Interrupt/distinfo
new file mode 100644
index 00000000000..06ae2b37d62
--- /dev/null
+++ b/devel/p5-Async-Interrupt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Async-Interrupt-1.05.tar.gz) = 2177e125175cd80857bff7e70d928ab794391c244a7e598c6f4f82b85b66c7f1
+SIZE (Async-Interrupt-1.05.tar.gz) = 24706
diff --git a/devel/p5-Async-Interrupt/pkg-descr b/devel/p5-Async-Interrupt/pkg-descr
new file mode 100644
index 00000000000..8e4c59dcb93
--- /dev/null
+++ b/devel/p5-Async-Interrupt/pkg-descr
@@ -0,0 +1,5 @@
+This module implements asynchronous notifications that enable you
+to signal running perl code from another thread, asynchronously,
+and sometimes even without using a single syscall.
+
+WWW: http://search.cpan.org/dist/Async-Interrupt/
diff --git a/devel/p5-Async-Interrupt/pkg-plist b/devel/p5-Async-Interrupt/pkg-plist
new file mode 100644
index 00000000000..6ba5c3310c1
--- /dev/null
+++ b/devel/p5-Async-Interrupt/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Async/Interrupt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt/Interrupt.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt/Interrupt.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%