aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-04 18:45:09 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-04 18:45:09 +0800
commitf220c7486212041424f704b88337cc8e6020d509 (patch)
tree72d80e754f28819b00166c6696441611a8eb30f3 /devel
parent8616aa601ec480e35f50fc5d8855092959140dd5 (diff)
downloadfreebsd-ports-graphics-f220c7486212041424f704b88337cc8e6020d509.tar.gz
freebsd-ports-graphics-f220c7486212041424f704b88337cc8e6020d509.tar.zst
freebsd-ports-graphics-f220c7486212041424f704b88337cc8e6020d509.zip
- Remove "BROKEN on powerpc" statement: the port builds and links fine
- Do not try to append to CONFIGURE_ARGS and thus sanitize indentation
Diffstat (limited to 'devel')
-rw-r--r--devel/libdlna/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/devel/libdlna/Makefile b/devel/libdlna/Makefile
index 44804e0c33f..d106b173929 100644
--- a/devel/libdlna/Makefile
+++ b/devel/libdlna/Makefile
@@ -18,9 +18,9 @@ USES= tar:bzip2 gmake pkgconfig
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS+= --prefix="${PREFIX}" --disable-optimize \
- --includedir="${PREFIX}/include" \
- --libdir="${PREFIX}/lib"
+CONFIGURE_ARGS= --prefix="${PREFIX}" --disable-optimize \
+ --includedir="${PREFIX}/include" \
+ --libdir="${PREFIX}/lib"
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -30,10 +30,4 @@ post-patch:
's#\(PKGCONFIG_DIR = \).*#\1${STAGEDIR}${PREFIX}/libdata/pkgconfig#' \
${WRKSRC}/Makefile
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc" && ${OSVERSION} > 900000
-BROKEN= Does not build on powerpc-9: fails to link
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>