aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-12-17 07:36:35 +0800
committerpav <pav@FreeBSD.org>2007-12-17 07:36:35 +0800
commitf770d382c710fdd5425975a44955aca6e67c1361 (patch)
tree01f57b7b81775ad0db0a5c1a1179ebfb5146c7a5 /devel
parentbbf92246df6be49ba42503f3ac79f8516906b7b5 (diff)
downloadfreebsd-ports-graphics-f770d382c710fdd5425975a44955aca6e67c1361.tar.gz
freebsd-ports-graphics-f770d382c710fdd5425975a44955aca6e67c1361.tar.zst
freebsd-ports-graphics-f770d382c710fdd5425975a44955aca6e67c1361.zip
- Mark BROKEN on respective targets/archs
Diffstat (limited to 'devel')
-rw-r--r--devel/cross-binutils/Makefile14
-rw-r--r--devel/cross-gcc/Makefile6
2 files changed, 19 insertions, 1 deletions
diff --git a/devel/cross-binutils/Makefile b/devel/cross-binutils/Makefile
index f4df54df4d7..e91214cb850 100644
--- a/devel/cross-binutils/Makefile
+++ b/devel/cross-binutils/Makefile
@@ -82,6 +82,18 @@ FIXREFS= ${SH} -c '${REINPLACE_CMD} -E \
-e "s,(@file)\{$$0\},\1\{${OURTARGET}-$$0\},g" \
-e "s,\($$0\),\(${OURTARGET}-$$0\),g" $$*' --
+.include <bsd.port.pre.mk>
+
+.if defined(TGTARCH)
+.if ${TGTARCH} == "sparc" && ${ARCH} == "amd64"
+BROKEN= Does not link
+.endif
+
+.if ${TGTARCH} == "m68k" && ${ARCH} == "amd64" && ${OSVERSION} < 600000
+BROKEN= Does not compile
+.endif
+.endif
+
post-patch:
#
# Patch and rename info files
@@ -122,4 +134,4 @@ post-install:
@${FIND} -ds ${PREFIX}/${OURTARGET} -type d | \
${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index d3c9281c542..b02d0846e23 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -134,6 +134,12 @@ OPTIONS= CXX "Enable C++ language support" on \
.include <bsd.port.pre.mk>
+.if defined(TGTARCH)
+.if ${TGTARCH} == "i386" && ${ARCH} == "amd64"
+BROKEN= Does not link
+.endif
+.endif
+
PKG_ARGS= -v -c -${COMMENT:Q} -d ${DESCR} -f ${TMPPLIST} -p ${PREFIX} -P "`cd ${PORTSDIR}/devel/cross-binutils && ${MAKE} ${DEPENDS_ARGS} -V PKGNAME`:devel/cross-binutils" ${EXTRA_PKG_ARGS} $${_LATE_PKG_ARGS} -m ${MTREE_FILE} -o ${PKGORIGIN}
.if !defined(WITHOUT_CXX)