aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2008-01-16 05:20:24 +0800
committerskv <skv@FreeBSD.org>2008-01-16 05:20:24 +0800
commitfd26b5674134bbcc9faa045f6f30bb4bc50cb102 (patch)
tree0d5df07fe1e23bf09122be8644ac440e7c85a4f5 /devel
parentde730ded75a8d178d93f84378cffeee0be4251fe (diff)
downloadfreebsd-ports-graphics-fd26b5674134bbcc9faa045f6f30bb4bc50cb102.tar.gz
freebsd-ports-graphics-fd26b5674134bbcc9faa045f6f30bb4bc50cb102.tar.zst
freebsd-ports-graphics-fd26b5674134bbcc9faa045f6f30bb4bc50cb102.zip
Add p5-SVN-S4 1.022, wrapper for subversion program.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-S4/Makefile31
-rw-r--r--devel/p5-SVN-S4/distinfo3
-rw-r--r--devel/p5-SVN-S4/pkg-descr6
-rw-r--r--devel/p5-SVN-S4/pkg-plist16
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b8ab14fdb26..00bde1e0ca2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1509,6 +1509,7 @@
SUBDIR += p5-SVN-Log
SUBDIR += p5-SVN-Mirror
SUBDIR += p5-SVN-Notify
+ SUBDIR += p5-SVN-S4
SUBDIR += p5-SVN-Simple
SUBDIR += p5-SVN-Statistics
SUBDIR += p5-SVN-Web
diff --git a/devel/p5-SVN-S4/Makefile b/devel/p5-SVN-S4/Makefile
new file mode 100644
index 00000000000..55966505c37
--- /dev/null
+++ b/devel/p5-SVN-S4/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: SVN-S4
+# Date created: 16 January 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-S4
+PORTVERSION= 1.022
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Wrapper for subversion program
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Client.pm:${PORTSDIR}/devel/subversion-perl \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/IO/AIO.pm:${PORTSDIR}/devel/p5-IO-AIO
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::S4.3 SVN::S4::FixProp.3 SVN::S4::Getopt.3 \
+ SVN::S4::Info.3 SVN::S4::Path.3 SVN::S4::QuickCommit.3 \
+ SVN::S4::Snapshot.3 SVN::S4::StrongRevert.3 SVN::S4::Update.3 \
+ SVN::S4::ViewSpec.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-S4/distinfo b/devel/p5-SVN-S4/distinfo
new file mode 100644
index 00000000000..65b34ac94dd
--- /dev/null
+++ b/devel/p5-SVN-S4/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-S4-1.022.tar.gz) = 24f98a7f294ad8806811115a34ccf993
+SHA256 (SVN-S4-1.022.tar.gz) = 302f14125b773fcc23a5d3a0bb4ed85b8579748026d600bcd662582abec51132
+SIZE (SVN-S4-1.022.tar.gz) = 58030
diff --git a/devel/p5-SVN-S4/pkg-descr b/devel/p5-SVN-S4/pkg-descr
new file mode 100644
index 00000000000..10e0d92ce86
--- /dev/null
+++ b/devel/p5-SVN-S4/pkg-descr
@@ -0,0 +1,6 @@
+S4 provides a wrapper to subversion that extends several of the commands
+(for example, "fixprop", "scrub", "snapshot"). It understands all svn
+commands; you may simply use "s4" whereever you would normally type
+"svn".
+
+WWW: http://search.cpan.org/dist/SVN-S4/
diff --git a/devel/p5-SVN-S4/pkg-plist b/devel/p5-SVN-S4/pkg-plist
new file mode 100644
index 00000000000..419dbd83c8b
--- /dev/null
+++ b/devel/p5-SVN-S4/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/S4/.packlist
+bin/s4
+%%SITE_PERL%%/SVN/S4.pm
+%%SITE_PERL%%/SVN/S4/FixProp.pm
+%%SITE_PERL%%/SVN/S4/Getopt.pm
+%%SITE_PERL%%/SVN/S4/Info.pm
+%%SITE_PERL%%/SVN/S4/Path.pm
+%%SITE_PERL%%/SVN/S4/QuickCommit.pm
+%%SITE_PERL%%/SVN/S4/Snapshot.pm
+%%SITE_PERL%%/SVN/S4/StrongRevert.pm
+%%SITE_PERL%%/SVN/S4/Update.pm
+%%SITE_PERL%%/SVN/S4/ViewSpec.pm
+@dirrm %%SITE_PERL%%/SVN/S4
+@dirrmtry %%SITE_PERL%%/SVN
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/S4
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN