aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /devel
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-graphics-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-graphics-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-graphics-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'devel')
-rw-r--r--devel/orbitcpp/Makefile5
-rw-r--r--devel/pedisassem/Makefile3
2 files changed, 5 insertions, 3 deletions
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index 1f573f08e56..142058180d5 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -20,13 +20,14 @@ LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
USE_GNOMENG= yes
USE_GNOME= glib12
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
INSTALL_CMD= /usr/bin/install -c -o ${BINOWN} -g ${BINGRP}
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
- 's|\@INSTALL\@|${INSTALL_CMD}|g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|@INSTALL@|${INSTALL_CMD}|g'
.include <bsd.port.mk>
diff --git a/devel/pedisassem/Makefile b/devel/pedisassem/Makefile
index f4546d4c8c1..6f7984d00ca 100644
--- a/devel/pedisassem/Makefile
+++ b/devel/pedisassem/Makefile
@@ -16,10 +16,11 @@ MAINTAINER= ports@FreeBSD.org
NO_WRKSUBDIR= yes
USE_ZIP= yes
+USE_REINPLACE= yes
MAKEFILE= ${FILESDIR}/Makefile
post-patch:
- @${PERL} -pi -e "s|\x0D|| ; s|malloc\.h|stdlib.h|" \
+ @${REINPLACE_CMD} -e "s|`/usr/bin/printf '\r'`|| ; s|malloc\.h|stdlib.h|" \
${WRKSRC}/*.[ch] ${WRKSRC}/readme.txt
post-install: