aboutsummaryrefslogtreecommitdiffstats
path: root/dns/fpdns/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-07-03 22:23:35 +0800
committeredwin <edwin@FreeBSD.org>2004-07-03 22:23:35 +0800
commit071c35b31d0bec199bd46a46530f219dfaab24a8 (patch)
tree61a8288d96e2fe30a4aae0b6e38ae252890bb0ee /dns/fpdns/Makefile
parent6d260bb77a1a6c3cd8a9ef6804afc8b88d0a7ba7 (diff)
downloadfreebsd-ports-graphics-071c35b31d0bec199bd46a46530f219dfaab24a8.tar.gz
freebsd-ports-graphics-071c35b31d0bec199bd46a46530f219dfaab24a8.tar.zst
freebsd-ports-graphics-071c35b31d0bec199bd46a46530f219dfaab24a8.zip
fpdns - Fingerprinting DNS servers
Identify what versions of nameserver software is running. WWW: http://www.rfc.se/fpdns/
Diffstat (limited to 'dns/fpdns/Makefile')
-rw-r--r--dns/fpdns/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
new file mode 100644
index 00000000000..fdfcef22830
--- /dev/null
+++ b/dns/fpdns/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fpdns
+# Date Created: July 2 2004
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpdns
+PORTVERSION= 0.9.0
+CATEGORIES= dns
+MASTER_SITES= http://www.rfc.se/fpdns/distfiles/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.gz
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= FPDNS - Fingerprinting DNS servers
+
+WRKSRC= ${WRKDIR}
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Requires at least Perl version 5.6.0"
+.endif
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${GZCAT} ${DISTDIR}/${DISTFILES} > ${WRKDIR}/fpdns.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/fpdns.pl ${PREFIX}/bin/fpdns
+
+.include <bsd.port.post.mk>