aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-06-09 02:32:30 +0800
committeradamw <adamw@FreeBSD.org>2016-06-09 02:32:30 +0800
commit0d92ac31f55cc36a1a657ce300c037869a75b8fd (patch)
tree7dc828894b753fb915081d053a625ff3244a2e02 /dns
parent8f9614c77ab78b9c3d5e217e683765b0850e7913 (diff)
downloadfreebsd-ports-graphics-0d92ac31f55cc36a1a657ce300c037869a75b8fd.tar.gz
freebsd-ports-graphics-0d92ac31f55cc36a1a657ce300c037869a75b8fd.tar.zst
freebsd-ports-graphics-0d92ac31f55cc36a1a657ce300c037869a75b8fd.zip
Digest::HMAC is only needed for TSIG support, so put it behind a TSIG
option that defaults to on.
Diffstat (limited to 'dns')
-rw-r--r--dns/p5-Net-DNS/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/dns/p5-Net-DNS/Makefile b/dns/p5-Net-DNS/Makefile
index aa4b9c137f6..827f6452e31 100644
--- a/dns/p5-Net-DNS/Makefile
+++ b/dns/p5-Net-DNS/Makefile
@@ -14,14 +14,14 @@ COMMENT= Perl5 interface to the DNS resolver, and dynamic updates
LICENSE= MIT
-BUILD_DEPENDS= p5-Digest-HMAC>=1.03:security/p5-Digest-HMAC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Digest-BubbleBabble>=0:security/p5-Digest-BubbleBabble \
p5-Test-Pod>=0:devel/p5-Test-Pod
-OPTIONS_DEFINE= GOST IDN IPV6 SSHFP
+OPTIONS_DEFINE= GOST IDN IPV6 SSHFP TSIG
+OPTIONS_DEFAULT=TSIG
GOST_DESC= GOST support
SSHFP_DESC= SSH2 Fingerprint support
+TSIG_DESC= Transaction Signature Support
CONFIGURE_ARGS= --no-IPv6-tests --no-online-tests
NO_ARCH= yes
@@ -34,6 +34,8 @@ IDN_BUILD_DEPENDS= p5-Net-LibIDN>=0.12:dns/p5-Net-LibIDN
IDN_RUN_DEPENDS= p5-Net-LibIDN>=0.12:dns/p5-Net-LibIDN
SSHFP_BUILD_DEPENDS= p5-Digest-BubbleBabble>=0.01:security/p5-Digest-BubbleBabble
SSHFP_RUN_DEPENDS= p5-Digest-BubbleBabble>=0.01:security/p5-Digest-BubbleBabble
+TSIG_BUILD_DEPENDS= p5-Digest-HMAC>=1.03:security/p5-Digest-HMAC
+TSIG_RUN_DEPENDS= p5-Digest-HMAC>=1.03:security/p5-Digest-HMAC
.include <bsd.port.pre.mk>