aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
committeraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
commit4539b36e07dc5d3a00796c31225b2da419544ef0 (patch)
tree59a0148ef943ecb5bc12a830cc669c801d3c91f8 /dns
parenta7f25a26617517dba99672639956e265390f576a (diff)
downloadfreebsd-ports-graphics-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.gz
freebsd-ports-graphics-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.zst
freebsd-ports-graphics-4539b36e07dc5d3a00796c31225b2da419544ef0.zip
- Convert to new perl framework
Diffstat (limited to 'dns')
-rw-r--r--dns/fpdns/Makefile3
-rw-r--r--dns/p5-Net-DNSBL-MultiDaemon/Makefile3
-rw-r--r--dns/p5-Net-LibIDN/Makefile3
-rw-r--r--dns/p5-Stanford-DNSserver/Makefile3
-rw-r--r--dns/p5-Tie-DNS/Makefile3
5 files changed, 10 insertions, 5 deletions
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
index 7ab25a08450..ac37ae3b295 100644
--- a/dns/fpdns/Makefile
+++ b/dns/fpdns/Makefile
@@ -19,7 +19,8 @@ GH_ACCOUNT= kirei
GH_COMMIT= 23eb0bf
GH_TAGNAME= 20130404
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= fpdns.1
diff --git a/dns/p5-Net-DNSBL-MultiDaemon/Makefile b/dns/p5-Net-DNSBL-MultiDaemon/Makefile
index f5cfc468d42..0c6285dc9cf 100644
--- a/dns/p5-Net-DNSBL-MultiDaemon/Makefile
+++ b/dns/p5-Net-DNSBL-MultiDaemon/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Unix-Syslog>=0:${PORTSDIR}/sysutils/p5-Unix-Syslog \
RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-File-SafeDO>=0:${PORTSDIR}/devel/p5-File-SafeDO
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::DNSBL::MultiDaemon.3 Net::DNSBL::Utilities.3
diff --git a/dns/p5-Net-LibIDN/Makefile b/dns/p5-Net-LibIDN/Makefile
index 3a07426cbeb..ffbf8574893 100644
--- a/dns/p5-Net-LibIDN/Makefile
+++ b/dns/p5-Net-LibIDN/Makefile
@@ -13,7 +13,8 @@ COMMENT= This module provides access to the libidn library
LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS+= --with-libidn=${PREFIX}/lib --with-libidn-inc=${PREFIX}/include
MAN3= Net::LibIDN.3
diff --git a/dns/p5-Stanford-DNSserver/Makefile b/dns/p5-Stanford-DNSserver/Makefile
index 3ab727eea12..a2a7d38f8ea 100644
--- a/dns/p5-Stanford-DNSserver/Makefile
+++ b/dns/p5-Stanford-DNSserver/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A DNS name server framework with a Perl backend
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Stanford::DNS.3 Stanford::DNSserver.3
diff --git a/dns/p5-Tie-DNS/Makefile b/dns/p5-Tie-DNS/Makefile
index 4b96284c6d7..fabed0e4a66 100644
--- a/dns/p5-Tie-DNS/Makefile
+++ b/dns/p5-Tie-DNS/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= p5-Net-DNS>=0.12:${PORTSDIR}/dns/p5-Net-DNS \
p5-Tie-Cache>=0.01:${PORTSDIR}/devel/p5-Tie-Cache
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::DNS.3