aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 01:45:09 +0800
committeraz <az@FreeBSD.org>2013-07-26 01:45:09 +0800
commita17aea5b36965f8ed6ecc0ca55f360944e3f46a8 (patch)
tree17b7739cec5c8bd24318f8970c77d5508f40b335 /dns
parent9bd11f4a568c740d3e38c88bf815647016ecdef7 (diff)
downloadfreebsd-ports-graphics-a17aea5b36965f8ed6ecc0ca55f360944e3f46a8.tar.gz
freebsd-ports-graphics-a17aea5b36965f8ed6ecc0ca55f360944e3f46a8.tar.zst
freebsd-ports-graphics-a17aea5b36965f8ed6ecc0ca55f360944e3f46a8.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'dns')
-rw-r--r--dns/sleuth/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/dns/sleuth/Makefile b/dns/sleuth/Makefile
index e40a43baa46..81b582cdee5 100644
--- a/dns/sleuth/Makefile
+++ b/dns/sleuth/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sleuth
-# Date created: Jun 15, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
-#
+# Created by: Mark Pulford <mark@kyne.com.au>
# $FreeBSD$
-#
PORTNAME= sleuth
PORTVERSION= 1.4.4
@@ -16,12 +12,14 @@ COMMENT= A tool for checking DNS zones
RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
USE_PERL5= yes
+USES= shebangfix
+SHEBANG_FILES= sleuth
PLIST_FILES= bin/sleuth etc/sleuth.conf.sample
post-patch:
- ${PERL} -pi -e "s|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|g; \
- s|#!/usr/bin/perl|#!${PERL}|g;" ${WRKSRC}/sleuth
+ @${REINPLACE_CMD} -i '' -e 's|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|' \
+ ${WRKSRC}/sleuth
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/sleuth ${PREFIX}/bin