aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-05-15 07:59:14 +0800
committermat <mat@FreeBSD.org>2014-05-15 07:59:14 +0800
commitdfc580695c21671ffe163374cac7100cd7f15879 (patch)
tree991cabe740d1959409257d086f7fc61b60a8819b /dns
parent23f2563b38fb9dca794bcef52f4c0c0a38c28b39 (diff)
downloadfreebsd-ports-graphics-dfc580695c21671ffe163374cac7100cd7f15879.tar.gz
freebsd-ports-graphics-dfc580695c21671ffe163374cac7100cd7f15879.tar.zst
freebsd-ports-graphics-dfc580695c21671ffe163374cac7100cd7f15879.zip
Make GOST in BIND 9.* optional
Test Plan: Currently testing in poudriere Differential Revision: https://phabric.freebsd.org/D12
Diffstat (limited to 'dns')
-rw-r--r--dns/bind910/Makefile6
-rw-r--r--dns/bind98/Makefile7
-rw-r--r--dns/bind99/Makefile9
3 files changed, 16 insertions, 6 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 40cd02d18aa..33c4b6577c9 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.10.0.1
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -34,7 +35,7 @@ SUB_FILES= pkg-message
OPTIONS_SUB= yes
OPTIONS_DEFAULT= IPV6 SSL THREADS SIGCHASE IDN
-OPTIONS_DEFINE= IDN LARGE_FILE \
+OPTIONS_DEFINE= IDN LARGE_FILE GOST \
FIXED_RRSET SIGCHASE IPV6 THREADS GSSAPI FILTER_AAAA
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -55,6 +56,7 @@ FILTER_AAAA_DESC= Enable filtering of AAAA records
CRYPTO_DESC= Choose which crypto engine to use
NATIVE_PKCS11_DESC= Use PKCS\#11 native API (**READ HELP**)
GEOIP_DESC= Allow geographically based ACL.
+GOST_DESC= Enable GOST ciphers (DSO incompatible with chroot)
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -97,6 +99,8 @@ NATIVE_PKCS11_CONFIGURE_ENABLE= native-pkcs11
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+GOST_CONFIGURE_WITH= gost
+
DLZ_POSTGRESQL_CONFIGURE_ON= --with-dlz-postgres=yes
DLZ_POSTGRESQL_USE= pgsql=yes
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 68774946285..32b8d93d9ab 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.8.7
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -35,7 +35,7 @@ CONFLICTS= bind9*-9.[45679].* bind9*-sdb-9.[45679].* bind-tools-9.*
OPTIONS_DEFAULT= IPV6 SSL THREADS
OPTIONS_DEFINE= SSL LINKS IDN REPLACE_BASE LARGE_FILE \
FIXED_RRSET RPZ_NSIP RPZ_NSDNAME RPZRRL_PATCH \
- SIGCHASE IPV6 THREADS GSSAPI FILTER_AAAA DOCS
+ SIGCHASE IPV6 THREADS GSSAPI FILTER_AAAA DOCS GOST
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
DLZ_LDAP DLZ_FILESYSTEM DLZ_STUB
@@ -50,6 +50,7 @@ RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
RPZ_NSDNAME_DESC= Enable RPZ NSDNAME policy records
RPZRRL_PATCH_DESC= RPZ improvements + RRL patch (experimental)
FILTER_AAAA_DESC= Enable filtering of AAAA records
+GOST_DESC= Enable GOST ciphers (DSO incompatible with chroot)
DLZ_DESC= Dynamically Loadable Zones
DLZ_POSTGRESQL_DESC= DLZ Postgres driver
DLZ_MYSQL_DESC= DLZ MySQL driver (no threading)
@@ -84,6 +85,8 @@ RPZ_NSDNAME_CONFIGURE_ENABLE= rpz-nsdname
RPZRRL_PATCH_PATCHFILES= 9.8.7-rpz2+rl.14038.05.patch:vix
RPZRRL_PATCH_PATCH_SITES= http://ss.vix.su/~vjs/:vix
+GOST_CONFIGURE_WITH= gost
+
DLZ_POSTGRESQL_CONFIGURE_ON= --with-dlz-postgres=yes
DLZ_POSTGRESQL_USE= pgsql=yes
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 9a7931ce223..669084a0a76 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.9.5
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -32,8 +32,8 @@ ETCDIR= ${PREFIX}/etc/namedb
CONFLICTS= bind9*-9.[45678].* bind9*-sdb-9.[45678].* bind-tools-9.*
OPTIONS_DEFAULT= IPV6 SSL THREADS
-OPTIONS_DEFINE= SSL IDN REPLACE_BASE LARGE_FILE \
- FIXED_RRSET SIGCHASE IPV6 THREADS GSSAPI FILTER_AAAA
+OPTIONS_DEFINE= SSL IDN REPLACE_BASE LARGE_FILE FIXED_RRSET SIGCHASE \
+ IPV6 THREADS GSSAPI FILTER_AAAA GOST
.if !defined(BIND_TOOLS_SLAVE)
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS RPZ_PATCH NEWSTATS
OPTIONS_GROUP= DLZ
@@ -47,6 +47,7 @@ LARGE_FILE_DESC= 64-bit file support
FIXED_RRSET_DESC= Enable fixed rrset ordering
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
FILTER_AAAA_DESC= Enable filtering of AAAA records
+GOST_DESC= Enable GOST ciphers (DSO incompatible with chroot)
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -85,6 +86,8 @@ IPV6_CONFIGURE_ENABLE= ipv6
FILTER_AAAA_CONFIGURE_ENABLE= filter-aaaa
+GOST_CONFIGURE_WITH= gost
+
DLZ_POSTGRESQL_CONFIGURE_ON= --with-dlz-postgres=yes
DLZ_POSTGRESQL_USE= pgsql=yes