aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-07-14 20:52:06 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-07-14 20:52:06 +0800
commite4293cc5671e0028c333649ebb210cdc15a4263d (patch)
treeb42a7ef11243853842efca3b97dafaf6630e9c7f /dns
parentc2c6cc1039cec6a21722dd98c9c64112458a9c03 (diff)
downloadfreebsd-ports-graphics-e4293cc5671e0028c333649ebb210cdc15a4263d.tar.gz
freebsd-ports-graphics-e4293cc5671e0028c333649ebb210cdc15a4263d.tar.zst
freebsd-ports-graphics-e4293cc5671e0028c333649ebb210cdc15a4263d.zip
- Update to 0.2.1
- Properly respect ${CC} - Cosmetic fixes - Mark broken on 9.x due to too long username PR: 210885 Submitted by: freebsd@toyingwithfate.com (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/dnscrypt-wrapper/Makefile11
-rw-r--r--dns/dnscrypt-wrapper/distinfo4
-rw-r--r--dns/dnscrypt-wrapper/files/patch-Makefile29
-rw-r--r--dns/dnscrypt-wrapper/files/patch-argparse_Makefile19
4 files changed, 56 insertions, 7 deletions
diff --git a/dns/dnscrypt-wrapper/Makefile b/dns/dnscrypt-wrapper/Makefile
index 5b6fc29d868..e7782e3cc8a 100644
--- a/dns/dnscrypt-wrapper/Makefile
+++ b/dns/dnscrypt-wrapper/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= dnscrypt-wrapper
-PORTVERSION= 0.2
+PORTVERSION= 0.2.1
DISTVERSIONPREFIX= v
PORTREVISION= 3
CATEGORIES= dns
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsodium.so:security/libsodium \
libevent.so:devel/libevent2
+BROKEN_FreeBSD_9= does not install (too long username)
+
USE_GITHUB= yes
GH_ACCOUNT= Cofyc
@@ -23,11 +25,10 @@ ETCDNSCRYPTWRAPPER= ${PREFIX}/etc/${PORTNAME}
SUB_LIST+= ETCDNSCRYPTWRAPPER="${ETCDNSCRYPTWRAPPER}" USERS="${USERS}"
USE_RC_SUBR= ${PORTNAME}
-USES= gmake
-MAKE_ARGS= LDFLAGS="-L${LOCALBASE}/lib" CFLAGS="-I${LOCALBASE}/include" PREFIX="${STAGEDIR}${PREFIX}"
+USES= gmake localbase
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
- ${MKDIR} ${STAGEDIR}${ETCDNSCRYPTWRAPPER}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
+ @${MKDIR} ${STAGEDIR}${ETCDNSCRYPTWRAPPER}
.include <bsd.port.mk>
diff --git a/dns/dnscrypt-wrapper/distinfo b/dns/dnscrypt-wrapper/distinfo
index 349d2a5d0e6..0fc176d89a5 100644
--- a/dns/dnscrypt-wrapper/distinfo
+++ b/dns/dnscrypt-wrapper/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Cofyc-dnscrypt-wrapper-v0.2_GH0.tar.gz) = 36612c5eb440658a27619ae6e345582e6e3be7a40e9215ea82ac6f65c15de95f
-SIZE (Cofyc-dnscrypt-wrapper-v0.2_GH0.tar.gz) = 50925
+SHA256 (Cofyc-dnscrypt-wrapper-v0.2.1_GH0.tar.gz) = 28c9936e90fc5602821353ca34c3180a047ae9eff08e0373cfa582e6af0c4e90
+SIZE (Cofyc-dnscrypt-wrapper-v0.2.1_GH0.tar.gz) = 52026
diff --git a/dns/dnscrypt-wrapper/files/patch-Makefile b/dns/dnscrypt-wrapper/files/patch-Makefile
new file mode 100644
index 00000000000..4f3ec441620
--- /dev/null
+++ b/dns/dnscrypt-wrapper/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig 2016-07-08 19:10:05 UTC
++++ Makefile
+@@ -7,7 +7,7 @@ all::
+
+ ### Defaults
+
+-BASIC_CFLAGS = -O2 -std=c99 -Wall -I./argparse
++BASIC_CFLAGS = -std=c99 -Wall -I./argparse
+ BASIC_LDFLAGS = -lm -lsodium
+
+ # Guard against environment variables
+@@ -29,13 +29,13 @@ uname_P := $(shell sh -c 'uname -p 2>/de
+ uname_V := $(shell sh -c 'uname -v 2>/dev/null || echo not')
+
+ # CFLAGS and LDFLAGS are for users to override
+-CFLAGS = -g -O2 -Wall
+-LDFLAGS =
++CFLAGS ?= -g -O2 -Wall
++LDFLAGS ?=
+ STRIP ?= strip
+
+ # We use ALL_* variants
+-ALL_CFLAGS = $(CFLAGS) $(BASIC_CFLAGS)
+-ALL_LDFLAGS = $(LDFLAGS) $(BASIC_LDFLAGS)
++ALL_CFLAGS = $(BASIC_CFLAGS) $(CFLAGS)
++ALL_LDFLAGS = $(BASIC_LDFLAGS) $(LDFLAGS)
+
+ ifdef PREFIX
+ prefix = $(PREFIX)
diff --git a/dns/dnscrypt-wrapper/files/patch-argparse_Makefile b/dns/dnscrypt-wrapper/files/patch-argparse_Makefile
new file mode 100644
index 00000000000..7eb0abb80ec
--- /dev/null
+++ b/dns/dnscrypt-wrapper/files/patch-argparse_Makefile
@@ -0,0 +1,19 @@
+--- argparse/Makefile.orig 2016-07-08 19:10:50 UTC
++++ argparse/Makefile
+@@ -1,10 +1,13 @@
+ # Defaults
+-BASIC_CFLAGS = -Wall -O3 -g -ggdb -fPIC
++CFLAGS ?= -O3 -g -ggdb
++LDFLAGS ?=
++
++BASIC_CFLAGS = -Wall -fPIC
+ BASIC_LDFLAGS = -lm
+
+ # We use ALL_* variants
+-ALL_CFLAGS = $(CFLAGS) $(BASIC_CFLAGS)
+-ALL_LDFLAGS = $(LDFLAGS) $(BASIC_LDFLAGS)
++ALL_CFLAGS = $(BASIC_CFLAGS) $(CFLAGS)
++ALL_LDFLAGS = $(BASIC_LDFLAGS) $(LDFLAGS)
+
+ LIBNAME=libargparse
+