aboutsummaryrefslogtreecommitdiffstats
path: root/editors/abiword/files
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-05-22 17:41:36 +0800
committerwill <will@FreeBSD.org>2000-05-22 17:41:36 +0800
commitc2f902b38bea76d0d1868ea30800458524a9c7fc (patch)
treeadba126e270727304cf5c909e29821572c97e888 /editors/abiword/files
parentf747009726e43b1fde152a3ebd65253b35cc1a89 (diff)
downloadfreebsd-ports-graphics-c2f902b38bea76d0d1868ea30800458524a9c7fc.tar.gz
freebsd-ports-graphics-c2f902b38bea76d0d1868ea30800458524a9c7fc.tar.zst
freebsd-ports-graphics-c2f902b38bea76d0d1868ea30800458524a9c7fc.zip
Update to 0.79.
1) Change of MAINTAINER, as dburr seems too busy to bother taking care of this port. He has never done any upgrades since originally importing it over a year ago. 2) Finally make spell-checking work. 3) Let AbiWord's own twisted Makefile mechanism install AbiWord. PR: 18692 Submitted by: Alec Wolman <wolman@cs.washington.edu>
Diffstat (limited to 'editors/abiword/files')
-rw-r--r--editors/abiword/files/patch-an43
-rw-r--r--editors/abiword/files/patch-ap22
-rw-r--r--editors/abiword/files/patch-aq27
-rw-r--r--editors/abiword/files/patch-ar11
4 files changed, 103 insertions, 0 deletions
diff --git a/editors/abiword/files/patch-an b/editors/abiword/files/patch-an
new file mode 100644
index 00000000000..ee7d51335e9
--- /dev/null
+++ b/editors/abiword/files/patch-an
@@ -0,0 +1,43 @@
+--- Makefile Tue Feb 29 07:34:29 2000
++++ Makefile.new Sun May 14 21:58:09 2000
+@@ -42,6 +42,7 @@
+
+ ## Set the following to a list of pathnames to be copied to $(CANONDIR)
+ CANON_TOPLEVELFILES= $(ABI_ROOT)/COPYING $(ABI_ROOT)/user/wp/readme.txt
++CANON_TLF_NOTDIR= $(notdir $(CANON_TOPLEVELFILES))
+
+ ## Set the following to a list of directories (probably a subset of DIRS)
+ ## that have work to do.
+@@ -52,6 +53,9 @@
+ @for k in $(CANON_TOPLEVELFILES); do \
+ $(ABICOPY) $$k $(CANONDIR); \
+ done
++ @for k in $(CANON_TLF_NOTDIR); do \
++ $(ABICHMOD) ugo=r $(CANONDIR)/$$k; \
++ done
+ @for k in $(CANON_SubDirs); do \
+ $(MAKE) ABI_ROOT=$(ABI_ROOT) -C $$k canonical; \
+ done
+@@ -63,6 +67,7 @@
+ unzip -o $$k; \
+ rm $$k; \
+ done)
++ @(cd $(CANONDIR)/dictionary; $(ABICHMOD) ugo=r *)
+ # (cd $(ABI_ROOT)/../abidistfiles; tar cf - dictionary/*.hash) | (cd $(CANONDIR); tar xf -)
+ ifeq ($(ABI_NATIVE),unix)
+ # each Unix installer requires both unixfonts and abidistfiles,
+@@ -92,10 +97,12 @@
+ fi
+ # icons for X window manager use
+ @$(subst xxxx,$(CANONDIR)/icons,$(VERIFY_DIRECTORY))
+- (cd $(ABI_ROOT)/../abidistfiles/icons; cp *_48* $(CANONDIR)/icons)
++ (cd $(ABI_ROOT)/../abidistfiles/icons; $(ABICOPY) *_48* $(CANONDIR)/icons)
++ @(cd $(CANONDIR)/icons; $(ABICHMOD) ugo=r *_48*)
+ # font stuff for installation
+ @$(subst xxxx,$(CANONDIR)/fonts,$(VERIFY_DIRECTORY))
+- (cd $(ABI_ROOT)/../unixfonts/fonts ; cp *.* $(CANONDIR)/fonts)
++ (cd $(ABI_ROOT)/../unixfonts/fonts ; $(ABICOPY) *.* $(CANONDIR)/fonts)
++ @(cd $(CANONDIR)/fonts; $(ABICHMOD) ugo=r *.*)
+ endif
+
+ ##################################################################
diff --git a/editors/abiword/files/patch-ap b/editors/abiword/files/patch-ap
new file mode 100644
index 00000000000..a006ac936e3
--- /dev/null
+++ b/editors/abiword/files/patch-ap
@@ -0,0 +1,22 @@
+--- wp/Makefile Tue Feb 29 07:34:31 2000
++++ wp/Makefile.new Sun May 14 21:15:19 2000
+@@ -44,10 +44,16 @@
+ @$(subst xxxx,$(CANON_AppDir),$(VERIFY_DIRECTORY))
+ @$(subst xxxx,$(CANON_AppDir)/strings,$(VERIFY_DIRECTORY))
+ @$(subst xxxx,$(CANON_AppDir)/help,$(VERIFY_DIRECTORY))
++ @$(subst xxxx,$(CANON_AppDir)/help/en-US,$(VERIFY_DIRECTORY))
+ @$(subst xxxx,$(CANON_AppDir)/sample,$(VERIFY_DIRECTORY))
++ @$(subst xxxx,$(CANON_AppDir)/sample/en-US,$(VERIFY_DIRECTORY))
+ @$(ABICOPY) $(USERDIR)/wp/readme.txt $(CANON_AppDir)
++ @$(ABICHMOD) ugo=r $(CANON_AppDir)/readme.txt
+ @$(ABICOPY) $(USERDIR)/wp/system.profile $(CANON_AppDir)
++ @$(ABICHMOD) ugo=r $(CANON_AppDir)/system.profile
+ @$(ABICOPY) $(USERDIR)/wp/strings/*.strings $(CANON_AppDir)/strings
+- (cd $(USERDIR)/wp/help; tar cf - $(CANON_Lang)/*.*) | (cd $(CANON_AppDir)/help; tar xf -)
+- (cd $(USERDIR)/wp/sample; tar cf - $(CANON_Lang)/*.*) | (cd $(CANON_AppDir)/sample; tar xf -)
+-
++ @$(ABICHMOD) ugo=r $(CANON_AppDir)/strings/*.strings
++ @$(ABICOPY) $(USERDIR)/wp/help/en-US/*.html $(CANON_AppDir)/help/en-US
++ @$(ABICHMOD) ugo=r $(CANON_AppDir)/help/en-US/*.html
++ @$(ABICOPY) $(USERDIR)/wp/sample/en-US/*.abw $(CANON_AppDir)/sample/en-US
++ @$(ABICHMOD) ugo=r $(CANON_AppDir)/sample/en-US/*.abw
diff --git a/editors/abiword/files/patch-aq b/editors/abiword/files/patch-aq
new file mode 100644
index 00000000000..c541d8b5d2f
--- /dev/null
+++ b/editors/abiword/files/patch-aq
@@ -0,0 +1,27 @@
+--- config/abi_defs.mk Mon Mar 13 14:48:16 2000
++++ config/abi_defs.mk.new Sat May 13 16:07:19 2000
+@@ -121,7 +121,9 @@
+ ##################################################################
+ ##################################################################
+
+-ABICOPY=cp
++ABICOPY = cp
++ABICHMOD = chmod
++ABIMKDIR = mkdir -m u=rwx,go=rx
+
+ ifdef ABISOURCE_LICENSED_TRADEMARKS
+ ABI_TMDEFS= -DABISOURCE_LICENSED_TRADEMARKS
+@@ -287,11 +289,11 @@
+ ## INSTALL program...
+
+ define MAKE_OBJDIR
+-if test ! -d $(@D); then rm -rf $(@D); mkdir -p $(@D); fi
++if test ! -d $(@D); then rm -rf $(@D); $(ABIMKDIR) -p $(@D); fi
+ endef
+
+ define VERIFY_DIRECTORY
+-if test ! -d xxxx; then rm -rf xxxx; mkdir -p xxxx; fi
++if test ! -d xxxx; then rm -rf xxxx; $(ABIMKDIR) -p xxxx; fi
+ endef
+
+ ##################################################################
diff --git a/editors/abiword/files/patch-ar b/editors/abiword/files/patch-ar
new file mode 100644
index 00000000000..1b319cafe8d
--- /dev/null
+++ b/editors/abiword/files/patch-ar
@@ -0,0 +1,11 @@
+--- pkg/common/unix/scripts/install.sh Tue Feb 29 13:37:57 2000
++++ pkg/common/unix/scripts/install.sh.new Sun May 14 18:11:15 2000
+@@ -80,7 +80,7 @@
+
+ echo "Installing program binaries to [$LIBEXECDIR]..."
+ # Setup bins
+-(cd $SRCDIR/bin; tar cf - Abi*) | (cd $LIBEXECDIR; tar xf -)
++(cd $SRCDIR/bin; cp Abi* $LIBEXECDIR)
+
+ ########################################################################
+ # If we're on Solaris, run makepsres on the font path